kmod: Enable xz support by default

Message ID 20220428062647.2717638-1-raj.khem@gmail.com
State Accepted, archived
Commit 20e9917b8d40f576b3661bc29e13602a24e86b7b
Headers show
Series kmod: Enable xz support by default | expand

Commit Message

Khem Raj April 28, 2022, 6:26 a.m. UTC
RPi kernel has started building compressed kernel modules by default
starting 5.15, currenrly therefore meta-raspberrypi kernels are unable
to load kernel modules since kmod and kmod-native do not entertain xz
compressed modules. There is a fix proposed in meta-raspberrypi [1]
but the fix is needed for native and nativesdk recipes as well, perhaps
its best to enable it here for best out of box experience with
meta-raspberrypi

[1] https://github.com/agherzan/meta-raspberrypi/pull/1056

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-kernel/kmod/kmod_29.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Andrei Gherzan April 28, 2022, 11:26 a.m. UTC | #1
On Thu, 28 Apr 2022, at 07:26, Khem Raj wrote:
> RPi kernel has started building compressed kernel modules by default
> starting 5.15, currenrly therefore meta-raspberrypi kernels are unable
> to load kernel modules since kmod and kmod-native do not entertain xz
> compressed modules. There is a fix proposed in meta-raspberrypi [1]
> but the fix is needed for native and nativesdk recipes as well, perhaps
> its best to enable it here for best out of box experience with
> meta-raspberrypi
>
> [1] https://github.com/agherzan/meta-raspberrypi/pull/1056
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>

I don't see any reason not to do this and it does help with the BSPs using this compression requirement. So here is my +1. Would it be reasonable to propose to have it in kirkstone too? Otherwise, @khem, I'd need to drop compression or downgrade the kernel in kirkstone rpi (or make some yocto incompatible changes - which I'd rather not).

Andrei
Khem Raj April 28, 2022, 3 p.m. UTC | #2
On Thu, Apr 28, 2022 at 4:27 AM Andrei Gherzan <andrei@gherzan.com> wrote:
>
> On Thu, 28 Apr 2022, at 07:26, Khem Raj wrote:
> > RPi kernel has started building compressed kernel modules by default
> > starting 5.15, currenrly therefore meta-raspberrypi kernels are unable
> > to load kernel modules since kmod and kmod-native do not entertain xz
> > compressed modules. There is a fix proposed in meta-raspberrypi [1]
> > but the fix is needed for native and nativesdk recipes as well, perhaps
> > its best to enable it here for best out of box experience with
> > meta-raspberrypi
> >
> > [1] https://github.com/agherzan/meta-raspberrypi/pull/1056
> >
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
>
> I don't see any reason not to do this and it does help with the BSPs using this compression requirement. So here is my +1. Would it be reasonable to propose to have it in kirkstone too? Otherwise, @khem, I'd need to drop compression or downgrade the kernel in kirkstone rpi (or make some yocto incompatible changes - which I'd rather not).
>

Its already in staging for master [1] so hope to land it in master
soon. kirkstone is something from Steve to cherry-pick CCing Steve
here

[1] https://git.yoctoproject.org/poky-contrib/log/?h=lucaceresoli/master-next
Steve Sakoman April 29, 2022, 6:24 p.m. UTC | #3
On Thu, Apr 28, 2022 at 5:00 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> On Thu, Apr 28, 2022 at 4:27 AM Andrei Gherzan <andrei@gherzan.com> wrote:
> >
> > On Thu, 28 Apr 2022, at 07:26, Khem Raj wrote:
> > > RPi kernel has started building compressed kernel modules by default
> > > starting 5.15, currenrly therefore meta-raspberrypi kernels are unable
> > > to load kernel modules since kmod and kmod-native do not entertain xz
> > > compressed modules. There is a fix proposed in meta-raspberrypi [1]
> > > but the fix is needed for native and nativesdk recipes as well, perhaps
> > > its best to enable it here for best out of box experience with
> > > meta-raspberrypi
> > >
> > > [1] https://github.com/agherzan/meta-raspberrypi/pull/1056
> > >
> > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> >
> > I don't see any reason not to do this and it does help with the BSPs using this compression requirement. So here is my +1. Would it be reasonable to propose to have it in kirkstone too? Otherwise, @khem, I'd need to drop compression or downgrade the kernel in kirkstone rpi (or make some yocto incompatible changes - which I'd rather not).
> >
>
> Its already in staging for master [1] so hope to land it in master
> soon. kirkstone is something from Steve to cherry-pick CCing Steve
> here
>
> [1] https://git.yoctoproject.org/poky-contrib/log/?h=lucaceresoli/master-next

It's hit master now, so I will cherry-pick into my next patch set.

Steve
Khem Raj April 29, 2022, 6:38 p.m. UTC | #4
On Fri, Apr 29, 2022 at 11:24 AM Steve Sakoman <steve@sakoman.com> wrote:
>
> On Thu, Apr 28, 2022 at 5:00 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > On Thu, Apr 28, 2022 at 4:27 AM Andrei Gherzan <andrei@gherzan.com> wrote:
> > >
> > > On Thu, 28 Apr 2022, at 07:26, Khem Raj wrote:
> > > > RPi kernel has started building compressed kernel modules by default
> > > > starting 5.15, currenrly therefore meta-raspberrypi kernels are unable
> > > > to load kernel modules since kmod and kmod-native do not entertain xz
> > > > compressed modules. There is a fix proposed in meta-raspberrypi [1]
> > > > but the fix is needed for native and nativesdk recipes as well, perhaps
> > > > its best to enable it here for best out of box experience with
> > > > meta-raspberrypi
> > > >
> > > > [1] https://github.com/agherzan/meta-raspberrypi/pull/1056
> > > >
> > > > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > >
> > > I don't see any reason not to do this and it does help with the BSPs using this compression requirement. So here is my +1. Would it be reasonable to propose to have it in kirkstone too? Otherwise, @khem, I'd need to drop compression or downgrade the kernel in kirkstone rpi (or make some yocto incompatible changes - which I'd rather not).
> > >
> >
> > Its already in staging for master [1] so hope to land it in master
> > soon. kirkstone is something from Steve to cherry-pick CCing Steve
> > here
> >
> > [1] https://git.yoctoproject.org/poky-contrib/log/?h=lucaceresoli/master-next
>
> It's hit master now, so I will cherry-pick into my next patch set.
>

thanks Steve.

> Steve

Patch

diff --git a/meta/recipes-kernel/kmod/kmod_29.bb b/meta/recipes-kernel/kmod/kmod_29.bb
index 9b663490666..32dc49c1269 100644
--- a/meta/recipes-kernel/kmod/kmod_29.bb
+++ b/meta/recipes-kernel/kmod/kmod_29.bb
@@ -27,7 +27,7 @@  S = "${WORKDIR}/git"
 
 EXTRA_OECONF += "--enable-tools"
 
-PACKAGECONFIG ??= "zlib"
+PACKAGECONFIG ??= "zlib xz"
 PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
 PACKAGECONFIG[logging] = " --enable-logging,--disable-logging"
 PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"