[11/26] python3-pytest-runner: Add from meta-oe/meta-python

Message ID 20220317115700.993924-12-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 3b8f5c823595ea8f375f89e9c30d534c217f160a
Headers show
Series Add support for sphinx documentation generation | expand

Commit Message

Richard Purdie March 17, 2022, 11:56 a.m. UTC
---
 .../python/python3-pytest-runner_5.3.1.bb         | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-pytest-runner_5.3.1.bb

Patch

diff --git a/meta/recipes-devtools/python/python3-pytest-runner_5.3.1.bb b/meta/recipes-devtools/python/python3-pytest-runner_5.3.1.bb
new file mode 100644
index 00000000000..fed2d91140f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest-runner_5.3.1.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
+
+SRC_URI[sha256sum] = "0fce5b8dc68760f353979d99fdd6b3ad46330b6b1837e2077a89ebcf204aac91"
+
+inherit pypi setuptools_build_meta
+
+DEPENDS += " \
+    ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+                  ${PYTHON_PN}-io"
+
+BBCLASSEXTEND = "native nativesdk"