[7/8] classes/flit_core: rename to python_flit_core

Message ID 20220316183243.876234-7-ross.burton@arm.com
State Accepted, archived
Commit c0e4ca3c7841028a658f21c11619228022d425b4
Headers show
Series [1/8] python3-packaging: remove duplicate python3-setuptools-native DEPENDS | expand

Commit Message

Ross Burton March 16, 2022, 6:32 p.m. UTC
To be more uniform with the other new Python classes, rename this to
python_flit_core and update the recipes that use it.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/classes/{flit_core.bbclass => python_flit_core.bbclass} | 2 +-
 meta/recipes-devtools/python/python3-flit-core_3.7.1.bb      | 2 +-
 meta/recipes-devtools/python/python3-installer_0.5.1.bb      | 2 +-
 meta/recipes-devtools/python/python3-tomli_2.0.1.bb          | 2 +-
 meta/recipes-devtools/python/python3-wheel_0.37.1.bb         | 2 +-
 5 files changed, 5 insertions(+), 5 deletions(-)
 rename meta/classes/{flit_core.bbclass => python_flit_core.bbclass} (84%)

Patch

diff --git a/meta/classes/flit_core.bbclass b/meta/classes/python_flit_core.bbclass
similarity index 84%
rename from meta/classes/flit_core.bbclass
rename to meta/classes/python_flit_core.bbclass
index 81fdf93e47..eef361bb1b 100644
--- a/meta/classes/flit_core.bbclass
+++ b/meta/classes/python_flit_core.bbclass
@@ -4,7 +4,7 @@  DEPENDS += "python3 python3-flit-core-native"
 
 PEP517_BUILD_API = "flit_core.buildapi"
 
-flit_core_do_configure () {
+python_flit_core_do_configure () {
     :
 }
 
diff --git a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
index dc815acf08..8d107384a6 100644
--- a/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
+++ b/meta/recipes-devtools/python/python3-flit-core_3.7.1.bb
@@ -10,7 +10,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
 
 SRC_URI[sha256sum] = "3c9bd9c140515bfe62dd938c6610d10d6efb9e35cc647fc614fe5fb3a5036682"
 
-inherit pypi flit_core
+inherit pypi python_flit_core
 
 # Need to install by hand as there's a dependency loop
 DEPENDS:remove:class-native = " python3-installer-native"
diff --git a/meta/recipes-devtools/python/python3-installer_0.5.1.bb b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
index 12d9fce249..f4f9e1bde6 100644
--- a/meta/recipes-devtools/python/python3-installer_0.5.1.bb
+++ b/meta/recipes-devtools/python/python3-installer_0.5.1.bb
@@ -10,7 +10,7 @@  SRC_URI += "file://interpreter.patch"
 
 SRC_URI[sha256sum] = "f970995ec2bb815e2fdaf7977b26b2091e1e386f0f42eafd5ac811953dc5d445"
 
-inherit pypi flit_core
+inherit pypi python_flit_core
 
 DEPENDS:remove:class-native = "python3-installer-native"
 DEPENDS:append:class-native = " unzip-native"
diff --git a/meta/recipes-devtools/python/python3-tomli_2.0.1.bb b/meta/recipes-devtools/python/python3-tomli_2.0.1.bb
index f8b423bbef..6118a6a9c3 100644
--- a/meta/recipes-devtools/python/python3-tomli_2.0.1.bb
+++ b/meta/recipes-devtools/python/python3-tomli_2.0.1.bb
@@ -6,7 +6,7 @@  BUGTRACKER = "https://github.com/hukkin/tomli/issues"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5"
 
-inherit pypi flit_core
+inherit pypi python_flit_core
 
 SRC_URI[sha256sum] = "de526c12914f0c550d15924c62d72abc48d6fe7364aa87328337a31007fe8a4f"
 
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index efd6c2f968..2f7dd122ba 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a01
 
 SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
 
-inherit flit_core pypi
+inherit python_flit_core pypi
 
 SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"