python3-pyparsing: rdepends on python3-html

Message ID 20220316022841.34226-1-kai.kang@windriver.com
State Accepted, archived
Commit bfc76d19f3d6e3a7b2d91c3fcd97501c8b29001e
Headers show
Series python3-pyparsing: rdepends on python3-html | expand

Commit Message

Kai March 16, 2022, 2:28 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

It fails to import python module 'pyparsing':

| root@qemux86-64:~# python3 -c 'import pyparsing'
| Traceback (most recent call last):
|   File "<string>", line 1, in <module>
|   File "/usr/lib64/python3.10/site-packages/pyparsing/__init__.py", line 141, in <module>
|     from .helpers import *
|   File "/usr/lib64/python3.10/site-packages/pyparsing/helpers.py", line 2, in <module>
|     import html.entities
| ModuleNotFoundError: No module named 'html'

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta/recipes-devtools/python/python3-pyparsing_3.0.7.bb | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta/recipes-devtools/python/python3-pyparsing_3.0.7.bb b/meta/recipes-devtools/python/python3-pyparsing_3.0.7.bb
index 14faea6590..9c3896918f 100644
--- a/meta/recipes-devtools/python/python3-pyparsing_3.0.7.bb
+++ b/meta/recipes-devtools/python/python3-pyparsing_3.0.7.bb
@@ -19,6 +19,7 @@  inherit pypi setuptools3
 RDEPENDS:${PN} += " \
     ${PYTHON_PN}-datetime \
     ${PYTHON_PN}-debugger \
+    ${PYTHON_PN}-html \
     ${PYTHON_PN}-json \
     ${PYTHON_PN}-netclient \
     ${PYTHON_PN}-pprint \