openssl: upgrade to 3.0.2

Message ID 20220315172545.722902-1-ross.burton@arm.com
State Accepted, archived
Commit 30f054a1e0afaa26d16a411df2a6310104342e63
Headers show
Series openssl: upgrade to 3.0.2 | expand

Commit Message

Ross Burton March 15, 2022, 5:25 p.m. UTC
From: Ross Burton <ross@burtonini.com>

  * Fixed a bug in the BN_mod_sqrt() function that can cause it to loop forever
    for non-prime moduli ([CVE-2022-0778])

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../openssl/openssl/reproducibility.patch     | 22 -------------------
 .../{openssl_3.0.1.bb => openssl_3.0.2.bb}    |  3 +--
 2 files changed, 1 insertion(+), 24 deletions(-)
 delete mode 100644 meta/recipes-connectivity/openssl/openssl/reproducibility.patch
 rename meta/recipes-connectivity/openssl/{openssl_3.0.1.bb => openssl_3.0.2.bb} (98%)

Patch

diff --git a/meta/recipes-connectivity/openssl/openssl/reproducibility.patch b/meta/recipes-connectivity/openssl/openssl/reproducibility.patch
deleted file mode 100644
index 8accbc9df2..0000000000
--- a/meta/recipes-connectivity/openssl/openssl/reproducibility.patch
+++ /dev/null
@@ -1,22 +0,0 @@ 
-Using localtime() means the output can depend on the timezone of the build machine.
-Using gmtime() is safer. For complete reproducibility use SOURCE_DATE_EPOCH if set.
-
-Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-Upstream-Status: Pending [should be suitable]
-
-Index: openssl-3.0.1/apps/progs.pl
-===================================================================
---- openssl-3.0.1.orig/apps/progs.pl
-+++ openssl-3.0.1/apps/progs.pl
-@@ -21,7 +21,10 @@ die "Unrecognised option, must be -C or
- my %commands     = ();
- my $cmdre        = qr/^\s*int\s+([a-z_][a-z0-9_]*)_main\(\s*int\s+argc\s*,/;
- my $apps_openssl = shift @ARGV;
--my $YEAR         = [localtime()]->[5] + 1900;
-+my $YEAR         = [gmtime()]->[5] + 1900;
-+if (defined($ENV{SOURCE_DATE_EPOCH}) && $ENV{SOURCE_DATE_EPOCH} !~ /\D/) {
-+    $YEAR = [gmtime($ENV{SOURCE_DATE_EPOCH})]->[5] + 1900;
-+}
- 
- # because the program apps/openssl has object files as sources, and
- # they then have the corresponding C files as source, we need to chain
diff --git a/meta/recipes-connectivity/openssl/openssl_3.0.1.bb b/meta/recipes-connectivity/openssl/openssl_3.0.2.bb
similarity index 98%
rename from meta/recipes-connectivity/openssl/openssl_3.0.1.bb
rename to meta/recipes-connectivity/openssl/openssl_3.0.2.bb
index 1128f6a737..ff2a22c6c3 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.0.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.0.2.bb
@@ -12,14 +12,13 @@  SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
            file://0001-buildinfo-strip-sysroot-and-debug-prefix-map-from-co.patch \
            file://afalg.patch \
            file://0001-Configure-do-not-tweak-mips-cflags.patch \
-           file://reproducibility.patch \
            "
 
 SRC_URI:append:class-nativesdk = " \
            file://environment.d-openssl.sh \
            "
 
-SRC_URI[sha256sum] = "c311ad853353bce796edad01a862c50a8a587f62e7e2100ef465ab53ec9b06d1"
+SRC_URI[sha256sum] = "98e91ccead4d4756ae3c9cde5e09191a8e586d9f4d50838e7ec09d6411dfdb63"
 
 inherit lib_package multilib_header multilib_script ptest perlnative
 MULTILIB_SCRIPTS = "${PN}-bin:${bindir}/c_rehash"