[2/2] webkitgtk: Fix build when x11 is not in distro features

Message ID 20220309170752.2892032-2-raj.khem@gmail.com
State Accepted, archived
Commit 4f6b987705a624da3304cb559b885c4352f9b517
Headers show
Series [v2,1/2] qemu: Fix build when x11 is not in distro features | expand

Commit Message

Khem Raj March 9, 2022, 5:07 p.m. UTC
ANGLE's copy of khrplatform.h is not uptodate with mesa/khronos khrplatform.h
which uses MESA_EGL_NO_X11_HEADERS which is now renamed in newer headers to
EGL_NO_X11 from mesa/khronos headers, however this define is
relatively new and 3D stacks do not have this adopted but apps
like qemu and bunch of others depend on it, I guess they assume mesa.
One can argue that its better to fix the 3D stacks to behave
like mesa but this means every BSP using these stacks will need to
carry such a fix.

https://gitlab.freedesktop.org/mesa/mesa/-/blob/main/include/EGL/eglplatform.h

This patch helps with that

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-sato/webkit/webkitgtk_2.34.6.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-sato/webkit/webkitgtk_2.34.6.bb b/meta/recipes-sato/webkit/webkitgtk_2.34.6.bb
index 8cea8a86000..6870eed5259 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.34.6.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.34.6.bb
@@ -98,6 +98,9 @@  EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
 CFLAGS:append:arc = " -mlong-calls"
 CXXFLAGS:append:arc = " -mlong-calls"
 
+# Needed for non-mesa graphics stacks when x11 is disabled
+CXXFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
+
 # Javascript JIT is not supported on powerpc
 EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
 EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "