[3/7] python3-wheel: clean up PYPA_WHEEL usage

Message ID 20220308163206.4039089-3-ross.burton@arm.com
State Accepted, archived
Commit e2c7501645eec12d3168b6e8606549ce3e5f8db2
Headers show
Series [1/7] python3-pip: clean up PYPA_WHEEL usage | expand

Commit Message

Ross Burton March 8, 2022, 4:32 p.m. UTC
Remove the use of PYPA_WHEEL in the native do_install() as this variable
will be disappearing shortly.

Remove the bbfatal_log in the native do_install(), if this breaks then
something has gone very wrong and the user is not expected to fix it.

Also flit_core inherits setuptools3-base, so no need to inherit it again.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-wheel_0.37.1.bb | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
index 91bff82509..83a7c986a8 100644
--- a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a01
 
 SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
 
-inherit flit_core pypi setuptools3-base
+inherit flit_core pypi
 
 SRC_URI += " file://0001-Backport-pyproject.toml-from-flit-backend-branch.patch"
 
@@ -15,9 +15,7 @@  DEPENDS:remove:class-native = "python3-pip-native"
 do_install:class-native () {
     # We need to bootstrap python3-wheel-native
     install -d ${D}${PYTHON_SITEPACKAGES_DIR}
-    PYPA_WHEEL="${B}/dist/${PYPI_PACKAGE}-${PV}-*.whl"
-    unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PYPA_WHEEL} || \
-    bbfatal_log "Failed to install"
+    unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PIP_INSTALL_DIST_PATH}/*.whl
 
     # pip install would normally generate [project.scripts] in ${bindir}
     install -d ${D}/${bindir}
@@ -37,4 +35,3 @@  EOF
 }
 
 BBCLASSEXTEND = "native nativesdk"
-