python3-flit-core: inherit pip_install_wheel

Message ID 20220224234514.2761033-1-tim.orling@konsulko.com
State Accepted, archived
Commit 200ae6b4d54c7235e0a96e2dd4bba1cdd68bd14f
Headers show
Series python3-flit-core: inherit pip_install_wheel | expand

Commit Message

Tim Orling Feb. 24, 2022, 11:45 p.m. UTC
Keep the pip install logic, especially --root in one place to ensure
that we fix e.g. reproducible issues in one place.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../python/python3-flit-core_3.6.0.bb               | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-flit-core_3.6.0.bb b/meta/recipes-devtools/python/python3-flit-core_3.6.0.bb
index 6dfacafd31c..a00ea1810e3 100644
--- a/meta/recipes-devtools/python/python3-flit-core_3.6.0.bb
+++ b/meta/recipes-devtools/python/python3-flit-core_3.6.0.bb
@@ -10,24 +10,21 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
 
 SRC_URI[sha256sum] = "b1464e006df4df4c8eeb37671c0e0ce66e1d04e4a36d91b702f180a25fde3c11"
 
-inherit python3native python3-dir pypi setuptools3-base
+inherit pip_install_wheel python3native python3-dir pypi setuptools3-base
 
-DEPENDS:append:class-target = " python3-pip-native"
+DEPENDS:remove:class-native = " python3-pip-native"
 DEPENDS:append:class-native = " unzip-native"
 
 # We need the full flit tarball
 PYPI_PACKAGE = "flit"
 
+PIP_INSTALL_PACKAGE = "flit_core"
+PIP_INSTALL_DIST_PATH = "${S}/flit_core/dist"
+
 do_compile () {
     nativepython3 flit_core/build_dists.py
 }
 
-do_install () {
-    install -d ${D}${PYTHON_SITEPACKAGES_DIR}
-    PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR} \
-    nativepython3 -m pip install -vvvv --no-deps --no-index --target ${D}${PYTHON_SITEPACKAGES_DIR} ./flit_core/dist/flit_core-${PV}-py3-none-any.whl
-}
-
 do_install:class-native () {
     install -d ${D}${PYTHON_SITEPACKAGES_DIR}
     unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ./flit_core/dist/flit_core-${PV}-py3-none-any.whl