systemd: move systemd shared library into its own package

Message ID 20220223155954.11408-1-stefan.herbrechtsmeier-oss@weidmueller.com
State Accepted, archived
Commit d1473149816674e3a3aa3f565e8b6390d2d0f1a6
Headers show
Series systemd: move systemd shared library into its own package | expand

Commit Message

Stefan Herbrechtsmeier Feb. 23, 2022, 3:59 p.m. UTC
From: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com>

Move the systemd shared library (libsystemd-shared.so) into its own
package to prevent a runtime dependency from udev package to systemd
package and thereby to a second init manager.

Signed-off-by: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com>

---

 meta/recipes-core/systemd/systemd_250.3.bb | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Konrad Weihmann Feb. 23, 2022, 4:04 p.m. UTC | #1
On 23.02.22 16:59, Stefan Herbrechtsmeier wrote:
> From: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com>
> 
> Move the systemd shared library (libsystemd-shared.so) into its own
> package to prevent a runtime dependency from udev package to systemd
> package and thereby to a second init manager.
> 
> Signed-off-by: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com>
> 
> ---
> 
>   meta/recipes-core/systemd/systemd_250.3.bb | 5 +++++
>   1 file changed, 5 insertions(+)
> 
> diff --git a/meta/recipes-core/systemd/systemd_250.3.bb b/meta/recipes-core/systemd/systemd_250.3.bb
> index 9121333f56..43ac66da62 100644
> --- a/meta/recipes-core/systemd/systemd_250.3.bb
> +++ b/meta/recipes-core/systemd/systemd_250.3.bb
> @@ -371,6 +371,7 @@ PACKAGE_BEFORE_PN = "\
>       ${PN}-journal-remote \
>       ${PN}-extra-utils \
>       ${PN}-udev-rules \
> +    libsystemd-shared \
>       udev \
>       udev-hwdb \
>   "
> @@ -387,6 +388,8 @@ DESCRIPTION:${PN}-journal-upload = "systemd-journal-upload uploads journal entri
>   SUMMARY:${PN}-journal-remote = "Receive journal messages over the network"
>   DESCRIPTION:${PN}-journal-remote = "systemd-journal-remote is a command to receive serialized journal events and store them to journal files."
>   
> +SUMMARY:${PN}-container = "Systemd shared library"

That doesn't look right to me - shouldn't that be SUMMARY:libsystemd-shared?

> +
>   SYSTEMD_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'binfmt', '${PN}-binfmt', '', d)} \
>                       ${@bb.utils.contains('PACKAGECONFIG', 'microhttpd', '${PN}-journal-gatewayd', '', d)} \
>                       ${@bb.utils.contains('PACKAGECONFIG', 'microhttpd', '${PN}-journal-remote', '', d)} \
> @@ -654,6 +657,8 @@ INSANE_SKIP:${PN} += "dev-so libdir"
>   INSANE_SKIP:${PN}-dbg += "libdir"
>   INSANE_SKIP:${PN}-doc += " libdir"
>   
> +FILES:libsystemd-shared = "${rootlibexecdir}/systemd/libsystemd-shared*.so"
> +
>   RPROVIDES:udev = "hotplug"
>   
>   RDEPENDS:udev-hwdb += "udev"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#162267): https://lists.openembedded.org/g/openembedded-core/message/162267
> Mute This Topic: https://lists.openembedded.org/mt/89343939/3647476
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [kweihmann@outlook.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Stefan Herbrechtsmeier Feb. 23, 2022, 4:18 p.m. UTC | #2
Am 23.02.2022 um 17:04 schrieb Konrad Weihmann:
> On 23.02.22 16:59, Stefan Herbrechtsmeier wrote:
>> From: Stefan Herbrechtsmeier <stefan.herbrechtsmeier@weidmueller.com>
>>
>> Move the systemd shared library (libsystemd-shared.so) into its own
>> package to prevent a runtime dependency from udev package to systemd
>> package and thereby to a second init manager.
>>
>> Signed-off-by: Stefan Herbrechtsmeier 
>> <stefan.herbrechtsmeier@weidmueller.com>
>>
>> ---
>>
>>   meta/recipes-core/systemd/systemd_250.3.bb | 5 +++++
>>   1 file changed, 5 insertions(+)
>>
>> diff --git a/meta/recipes-core/systemd/systemd_250.3.bb 
>> b/meta/recipes-core/systemd/systemd_250.3.bb
>> index 9121333f56..43ac66da62 100644
>> --- a/meta/recipes-core/systemd/systemd_250.3.bb
>> +++ b/meta/recipes-core/systemd/systemd_250.3.bb
>> @@ -371,6 +371,7 @@ PACKAGE_BEFORE_PN = "\
>>       ${PN}-journal-remote \
>>       ${PN}-extra-utils \
>>       ${PN}-udev-rules \
>> +    libsystemd-shared \
>>       udev \
>>       udev-hwdb \
>>   "
>> @@ -387,6 +388,8 @@ DESCRIPTION:${PN}-journal-upload = 
>> "systemd-journal-upload uploads journal entri
>>   SUMMARY:${PN}-journal-remote = "Receive journal messages over the 
>> network"
>>   DESCRIPTION:${PN}-journal-remote = "systemd-journal-remote is a 
>> command to receive serialized journal events and store them to journal 
>> files."
>> +SUMMARY:${PN}-container = "Systemd shared library"
> 
> That doesn't look right to me - shouldn't that be 
> SUMMARY:libsystemd-shared?

Thanks. I have fix the copy paste error and send a new version.

Patch

diff --git a/meta/recipes-core/systemd/systemd_250.3.bb b/meta/recipes-core/systemd/systemd_250.3.bb
index 9121333f56..43ac66da62 100644
--- a/meta/recipes-core/systemd/systemd_250.3.bb
+++ b/meta/recipes-core/systemd/systemd_250.3.bb
@@ -371,6 +371,7 @@  PACKAGE_BEFORE_PN = "\
     ${PN}-journal-remote \
     ${PN}-extra-utils \
     ${PN}-udev-rules \
+    libsystemd-shared \
     udev \
     udev-hwdb \
 "
@@ -387,6 +388,8 @@  DESCRIPTION:${PN}-journal-upload = "systemd-journal-upload uploads journal entri
 SUMMARY:${PN}-journal-remote = "Receive journal messages over the network"
 DESCRIPTION:${PN}-journal-remote = "systemd-journal-remote is a command to receive serialized journal events and store them to journal files."
 
+SUMMARY:${PN}-container = "Systemd shared library"
+
 SYSTEMD_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'binfmt', '${PN}-binfmt', '', d)} \
                     ${@bb.utils.contains('PACKAGECONFIG', 'microhttpd', '${PN}-journal-gatewayd', '', d)} \
                     ${@bb.utils.contains('PACKAGECONFIG', 'microhttpd', '${PN}-journal-remote', '', d)} \
@@ -654,6 +657,8 @@  INSANE_SKIP:${PN} += "dev-so libdir"
 INSANE_SKIP:${PN}-dbg += "libdir"
 INSANE_SKIP:${PN}-doc += " libdir"
 
+FILES:libsystemd-shared = "${rootlibexecdir}/systemd/libsystemd-shared*.so"
+
 RPROVIDES:udev = "hotplug"
 
 RDEPENDS:udev-hwdb += "udev"