sudo: add /etc/sudoers to sudo-lib conffiles

Message ID 20220222234457.2211495-1-alex.stewart@ni.com
State Accepted, archived
Commit 7d688f0ece8fa7e3118cde0c79bbcc56048a2bb5
Headers show
Series sudo: add /etc/sudoers to sudo-lib conffiles | expand

Commit Message

Alex Stewart Feb. 22, 2022, 11:44 p.m. UTC
When OE-core commit 788c95c3bb8ede0d3d6a8f125743ac47c0b3f00e created the
`sudo-lib` subpackage, /etc/sudoers was moved from `sudo` to `sudo-lib`.
The commit didn't update the `CONFFILES:${PN}` assignment in sudo.inc,
however. So the `sudo` base package continued to advertise conffile
ownership of /etc/sudoers, though it did not contain it.

Move the CONFFILES assignment to the sudo.bb file, since it is
packaging-related. Change the package owner to the `sudo-lib`
subpackage, since it is the rightful file-owner.

Signed-off-by: Alex Stewart <alex.stewart@ni.com>
---
 meta/recipes-extended/sudo/sudo.inc      | 2 --
 meta/recipes-extended/sudo/sudo_1.9.9.bb | 2 ++
 2 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-extended/sudo/sudo.inc b/meta/recipes-extended/sudo/sudo.inc
index 05d030c2e9f176d63f3f5c5d44321db9729b7983..8947c46129f53e819f62ca6a27fba238babce88f 100644
--- a/meta/recipes-extended/sudo/sudo.inc
+++ b/meta/recipes-extended/sudo/sudo.inc
@@ -24,8 +24,6 @@  PACKAGECONFIG ??= ""
 PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
 PACKAGECONFIG[pam-wheel] = ",,,pam-plugin-wheel"
 
-CONFFILES:${PN} = "${sysconfdir}/sudoers"
-
 EXTRA_OECONF = "--with-editor=${base_bindir}/vi --with-env-editor"
 
 EXTRA_OECONF:append:libc-musl = " --disable-hardening "
diff --git a/meta/recipes-extended/sudo/sudo_1.9.9.bb b/meta/recipes-extended/sudo/sudo_1.9.9.bb
index f1c0339bb3be7fd48798ceb65a0dbcb0f2da63ea..d7d71bb3643ed94f5e4a5d2a2d9f4d2ff68a8f70 100644
--- a/meta/recipes-extended/sudo/sudo_1.9.9.bb
+++ b/meta/recipes-extended/sudo/sudo_1.9.9.bb
@@ -48,6 +48,8 @@  do_install:append () {
 FILES:${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/*.la \
                     ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la"
 
+CONFFILES:${PN}-lib = "${sysconfdir}/sudoers"
+
 SUDO_PACKAGES = "${PN}-sudo\
                  ${PN}-lib"