curl: configure with '--without-ssl' if ssl is disabled

Message ID 20220215125456.13686-1-ceggers@arri.de
State Accepted, archived
Commit 6c737396c705e1388aff5f5a599c901a1a1760a2
Headers show
Series curl: configure with '--without-ssl' if ssl is disabled | expand

Commit Message

Christian Eggers Feb. 15, 2022, 12:54 p.m. UTC
curl requires that at least one SSL implementation or explicitly
'--without-ssl' is specified. This is particularly the case if
PACKAGECONFIG is empty.

| configure: error: select TLS backend(s) or disable TLS with
--without-ssl.
|
| Select from these:
|
|   --with-amissl
|   --with-bearssl
|   --with-gnutls
|   --with-mbedtls
|   --with-mesalink
|   --with-nss
|   --with-openssl (also works for BoringSSL and libressl)
|   --with-rustls
|   --with-schannel
|   --with-secure-transport
|   --with-wolfssl
|

Fixes: eef6c45fc6ec ("curl: Rework openssl and random PACKAGECONFIGs")
Signed-off-by: Christian Eggers <ceggers@arri.de>
---
 meta/recipes-support/curl/curl_7.81.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Robert Joslyn Feb. 15, 2022, 3:12 p.m. UTC | #1
> On Feb 15, 2022, at 4:54 AM, Christian Eggers <ceggers@arri.de> wrote:
> 
> curl requires that at least one SSL implementation or explicitly
> '--without-ssl' is specified. This is particularly the case if
> PACKAGECONFIG is empty.
> 
> | configure: error: select TLS backend(s) or disable TLS with
> --without-ssl.
> |
> | Select from these:
> |
> |   --with-amissl
> |   --with-bearssl
> |   --with-gnutls
> |   --with-mbedtls
> |   --with-mesalink
> |   --with-nss
> |   --with-openssl (also works for BoringSSL and libressl)
> |   --with-rustls
> |   --with-schannel
> |   --with-secure-transport
> |   --with-wolfssl
> |
> 
> Fixes: eef6c45fc6ec ("curl: Rework openssl and random PACKAGECONFIGs")
> Signed-off-by: Christian Eggers <ceggers@arri.de>
> ---
> meta/recipes-support/curl/curl_7.81.0.bb | 1 +
> 1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-support/curl/curl_7.81.0.bb b/meta/recipes-support/curl/curl_7.81.0.bb
> index c22a13cfea3f..e7219def18d8 100644
> --- a/meta/recipes-support/curl/curl_7.81.0.bb
> +++ b/meta/recipes-support/curl/curl_7.81.0.bb
> @@ -67,6 +67,7 @@ EXTRA_OECONF = " \
>     --enable-debug \
>     --enable-optimize \
>     --disable-curldebug \
> +    ${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls nss openssl', d) == '') else ''} \
> "
> 
> do_install:append:class-target() {
> -- 
> 2.34.1

Somehow I didn’t have an empty PACKAGECONFIG in my test set. I do now!

Tested-by: Robert Joslyn <robert.joslyn@redrectangle.org>

Patch

diff --git a/meta/recipes-support/curl/curl_7.81.0.bb b/meta/recipes-support/curl/curl_7.81.0.bb
index c22a13cfea3f..e7219def18d8 100644
--- a/meta/recipes-support/curl/curl_7.81.0.bb
+++ b/meta/recipes-support/curl/curl_7.81.0.bb
@@ -67,6 +67,7 @@  EXTRA_OECONF = " \
     --enable-debug \
     --enable-optimize \
     --disable-curldebug \
+    ${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls nss openssl', d) == '') else ''} \
 "
 
 do_install:append:class-target() {