seatd: build systemd backend if DISTRO_FEATURE systemd is set

Message ID 20220208164259.4017-1-f_l_k@t-online.de
State Accepted, archived
Commit c659e7468686b8f6995cdc01dd0dbe0e84946bf6
Headers show
Series seatd: build systemd backend if DISTRO_FEATURE systemd is set | expand

Commit Message

Markus Volk Feb. 8, 2022, 4:42 p.m. UTC
Add libsystemd dependency if we have systemd in DISTRO_FEATURES.
This is needed to build the systemd backend. Projects that use seatd
to hook into logind (e.g. wlroots) fail to properly login without it.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-core/seatd/seatd_0.6.3.bb | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-core/seatd/seatd_0.6.3.bb b/meta/recipes-core/seatd/seatd_0.6.3.bb
index 0e1a79dddf..abc8583087 100644
--- a/meta/recipes-core/seatd/seatd_0.6.3.bb
+++ b/meta/recipes-core/seatd/seatd_0.6.3.bb
@@ -13,9 +13,13 @@  S = "${WORKDIR}/git"
 
 inherit meson pkgconfig update-rc.d
 
-PACKAGECONFIG ?= "libseat-builtin"
+PACKAGECONFIG ?= " \
+	${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+	libseat-builtin \
+"
 
 PACKAGECONFIG[libseat-builtin] = "-Dlibseat-builtin=enabled,-Dlibseat-builtin=disabled"
+PACKAGECONFIG[systemd] = ",,systemd"
 
 do_install:append() {
         if [ "${VIRTUAL-RUNTIME_init_manager}" != "systemd" ]; then
@@ -26,4 +30,3 @@  do_install:append() {
 INITSCRIPT_NAME = "seatd"
 INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
 INHIBIT_UPDATERCD_BBCLASS = "${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', '1', '', d)}"
-