[dunfell] rpm: fix intermittent compression failure in do_package_write_rpm

Message ID 20220208034149.399705-1-bkylerussell@gmail.com
State Accepted, archived
Commit b093005d31467d89b00af621f86eb5cac7f845af
Headers show
Series [dunfell] rpm: fix intermittent compression failure in do_package_write_rpm | expand

Commit Message

Kyle Russell Feb. 8, 2022, 3:41 a.m. UTC
rpmbuild can start processing random memory when processing the value
provided by XZ_THREADS, and unintentionally disable encoding for a
file descriptor that in fact requires encoding to be enabled in order
for lzwrite() to actually create an rpm.

  *** Fdopen(0x7f2030002b30,w6T16.xzdio)  | fdio 23 fp (nil)
  ==>     lzopen_internal("w6T16", 23, 1)
  ==>     lzopen_internal set encoding
  ==>     lzopen_internal clear encoding
  ==> Fdopen(0x7f2030002b30,"w6T16.xzdio") returns fd 0x7f2030002b30      | xzdio 0x7f2030004e30 fp 23 | fdio -1 fp (nil)
  ==>     lzwrite(0x7f2030004e30, 0x7f20789d8070, 6) encoding 0
  ==>     Fwrite(0x7f2030002b30,0x7f20789d8070,6) rc -1   | xzdio 0x7f2030004e30 fp 23 | fdio -1 fp (nil)
  error: create archive failed: cpio: write

When the encoding bit gets cleared on the LZFILE* struct, lzwrite() then
rightfully complains when it detects !lzfile->encoding, which then gets
bubbled up as a write failure when we go to create the archive.

This fix is available in the rpm 4.17-release.

Upstream-Status: Backport [https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276]
---
 ..._internal-mode-parsing-when-Tn-is-us.patch | 31 +++++++++++++++++++
 meta/recipes-devtools/rpm/rpm_4.14.2.1.bb     |  1 +
 2 files changed, 32 insertions(+)
 create mode 100644 meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch

Comments

Jose Quaresma Feb. 8, 2022, 10:09 a.m. UTC | #1
Hi,

<bkylerussell@gmail.com> escreveu no dia terça, 8/02/2022 à(s) 03:42:

> rpmbuild can start processing random memory when processing the value
> provided by XZ_THREADS, and unintentionally disable encoding for a
> file descriptor that in fact requires encoding to be enabled in order
> for lzwrite() to actually create an rpm.
>
>   *** Fdopen(0x7f2030002b30,w6T16.xzdio)  | fdio 23 fp (nil)
>   ==>     lzopen_internal("w6T16", 23, 1)
>   ==>     lzopen_internal set encoding
>   ==>     lzopen_internal clear encoding
>   ==> Fdopen(0x7f2030002b30,"w6T16.xzdio") returns fd 0x7f2030002b30
> | xzdio 0x7f2030004e30 fp 23 | fdio -1 fp (nil)
>   ==>     lzwrite(0x7f2030004e30, 0x7f20789d8070, 6) encoding 0
>   ==>     Fwrite(0x7f2030002b30,0x7f20789d8070,6) rc -1   | xzdio
> 0x7f2030004e30 fp 23 | fdio -1 fp (nil)
>   error: create archive failed: cpio: write
>
> When the encoding bit gets cleared on the LZFILE* struct, lzwrite() then
> rightfully complains when it detects !lzfile->encoding, which then gets
> bubbled up as a write failure when we go to create the archive.
>
> This fix is available in the rpm 4.17-release.
>
> Upstream-Status: Backport [
> https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276
> ]
>

-Upstream-Status: Backport [
https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276
]
+Signed-off-by: your@mail

Upstream-Status need to be placed on the patch an not on the commit message

---
>  ..._internal-mode-parsing-when-Tn-is-us.patch | 31 +++++++++++++++++++
>  meta/recipes-devtools/rpm/rpm_4.14.2.1.bb     |  1 +
>  2 files changed, 32 insertions(+)
>  create mode 100644
> meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
>
> diff --git
> a/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
> b/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
> new file mode 100644
> index 0000000000..52110fa2b1
> --- /dev/null
> +++
> b/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
> @@ -0,0 +1,31 @@
> +From 405fc8998181353bd510864ca251dc233afec276 Mon Sep 17 00:00:00 2001
> +From: Vitaly Chikunov <vt@altlinux.org>
> +Date: Wed, 6 Jan 2021 23:43:41 +0300
> +Subject: [PATCH] rpmio: Fix lzopen_internal mode parsing when 'Tn' is used
> +
> +When there is number after "T" (suggested number of threads or "0" for
> +getncpus), lzopen_internal() mode parser would skip one byte, and when
> +it's at the end of the string it would then parse undesired garbage from
> +the memory, making intermittent compression failures.
> +
> +Fixes: 7740d1098 ("Add support for multithreaded xz compression")
> +Signed-off-by: Vitaly Chikunov <vt@altlinux.org>
>

+Upstream-Status: Backport [
https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276
]


> +---
> + rpmio/rpmio.c | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/rpmio/rpmio.c b/rpmio/rpmio.c
> +index ed1e25140..9d32ec6d9 100644
> +--- a/rpmio/rpmio.c
> ++++ b/rpmio/rpmio.c
> +@@ -798,6 +798,7 @@ static LZFILE *lzopen_internal(const char *mode, int
> fd, int xz)
> +                * should've processed
> +                * */
> +               while (isdigit(*++mode));
> ++              --mode;
> +           }
> + #ifdef HAVE_LZMA_MT
> +           else
> +--
> +2.25.1
> +
> diff --git a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
> b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
> index c39a5208e5..376021d913 100644
> --- a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
> +++ b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
> @@ -44,6 +44,7 @@ SRC_URI = "git://
> github.com/rpm-software-management/rpm;branch=rpm-4.14.x;protoc
>
> file://0001-mono-find-provides-requires-do-not-use-monodis-from-.patch \
>
> file://0001-Rip-out-partial-support-for-unused-MD2-and-RIPEMD160.patch \
>             file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
> +
>  file://0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch \
>             file://CVE-2021-3421.patch \
>             file://CVE-2021-20266.patch \
>             "
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#161472):
> https://lists.openembedded.org/g/openembedded-core/message/161472
> Mute This Topic: https://lists.openembedded.org/mt/88989796/5052612
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Kyle Russell Feb. 8, 2022, 12:13 p.m. UTC | #2
Ok, sorry about that.  I can fixup and resend.

On Tue, Feb 8, 2022 at 5:09 AM Jose Quaresma <quaresma.jose@gmail.com>
wrote:

> Hi,
>
> <bkylerussell@gmail.com> escreveu no dia terça, 8/02/2022 à(s) 03:42:
>
>> rpmbuild can start processing random memory when processing the value
>> provided by XZ_THREADS, and unintentionally disable encoding for a
>> file descriptor that in fact requires encoding to be enabled in order
>> for lzwrite() to actually create an rpm.
>>
>>   *** Fdopen(0x7f2030002b30,w6T16.xzdio)  | fdio 23 fp (nil)
>>   ==>     lzopen_internal("w6T16", 23, 1)
>>   ==>     lzopen_internal set encoding
>>   ==>     lzopen_internal clear encoding
>>   ==> Fdopen(0x7f2030002b30,"w6T16.xzdio") returns fd 0x7f2030002b30
>> | xzdio 0x7f2030004e30 fp 23 | fdio -1 fp (nil)
>>   ==>     lzwrite(0x7f2030004e30, 0x7f20789d8070, 6) encoding 0
>>   ==>     Fwrite(0x7f2030002b30,0x7f20789d8070,6) rc -1   | xzdio
>> 0x7f2030004e30 fp 23 | fdio -1 fp (nil)
>>   error: create archive failed: cpio: write
>>
>> When the encoding bit gets cleared on the LZFILE* struct, lzwrite() then
>> rightfully complains when it detects !lzfile->encoding, which then gets
>> bubbled up as a write failure when we go to create the archive.
>>
>> This fix is available in the rpm 4.17-release.
>>
>> Upstream-Status: Backport [
>> https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276
>> ]
>>
>
> -Upstream-Status: Backport [
> https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276
> ]
> +Signed-off-by: your@mail
>
> Upstream-Status need to be placed on the patch an not on the commit message
>
> ---
>>  ..._internal-mode-parsing-when-Tn-is-us.patch | 31 +++++++++++++++++++
>>  meta/recipes-devtools/rpm/rpm_4.14.2.1.bb     |  1 +
>>  2 files changed, 32 insertions(+)
>>  create mode 100644
>> meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
>>
>> diff --git
>> a/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
>> b/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
>> new file mode 100644
>> index 0000000000..52110fa2b1
>> --- /dev/null
>> +++
>> b/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
>> @@ -0,0 +1,31 @@
>> +From 405fc8998181353bd510864ca251dc233afec276 Mon Sep 17 00:00:00 2001
>> +From: Vitaly Chikunov <vt@altlinux.org>
>> +Date: Wed, 6 Jan 2021 23:43:41 +0300
>> +Subject: [PATCH] rpmio: Fix lzopen_internal mode parsing when 'Tn' is
>> used
>> +
>> +When there is number after "T" (suggested number of threads or "0" for
>> +getncpus), lzopen_internal() mode parser would skip one byte, and when
>> +it's at the end of the string it would then parse undesired garbage from
>> +the memory, making intermittent compression failures.
>> +
>> +Fixes: 7740d1098 ("Add support for multithreaded xz compression")
>> +Signed-off-by: Vitaly Chikunov <vt@altlinux.org>
>>
>
> +Upstream-Status: Backport [
> https://github.com/rpm-software-management/rpm/commit/405fc8998181353bd510864ca251dc233afec276
> ]
>
>
>> +---
>> + rpmio/rpmio.c | 1 +
>> + 1 file changed, 1 insertion(+)
>> +
>> +diff --git a/rpmio/rpmio.c b/rpmio/rpmio.c
>> +index ed1e25140..9d32ec6d9 100644
>> +--- a/rpmio/rpmio.c
>> ++++ b/rpmio/rpmio.c
>> +@@ -798,6 +798,7 @@ static LZFILE *lzopen_internal(const char *mode, int
>> fd, int xz)
>> +                * should've processed
>> +                * */
>> +               while (isdigit(*++mode));
>> ++              --mode;
>> +           }
>> + #ifdef HAVE_LZMA_MT
>> +           else
>> +--
>> +2.25.1
>> +
>> diff --git a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
>> b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
>> index c39a5208e5..376021d913 100644
>> --- a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
>> +++ b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
>> @@ -44,6 +44,7 @@ SRC_URI = "git://
>> github.com/rpm-software-management/rpm;branch=rpm-4.14.x;protoc
>>
>> file://0001-mono-find-provides-requires-do-not-use-monodis-from-.patch \
>>
>> file://0001-Rip-out-partial-support-for-unused-MD2-and-RIPEMD160.patch \
>>             file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
>> +
>>  file://0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch \
>>             file://CVE-2021-3421.patch \
>>             file://CVE-2021-20266.patch \
>>             "
>> --
>> 2.25.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#161472):
>> https://lists.openembedded.org/g/openembedded-core/message/161472
>> Mute This Topic: https://lists.openembedded.org/mt/88989796/5052612
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
>> quaresma.jose@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>>
>
> --
> Best regards,
>
> José Quaresma
>

Patch

diff --git a/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch b/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
new file mode 100644
index 0000000000..52110fa2b1
--- /dev/null
+++ b/meta/recipes-devtools/rpm/files/0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch
@@ -0,0 +1,31 @@ 
+From 405fc8998181353bd510864ca251dc233afec276 Mon Sep 17 00:00:00 2001
+From: Vitaly Chikunov <vt@altlinux.org>
+Date: Wed, 6 Jan 2021 23:43:41 +0300
+Subject: [PATCH] rpmio: Fix lzopen_internal mode parsing when 'Tn' is used
+
+When there is number after "T" (suggested number of threads or "0" for
+getncpus), lzopen_internal() mode parser would skip one byte, and when
+it's at the end of the string it would then parse undesired garbage from
+the memory, making intermittent compression failures.
+
+Fixes: 7740d1098 ("Add support for multithreaded xz compression")
+Signed-off-by: Vitaly Chikunov <vt@altlinux.org>
+---
+ rpmio/rpmio.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/rpmio/rpmio.c b/rpmio/rpmio.c
+index ed1e25140..9d32ec6d9 100644
+--- a/rpmio/rpmio.c
++++ b/rpmio/rpmio.c
+@@ -798,6 +798,7 @@ static LZFILE *lzopen_internal(const char *mode, int fd, int xz)
+ 		 * should've processed
+ 		 * */
+ 		while (isdigit(*++mode));
++		--mode;
+ 	    }
+ #ifdef HAVE_LZMA_MT
+ 	    else
+-- 
+2.25.1
+
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
index c39a5208e5..376021d913 100644
--- a/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.14.2.1.bb
@@ -44,6 +44,7 @@  SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.14.x;protoc
            file://0001-mono-find-provides-requires-do-not-use-monodis-from-.patch \
            file://0001-Rip-out-partial-support-for-unused-MD2-and-RIPEMD160.patch \
            file://0001-rpmplugins.c-call-dlerror-prior-to-dlsym.patch \
+           file://0001-rpmio-Fix-lzopen_internal-mode-parsing-when-Tn-is-us.patch \
            file://CVE-2021-3421.patch \
            file://CVE-2021-20266.patch \
            "