openssl: export OPENSSL_MODULES in the wrapper

Message ID 20220127114445.2625495-1-ross.burton@arm.com
State Accepted, archived
Commit 160ac2f136cb8df829c803848c7c47d707a908ff
Headers show
Series openssl: export OPENSSL_MODULES in the wrapper | expand

Commit Message

Ross Burton Jan. 27, 2022, 11:44 a.m. UTC
OpenSSL 3 added the concept of provider modules which are loaded from
disk.  The load path is hard-coded into the library and needs to be
relocated when running natively, so add OPENSSL_MODULES to the wrapper.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-connectivity/openssl/openssl_3.0.1.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-connectivity/openssl/openssl_3.0.1.bb b/meta/recipes-connectivity/openssl/openssl_3.0.1.bb
index 7727ec43e87..e97c986b398 100644
--- a/meta/recipes-connectivity/openssl/openssl_3.0.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_3.0.1.bb
@@ -160,7 +160,8 @@  do_install:append:class-native () {
 	    OPENSSL_CONF=${libdir}/ssl-3/openssl.cnf \
 	    SSL_CERT_DIR=${libdir}/ssl-3/certs \
 	    SSL_CERT_FILE=${libdir}/ssl-3/cert.pem \
-	    OPENSSL_ENGINES=${libdir}/engines-3
+	    OPENSSL_ENGINES=${libdir}/engines-3 \
+	    OPENSSL_MODULES=${libdir}/ossl-modules
 }
 
 do_install:append:class-nativesdk () {