nghttp2: fix for multilib support

Message ID 20220113034439.19018-1-changqing.li@windriver.com
State Accepted, archived
Commit 23b87e315962b8cb79219e7782c24b6700ebeff4
Headers show
Series nghttp2: fix for multilib support | expand

Commit Message

Changqing Li Jan. 13, 2022, 3:44 a.m. UTC
From: Changqing Li <changqing.li@windriver.com>

correct the package name

Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
 meta/recipes-support/nghttp2/nghttp2_1.46.0.bb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Richard Purdie Jan. 13, 2022, 3:26 p.m. UTC | #1
On Thu, 2022-01-13 at 11:44 +0800, Changqing Li wrote:
> From: Changqing Li <changqing.li@windriver.com>
> 
> correct the package name
> 
> Signed-off-by: Changqing Li <changqing.li@windriver.com>
> ---
>  meta/recipes-support/nghttp2/nghttp2_1.46.0.bb | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
> index 972ff2d60a..a5f0be856f 100644
> --- a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
> +++ b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
> @@ -19,7 +19,7 @@ PACKAGECONFIG[manpages] = ""
>  # first place
>  EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF"
>  
> -PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
> +PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
>  
>  RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
>  RDEPENDS:${PN}:class-native = ""
> @@ -27,7 +27,7 @@ RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
>  
>  ALLOW_EMPTY:${PN} = "1"
>  FILES:${PN} = ""
> -FILES:lib${PN} = "${libdir}/*${SOLIBS}"
> +FILES:${MLPREFIX}lib${BPN} = "${libdir}/*${SOLIBS}"
>  FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
>  FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
>  FILES:${PN}-server = "${bindir}/nghttpd"

This doesn't look correct, particularly using with MLPREFIX in one location and
not in the other...

Cheers,

Richard
Changqing Li Jan. 17, 2022, 9:12 a.m. UTC | #2
On 1/13/22 11:26 PM, Richard Purdie wrote:
> [Please note: This e-mail is from an EXTERNAL e-mail address]
>
> On Thu, 2022-01-13 at 11:44 +0800, Changqing Li wrote:
>> From: Changqing Li <changqing.li@windriver.com>
>>
>> correct the package name
>>
>> Signed-off-by: Changqing Li <changqing.li@windriver.com>
>> ---
>>   meta/recipes-support/nghttp2/nghttp2_1.46.0.bb | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
>> index 972ff2d60a..a5f0be856f 100644
>> --- a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
>> +++ b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
>> @@ -19,7 +19,7 @@ PACKAGECONFIG[manpages] = ""
>>   # first place
>>   EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF"
>>
>> -PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
>> +PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
>>
>>   RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
>>   RDEPENDS:${PN}:class-native = ""
>> @@ -27,7 +27,7 @@ RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
>>
>>   ALLOW_EMPTY:${PN} = "1"
>>   FILES:${PN} = ""
>> -FILES:lib${PN} = "${libdir}/*${SOLIBS}"
>> +FILES:${MLPREFIX}lib${BPN} = "${libdir}/*${SOLIBS}"
>>   FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
>>   FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
>>   FILES:${PN}-server = "${bindir}/nghttpd"
> This doesn't look correct, particularly using with MLPREFIX in one location and
> not in the other...

PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"

the first package lib${PN}  is not correct. when enable multilib,
for lib64, ${PN} is nghttp2,       lib${PN}=libnghttp2,
for lib32, ${PN} is lib32-nghttp2, lib${PN}=liblib32-nghttp2,
but I think it should be lib32-libnghttp2. so change it to lib${BPN}.

for PACKAGES, it will be extend by classextended.py
#   prepend /buildarea3/cli10/yocto/poky/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb:22
#     "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
#   rename (to) classextend.py:127 [rename_packages]
#     "PACKAGES_NONML"
#   set classextend.py:128 [rename_packages]
#     "${@oe.classextend.get_packages(d)}"
# pre-expansion value:
#   "${@oe.classextend.get_packages(d)}"
PACKAGES="lib32-libnghttp2 lib32-nghttp2-client lib32-nghttp2-proxy lib32-nghttp2-server lib32-nghttp2-src lib32-nghttp2-dbg lib32-nghttp2-staticdev lib32-nghttp2-dev lib32-nghttp2-doc lib32-nghttp2-locale lib32-nghttp2"

for FILES, other packages start with ${PN} aleady extened with lib32-,  so don't need MLPREFIX. but lib${BPN} need to add it manually.

>
> Cheers,
>
> Richard
>
Changqing Li Jan. 24, 2022, 3:19 a.m. UTC | #3
On 1/17/22 5:12 PM, Changqing Li wrote:
>
> On 1/13/22 11:26 PM, Richard Purdie wrote:
>> [Please note: This e-mail is from an EXTERNAL e-mail address]
>>
>> On Thu, 2022-01-13 at 11:44 +0800, Changqing Li wrote:
>>> From: Changqing Li <changqing.li@windriver.com>
>>>
>>> correct the package name
>>>
>>> Signed-off-by: Changqing Li <changqing.li@windriver.com>
>>> ---
>>>   meta/recipes-support/nghttp2/nghttp2_1.46.0.bb | 4 ++--
>>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb 
>>> b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
>>> index 972ff2d60a..a5f0be856f 100644
>>> --- a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
>>> +++ b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
>>> @@ -19,7 +19,7 @@ PACKAGECONFIG[manpages] = ""
>>>   # first place
>>>   EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF 
>>> -DENABLE_HPACK_TOOLS=OFF"
>>>
>>> -PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
>>> +PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
>>>
>>>   RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) 
>>> ${PN}-server (>= ${PV})"
>>>   RDEPENDS:${PN}:class-native = ""
>>> @@ -27,7 +27,7 @@ RDEPENDS:${PN}-proxy = "openssl python3-core 
>>> python3-io python3-shell"
>>>
>>>   ALLOW_EMPTY:${PN} = "1"
>>>   FILES:${PN} = ""
>>> -FILES:lib${PN} = "${libdir}/*${SOLIBS}"
>>> +FILES:${MLPREFIX}lib${BPN} = "${libdir}/*${SOLIBS}"
>>>   FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
>>>   FILES:${PN}-proxy = "${bindir}/nghttpx 
>>> ${datadir}/${BPN}/fetch-ocsp-response"
>>>   FILES:${PN}-server = "${bindir}/nghttpd"
>> This doesn't look correct, particularly using with MLPREFIX in one 
>> location and
>> not in the other...
>
> PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
>
> the first package lib${PN}  is not correct. when enable multilib,
> for lib64, ${PN} is nghttp2,       lib${PN}=libnghttp2,
> for lib32, ${PN} is lib32-nghttp2, lib${PN}=liblib32-nghttp2,
> but I think it should be lib32-libnghttp2. so change it to lib${BPN}.
>
> for PACKAGES, it will be extend by classextended.py
> #   prepend /yocto/poky/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb:22
> #     "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
> #   rename (to) classextend.py:127 [rename_packages]
> #     "PACKAGES_NONML"
> #   set classextend.py:128 [rename_packages]
> #     "${@oe.classextend.get_packages(d)}"
> # pre-expansion value:
> #   "${@oe.classextend.get_packages(d)}"
> PACKAGES="lib32-libnghttp2 lib32-nghttp2-client lib32-nghttp2-proxy 
> lib32-nghttp2-server lib32-nghttp2-src lib32-nghttp2-dbg 
> lib32-nghttp2-staticdev lib32-nghttp2-dev lib32-nghttp2-doc 
> lib32-nghttp2-locale lib32-nghttp2"
>
> for FILES, other packages start with ${PN} aleady extened with 
> lib32-,  so don't need MLPREFIX. but lib${BPN} need to add it manually.

ping

>
>>
>> Cheers,
>>
>> Richard
>>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#160638): https://lists.openembedded.org/g/openembedded-core/message/160638
> Mute This Topic: https://lists.openembedded.org/mt/88390547/3616873
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [changqing.li@windriver.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
index 972ff2d60a..a5f0be856f 100644
--- a/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
+++ b/meta/recipes-support/nghttp2/nghttp2_1.46.0.bb
@@ -19,7 +19,7 @@  PACKAGECONFIG[manpages] = ""
 # first place
 EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF"
 
-PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
+PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
 
 RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
 RDEPENDS:${PN}:class-native = ""
@@ -27,7 +27,7 @@  RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
 
 ALLOW_EMPTY:${PN} = "1"
 FILES:${PN} = ""
-FILES:lib${PN} = "${libdir}/*${SOLIBS}"
+FILES:${MLPREFIX}lib${BPN} = "${libdir}/*${SOLIBS}"
 FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
 FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
 FILES:${PN}-server = "${bindir}/nghttpd"