python3-pyelftools: Depend on debugger, pprint

Message ID 20211216170022.22028-1-chaitanya.vadrevu@ni.com
State Accepted, archived
Commit 22e84cdd05870f1a19c6389b66c4dfd5e9b418f7
Headers show
Series python3-pyelftools: Depend on debugger, pprint | expand

Commit Message

Chaitanya Vadrevu Dec. 16, 2021, 5 p.m. UTC
python3-pyelftools uses python3-debugger, python3-pprint.
So add dependencies on these packages.

Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
---
 meta/recipes-devtools/python/python3-pyelftools_0.27.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj Dec. 16, 2021, 10:27 p.m. UTC | #1
On Thu, Dec 16, 2021 at 9:00 AM Chaitanya Vadrevu
<chaitanya.vadrevu@ni.com> wrote:
>
> python3-pyelftools uses python3-debugger, python3-pprint.
> So add dependencies on these packages.
>
> Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
> ---
>  meta/recipes-devtools/python/python3-pyelftools_0.27.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
> index 0cfd99504b..f8b9d420a5 100644
> --- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
> +++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
> @@ -11,3 +11,5 @@ PYPI_PACKAGE = "pyelftools"
>  inherit pypi setuptools3
>
>  BBCLASSEXTEND = "native"
> +
> +RDEPENDS_${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"

this should use new override separator. It should be RDEPENDS:${PN}

> --
> 2.17.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#159796): https://lists.openembedded.org/g/openembedded-core/message/159796
> Mute This Topic: https://lists.openembedded.org/mt/87771402/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
index 0cfd99504b..f8b9d420a5 100644
--- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
+++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
@@ -11,3 +11,5 @@  PYPI_PACKAGE = "pyelftools"
 inherit pypi setuptools3
 
 BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"