[06/29] ruby: update 3.0.2 -> 3.0.3

Message ID 20211208215947.1979470-6-alex@linutronix.de
State Accepted, archived
Commit 1af0c4ef56d1892f284b6787ccc5a925d023e178
Headers show
Series [01/29] fetch: add a test for version check where compression changes | expand

Commit Message

Alexander Kanavin Dec. 8, 2021, 9:59 p.m. UTC
Do not tweak a file that is no longer installed.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/ruby/{ruby_3.0.2.bb => ruby_3.0.3.bb} | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
 rename meta/recipes-devtools/ruby/{ruby_3.0.2.bb => ruby_3.0.3.bb} (93%)

Comments

Khem Raj Dec. 8, 2021, 11:01 p.m. UTC | #1
On Wed, Dec 8, 2021 at 2:00 PM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
>
> Do not tweak a file that is no longer installed.
>
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  meta/recipes-devtools/ruby/{ruby_3.0.2.bb => ruby_3.0.3.bb} | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>  rename meta/recipes-devtools/ruby/{ruby_3.0.2.bb => ruby_3.0.3.bb} (93%)
>
> diff --git a/meta/recipes-devtools/ruby/ruby_3.0.2.bb b/meta/recipes-devtools/ruby/ruby_3.0.3.bb
> similarity index 93%
> rename from meta/recipes-devtools/ruby/ruby_3.0.2.bb
> rename to meta/recipes-devtools/ruby/ruby_3.0.3.bb
> index 2abf504d91..73bea9e089 100644
> --- a/meta/recipes-devtools/ruby/ruby_3.0.2.bb
> +++ b/meta/recipes-devtools/ruby/ruby_3.0.3.bb
> @@ -13,7 +13,7 @@ SRC_URI += " \
>             file://0006-Make-gemspecs-reproducible.patch \
>             "
>
> -SRC_URI[sha256sum] = "5085dee0ad9f06996a8acec7ebea4a8735e6fac22f22e2d98c3f2bc3bef7e6f1"
> +SRC_URI[sha256sum] = "3586861cb2df56970287f0fd83f274bd92058872d830d15570b36def7f1a92ac"
>
>  PACKAGECONFIG ??= ""
>  PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
> @@ -67,6 +67,7 @@ do_install:append:class-target () {
>  }
>
>  do_install_ptest () {
> +    set -x

perhaps not needed ?

>      cp -rf ${S}/test ${D}${PTEST_PATH}/
>
>      install -D ${S}/tool/test/runner.rb ${D}${PTEST_PATH}/tool/test/runner.rb
> @@ -83,8 +84,6 @@ do_install_ptest () {
>          -i ${D}${PTEST_PATH}/test/erb/test_erb_command.rb
>
>      cp -r ${S}/include ${D}/${libdir}/ruby/
> -    test_case_rb=`grep rubygems/test_case.rb ${B}/.installed.list`
> -    sed -i -e 's:../../../test/:../../../ptest/test/:g' ${D}/$test_case_rb
>  }
>
>  PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
> --
> 2.20.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#159372): https://lists.openembedded.org/g/openembedded-core/message/159372
> Mute This Topic: https://lists.openembedded.org/mt/87599632/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin Dec. 9, 2021, 8:55 a.m. UTC | #2
On Thu, 9 Dec 2021 at 00:01, Khem Raj <raj.khem@gmail.com> wrote:

> > +    set -x
>
> perhaps not needed ?
>

Yes, there's a followup patch in the set.

Alex

Patch

diff --git a/meta/recipes-devtools/ruby/ruby_3.0.2.bb b/meta/recipes-devtools/ruby/ruby_3.0.3.bb
similarity index 93%
rename from meta/recipes-devtools/ruby/ruby_3.0.2.bb
rename to meta/recipes-devtools/ruby/ruby_3.0.3.bb
index 2abf504d91..73bea9e089 100644
--- a/meta/recipes-devtools/ruby/ruby_3.0.2.bb
+++ b/meta/recipes-devtools/ruby/ruby_3.0.3.bb
@@ -13,7 +13,7 @@  SRC_URI += " \
            file://0006-Make-gemspecs-reproducible.patch \
            "
 
-SRC_URI[sha256sum] = "5085dee0ad9f06996a8acec7ebea4a8735e6fac22f22e2d98c3f2bc3bef7e6f1"
+SRC_URI[sha256sum] = "3586861cb2df56970287f0fd83f274bd92058872d830d15570b36def7f1a92ac"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
@@ -67,6 +67,7 @@  do_install:append:class-target () {
 }
 
 do_install_ptest () {
+    set -x
     cp -rf ${S}/test ${D}${PTEST_PATH}/
 
     install -D ${S}/tool/test/runner.rb ${D}${PTEST_PATH}/tool/test/runner.rb
@@ -83,8 +84,6 @@  do_install_ptest () {
         -i ${D}${PTEST_PATH}/test/erb/test_erb_command.rb
 
     cp -r ${S}/include ${D}/${libdir}/ruby/
-    test_case_rb=`grep rubygems/test_case.rb ${B}/.installed.list`
-    sed -i -e 's:../../../test/:../../../ptest/test/:g' ${D}/$test_case_rb
 }
 
 PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"