[5/7] linux-yocto-dev: use versioned branch as default

Message ID 1af8b17226603e07d823e1e4d25127cd6fa14723.1638895732.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit 73174b29d414ab0b5921f4fcdf5aebb988f0daf5
Headers show
Series [1/7] linux-yocto/5.15: update to v5.15.5 | expand

Commit Message

Bruce Ashfield Dec. 7, 2021, 4:52 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

The -dev kernel used to only have standard/* branches, which were
managed similarly to linux-next. Which means, they are for testing
integration of patches, and are rebased as needed (typically on
version changes).

We now do some leading edge BSP development on the -dev kernel,
so the standard/* branches are not deleted, but are instead
archived with a version prefix v<kernel version>/standard/*

The branch renaming causes problems for maintained releases
(they'll jump forward to newer kernels), and for anything that
wants to specify a particular commit (-dev is AUTOREV by
design).

There's no reason why the branches can't start versioned at
this point, and that solves both problems. So we switch our
default branch to v5.16/standard/base now, and it will be
updated with each new version (we bump the version anyway).

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/linux-yocto-dev.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 6b6ea9a7e8..80f62a0412 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -16,7 +16,7 @@  inherit pkgconfig
 # provide this .inc to set specific revisions
 include recipes-kernel/linux/linux-yocto-dev-revisions.inc
 
-KBRANCH = "standard/base"
+KBRANCH ?= "v5.16/standard/base"
 KMETA = "kernel-meta"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name=machine \