diff mbox series

[19/36] python3-cython: upgrade 3.0.8 -> 3.0.9

Message ID 1710313714-12541-19-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [01/36] debianutils: upgrade 5.16 -> 5.17 | expand

Commit Message

Mingyu Wang (Fujitsu) March 13, 2024, 7:08 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
Features added
--------------
* Assigning "const" values to non-const variables now issues a warning.
* Using "noexcept" on a function returning Python objects now issues a warning.
* Some C-API usage was updated for the upcoming CPython 3.13.
* The deprecated "Py_UNICODE" type is no longer used, unless required by user code.
* "std::string.replace()" declarations were added to libcpp.string.

Bugs fixed
----------
* Cython generates incorrect (but harmless) self-casts when directly calling
  final methods of subtypes.  Lacking a better solution, the errors that recent
  gcc versions produce have been silenced for the time being.
* Unused variable warnings about clineno were fixed when C lines in tracebacks are disabled.
* Subclass deallocation of extern classes could crash if the base class uses GC.
* Type checks for Python "memoryview" could use an invalid C function.
* Calling final fused functions could generate invalid C code.
* Declaring extern enums multiple times could generate invalid C code.
* "pyximport" used relative paths incorrectly.
* Running Cython with globbing characters ("[]*?") in the module search path could fail.
* Literal strings that include braces could change the C code indentation.

Other changes
-------------
* The "enum class not importable" warning is now only issued once per enum type.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-devtools/python/python-cython.inc                  | 2 +-
 .../python/{python3-cython_3.0.8.bb => python3-cython_3.0.9.bb} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-cython_3.0.8.bb => python3-cython_3.0.9.bb} (100%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
index e54926ae6d..2235aa9332 100644
--- a/meta/recipes-devtools/python/python-cython.inc
+++ b/meta/recipes-devtools/python/python-cython.inc
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
 PYPI_PACKAGE = "Cython"
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI[sha256sum] = "8333423d8fd5765e7cceea3a9985dd1e0a5dfeb2734629e1a2ed2d6233d39de6"
+SRC_URI[sha256sum] = "a2d354f059d1f055d34cfaa62c5b68bc78ac2ceab6407148d47fb508cf3ba4f3"
 UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
 
 inherit pypi
diff --git a/meta/recipes-devtools/python/python3-cython_3.0.8.bb b/meta/recipes-devtools/python/python3-cython_3.0.9.bb
similarity index 100%
rename from meta/recipes-devtools/python/python3-cython_3.0.8.bb
rename to meta/recipes-devtools/python/python3-cython_3.0.9.bb