diff mbox series

python3-typing-extensions: upgrade 4.7.1 -> 4.8.0

Message ID 1695717333-12999-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit f35bbd665b52d764376aab4f56a67e2618759ec6
Headers show
Series python3-typing-extensions: upgrade 4.7.1 -> 4.8.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Sept. 26, 2023, 8:35 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Add typing_extensions.Doc, as proposed by PEP 727.
-Drop support for Python 3.7 (including PyPy-3.7).
-Fix bug where get_original_bases() would return incorrect results when called
 on a concrete subclass of a generic class.
-Fix bug where ParamSpec(default=...) would raise a TypeError on Python versions <3.11.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...g-extensions_4.7.1.bb => python3-typing-extensions_4.8.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-typing-extensions_4.7.1.bb => python3-typing-extensions_4.8.0.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.7.1.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.8.0.bb
similarity index 91%
rename from meta/recipes-devtools/python/python3-typing-extensions_4.7.1.bb
rename to meta/recipes-devtools/python/python3-typing-extensions_4.8.0.bb
index 8ff77ba4fd..33749a9f0f 100644
--- a/meta/recipes-devtools/python/python3-typing-extensions_4.7.1.bb
+++ b/meta/recipes-devtools/python/python3-typing-extensions_4.8.0.bb
@@ -15,7 +15,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2"
 # The name on PyPi is slightly different.
 PYPI_PACKAGE = "typing_extensions"
 
-SRC_URI[sha256sum] = "b75ddc264f0ba5615db7ba217daeb99701ad295353c45f9e95963337ceeeffb2"
+SRC_URI[sha256sum] = "df8e4339e9cb77357558cbdbceca33c303714cf861d1eef15e1070055ae8b7ef"
 
 inherit pypi python_flit_core