diff mbox series

[v2] librepo: upgrade 1.15.2 -> 1.16.0

Message ID 1694053444-23870-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 05617d5636d3712c4374cf3590ff123f63e8e26a
Headers show
Series [v2] librepo: upgrade 1.15.2 -> 1.16.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Sept. 7, 2023, 2:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
 Implement OpenPGP using librpm API

0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
refreshed for 1.16.0

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...les-with-pkg-config-not-with-cmake-m.patch | 21 +++++++++++--------
 .../{librepo_1.15.2.bb => librepo_1.16.0.bb}  |  2 +-
 2 files changed, 13 insertions(+), 10 deletions(-)
 rename meta/recipes-devtools/librepo/{librepo_1.15.2.bb => librepo_1.16.0.bb} (94%)

Comments

Alexander Kanavin Sept. 7, 2023, 8:49 a.m. UTC | #1
Thank you, this looks good.

Alex

On Thu, 7 Sept 2023 at 04:24, wangmy <wangmy@fujitsu.com> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Changelog:
>  Implement OpenPGP using librpm API
>
> 0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
> refreshed for 1.16.0
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  ...les-with-pkg-config-not-with-cmake-m.patch | 21 +++++++++++--------
>  .../{librepo_1.15.2.bb => librepo_1.16.0.bb}  |  2 +-
>  2 files changed, 13 insertions(+), 10 deletions(-)
>  rename meta/recipes-devtools/librepo/{librepo_1.15.2.bb => librepo_1.16.0.bb} (94%)
>
> diff --git a/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch b/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
> index d61d8fbf85..a0a4d490f1 100644
> --- a/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
> +++ b/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
> @@ -12,16 +12,19 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
>   1 file changed, 2 insertions(+), 1 deletion(-)
>
>  diff --git a/CMakeLists.txt b/CMakeLists.txt
> -index a45d5c4..40249e6 100644
> +index cd975a8..713cc87 100644
>  --- a/CMakeLists.txt
>  +++ b/CMakeLists.txt
> -@@ -32,7 +32,8 @@ PKG_CHECK_MODULES(GLIB2 glib-2.0 REQUIRED)
> - PKG_SEARCH_MODULE(LIBCRYPTO REQUIRED libcrypto openssl)
> - PKG_CHECK_MODULES(LIBXML2 libxml-2.0 REQUIRED)
> +@@ -35,7 +35,8 @@ PKG_CHECK_MODULES(LIBXML2 libxml-2.0 REQUIRED)
>   FIND_PACKAGE(CURL 7.52.0 REQUIRED)
> --FIND_PACKAGE(Gpgme REQUIRED)
> -+PKG_CHECK_MODULES(GPGME gpgme REQUIRED)
> -+set(GPGME_VANILLA_LIBRARIES ${GPGME_LIBRARIES})
>
> -
> - IF (WITH_ZCHUNK)
> + IF (USE_GPGME)
> +-    FIND_PACKAGE(Gpgme REQUIRED)
> ++    PKG_CHECK_MODULES(GPGME gpgme REQUIRED)
> ++    set(GPGME_VANILLA_LIBRARIES ${GPGME_LIBRARIES})
> + ELSE (USE_GPGME)
> +     PKG_CHECK_MODULES(RPM REQUIRED rpm>=4.18.0)
> + ENDIF (USE_GPGME)
> +--
> +2.34.1
> +
> diff --git a/meta/recipes-devtools/librepo/librepo_1.15.2.bb b/meta/recipes-devtools/librepo/librepo_1.16.0.bb
> similarity index 94%
> rename from meta/recipes-devtools/librepo/librepo_1.15.2.bb
> rename to meta/recipes-devtools/librepo/librepo_1.16.0.bb
> index 995301d601..4710a6b72a 100644
> --- a/meta/recipes-devtools/librepo/librepo_1.15.2.bb
> +++ b/meta/recipes-devtools/librepo/librepo_1.16.0.bb
> @@ -10,7 +10,7 @@ SRC_URI = "git://github.com/rpm-software-management/librepo.git;branch=master;pr
>             file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
>             "
>
> -SRCREV = "1a0a5fd2b040d00872118b32d09d1f79730897a2"
> +SRCREV = "7c9af219abd49f8961542b7622fc82cfdaa572e3"
>
>  S = "${WORKDIR}/git"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#187360): https://lists.openembedded.org/g/openembedded-core/message/187360
> Mute This Topic: https://lists.openembedded.org/mt/101207751/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch b/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
index d61d8fbf85..a0a4d490f1 100644
--- a/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
+++ b/meta/recipes-devtools/librepo/librepo/0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch
@@ -12,16 +12,19 @@  Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
  1 file changed, 2 insertions(+), 1 deletion(-)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a45d5c4..40249e6 100644
+index cd975a8..713cc87 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -32,7 +32,8 @@ PKG_CHECK_MODULES(GLIB2 glib-2.0 REQUIRED)
- PKG_SEARCH_MODULE(LIBCRYPTO REQUIRED libcrypto openssl)
- PKG_CHECK_MODULES(LIBXML2 libxml-2.0 REQUIRED)
+@@ -35,7 +35,8 @@ PKG_CHECK_MODULES(LIBXML2 libxml-2.0 REQUIRED)
  FIND_PACKAGE(CURL 7.52.0 REQUIRED)
--FIND_PACKAGE(Gpgme REQUIRED)
-+PKG_CHECK_MODULES(GPGME gpgme REQUIRED)
-+set(GPGME_VANILLA_LIBRARIES ${GPGME_LIBRARIES})
  
- 
- IF (WITH_ZCHUNK)
+ IF (USE_GPGME)
+-    FIND_PACKAGE(Gpgme REQUIRED)
++    PKG_CHECK_MODULES(GPGME gpgme REQUIRED)
++    set(GPGME_VANILLA_LIBRARIES ${GPGME_LIBRARIES})
+ ELSE (USE_GPGME)
+     PKG_CHECK_MODULES(RPM REQUIRED rpm>=4.18.0)
+ ENDIF (USE_GPGME)
+-- 
+2.34.1
+
diff --git a/meta/recipes-devtools/librepo/librepo_1.15.2.bb b/meta/recipes-devtools/librepo/librepo_1.16.0.bb
similarity index 94%
rename from meta/recipes-devtools/librepo/librepo_1.15.2.bb
rename to meta/recipes-devtools/librepo/librepo_1.16.0.bb
index 995301d601..4710a6b72a 100644
--- a/meta/recipes-devtools/librepo/librepo_1.15.2.bb
+++ b/meta/recipes-devtools/librepo/librepo_1.16.0.bb
@@ -10,7 +10,7 @@  SRC_URI = "git://github.com/rpm-software-management/librepo.git;branch=master;pr
            file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
            "
 
-SRCREV = "1a0a5fd2b040d00872118b32d09d1f79730897a2"
+SRCREV = "7c9af219abd49f8961542b7622fc82cfdaa572e3"
 
 S = "${WORKDIR}/git"