diff mbox series

gmp: upgrade 6.2.1 -> 6.3.0

Message ID 1690875687-21573-4-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 49b625116b67a19abfd17670431ba3f96031b86e
Headers show
Series gmp: upgrade 6.2.1 -> 6.3.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 1, 2023, 7:41 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

cve-2021-43618.patch
removed since it's included in 6.3.0

Changelog:
============
  BUGS FIXED
  * A possible overflow of type int is avoided for mpz_cmp on huge operands.

  * A possible error condition when a malformed file is read with
    mpz_inp_raw is now correctly handled.

  FEATURES
  * New public function mpz_prevprime, companion of the existing
    mpz_nextprime.

  * New documented pointer types mpz_ptr, mpz_srcptr, and similar for
    other GMP types. Refer to the manual for full list and suggested
    usage. These types have been present in gmp.h at least since
    GMP-4.0, but previously not advertised to users.

  * Support for 64-bit Arm under Macos.

  * Support for the loongarch64 CPU family.

  * Support for building with LTO, link-time optimisations.

  SPEEDUPS
  * New special code for base = 2 in mpz_powm reduces the average time
    for the functions that test primality.

  * Speedup for the function mpz_nextprime on large operands.

  * Speedup for multiplications (some sizes only) thanks to new
    internal functions to compute small negacyclic products.

  * Special assembly code for IBM z13 and later "mainframe" CPUs, resulting in
    a huge speedup.

  * Improved assembly for several 64-bit x86 CPUs, Risc-V, 64-bit Arm.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../gmp/gmp/cve-2021-43618.patch              | 27 -------------------
 .../gmp/{gmp_6.2.1.bb => gmp_6.3.0.bb}        |  4 +--
 2 files changed, 1 insertion(+), 30 deletions(-)
 delete mode 100644 meta/recipes-support/gmp/gmp/cve-2021-43618.patch
 rename meta/recipes-support/gmp/{gmp_6.2.1.bb => gmp_6.3.0.bb} (87%)
diff mbox series

Patch

diff --git a/meta/recipes-support/gmp/gmp/cve-2021-43618.patch b/meta/recipes-support/gmp/gmp/cve-2021-43618.patch
deleted file mode 100644
index 095fb21eaa..0000000000
--- a/meta/recipes-support/gmp/gmp/cve-2021-43618.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-CVE: CVE-2021-43618
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@arm.com>
-
-# HG changeset patch
-# User Marco Bodrato <bodrato@mail.dm.unipi.it>
-# Date 1634836009 -7200
-# Node ID 561a9c25298e17bb01896801ff353546c6923dbd
-# Parent  e1fd9db13b475209a864577237ea4b9105b3e96e
-mpz/inp_raw.c: Avoid bit size overflows
-
-diff -r e1fd9db13b47 -r 561a9c25298e mpz/inp_raw.c
---- a/mpz/inp_raw.c	Tue Dec 22 23:49:51 2020 +0100
-+++ b/mpz/inp_raw.c	Thu Oct 21 19:06:49 2021 +0200
-@@ -88,8 +88,11 @@
- 
-   abs_csize = ABS (csize);
- 
-+  if (UNLIKELY (abs_csize > ~(mp_bitcnt_t) 0 / 8))
-+    return 0; /* Bit size overflows */
-+
-   /* round up to a multiple of limbs */
--  abs_xsize = BITS_TO_LIMBS (abs_csize*8);
-+  abs_xsize = BITS_TO_LIMBS ((mp_bitcnt_t) abs_csize * 8);
- 
-   if (abs_xsize != 0)
-     {
diff --git a/meta/recipes-support/gmp/gmp_6.2.1.bb b/meta/recipes-support/gmp/gmp_6.3.0.bb
similarity index 87%
rename from meta/recipes-support/gmp/gmp_6.2.1.bb
rename to meta/recipes-support/gmp/gmp_6.3.0.bb
index 29055492c2..3dbcd68b5c 100644
--- a/meta/recipes-support/gmp/gmp_6.2.1.bb
+++ b/meta/recipes-support/gmp/gmp_6.3.0.bb
@@ -14,10 +14,8 @@  SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2 \
            file://use-includedir.patch \
            file://0001-Append-the-user-provided-flags-to-the-auto-detected-.patch \
            file://0001-confiure.ac-Believe-the-cflags-from-environment.patch \
-           file://cve-2021-43618.patch \
            "
-SRC_URI[md5sum] = "28971fc21cf028042d4897f02fd355ea"
-SRC_URI[sha256sum] = "eae9326beb4158c386e39a356818031bd28f3124cf915f8c5b1dc4c7a36b4d7c"
+SRC_URI[sha256sum] = "ac28211a7cfb609bae2e2c8d6058d66c8fe96434f740cf6fe2e47b000d1c20cb"
 
 acpaths = ""