diff mbox series

python3-testtools: upgrade 2.5.0 -> 2.6.0

Message ID 1678878814-19528-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit c0d0428deabf519e86bc0ffb7ff47e9bb0a165c4
Headers show
Series python3-testtools: upgrade 2.5.0 -> 2.6.0 | expand

Commit Message

Mingyu Wang (Fujitsu) March 15, 2023, 11:13 a.m. UTC
From: Upgrade Helper <uh@not.set>

Improvements
------------
* Add support for Python 3.10 and 3.11.
* Drop support for Python 3.5 (EOL).
* Distutils integration is deprecated and will be removed in the next major
  version.
* Use "CompoundFixture" from "fixtures>=2.0" rather than rolling our
  own.
* Provide a "testtools[twisted]" extra documenting dependencies needed for
  "testtools.twistedsupport".
* Make "TestCase" hashable.
* Prevent "AttributeError" in "TestCase.__eq__" for objects lacking a
  "__dict__" attribute.
* Replace deprecated "cgi" module usage with "email".

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-devtools/python/python-testtools.inc               | 2 +-
 .../{python3-testtools_2.5.0.bb => python3-testtools_2.6.0.bb}  | 1 +
 2 files changed, 2 insertions(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-testtools_2.5.0.bb => python3-testtools_2.6.0.bb} (98%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-testtools.inc b/meta/recipes-devtools/python/python-testtools.inc
index ef5e15cc3a..e004d0eb0b 100644
--- a/meta/recipes-devtools/python/python-testtools.inc
+++ b/meta/recipes-devtools/python/python-testtools.inc
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
 
 inherit pypi
 
-SRC_URI[sha256sum] = "57c13433d94f9ffde3be6534177d10fb0c1507cc499319128958ca91a65cb23f"
+SRC_URI[sha256sum] = "28b65e14c0f2d3ecbbfb5f55c9dcde5e4faa80ac16a37a823909a1fe3cbcb30a"
 
 DEPENDS += " \
     ${PYTHON_PN}-pbr \
diff --git a/meta/recipes-devtools/python/python3-testtools_2.5.0.bb b/meta/recipes-devtools/python/python3-testtools_2.6.0.bb
similarity index 98%
rename from meta/recipes-devtools/python/python3-testtools_2.5.0.bb
rename to meta/recipes-devtools/python/python3-testtools_2.6.0.bb
index 896ecee65c..79e46a02de 100644
--- a/meta/recipes-devtools/python/python3-testtools_2.5.0.bb
+++ b/meta/recipes-devtools/python/python3-testtools_2.6.0.bb
@@ -1,2 +1,3 @@ 
 inherit setuptools3
 require python-testtools.inc
+