diff mbox series

python3-cython: upgrade 0.29.32 -> 0.29.33

Message ID 1673760250-2563-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 4c5b05d92d691447d493ce87f32f4af907410c39
Headers show
Series python3-cython: upgrade 0.29.32 -> 0.29.33 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 15, 2023, 5:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
Features added
--------------
* The "cythonize" and "cython" commands have a new option "-M" / "--depfile"
  to generate ".dep" dependency files for the compilation unit.  This can be used
  by external build tools to track these dependencies.
  The "cythonize" option was already available in Cython :ref:'0.29.27'.

Bugs fixed
----------
* "const" fused types could not be used with memory views.
  Patch by Thomas Vincent.  (Github issue :issue:'1772')
* "wstr" usage was removed in Python 3.12 and later (PEP-623).
  (Github issue :issue:'5145')
* A type check assertion for Cython functions failed in debug Python builds.
  (Github issue :issue:'5031')
* Fixed various compiler warnings.
  Patches by Lisandro Dalcin et al.  (Github issues :issue:'4948', :issue:'5086')
* Fixed error when calculating complex powers of negative numbers.
  (Github issue :issue:'5014')
* Corrected a small mis-formatting of exception messages on Python 2.
  (Github issue :issue:'5018')
* The "PyUnicode_AsUTF8AndSize()" C-API function was missing from the CPython declarations.
  (Github issue :issue:'5163')
* A performance problem in the compiler was resolved when nesting conditional expressions.
  (Github issue :issue:'5197')
* Test suite problems with recent NumPy and CPython versions were resolved.
  (Github issues :issue:'5183', :issue:'5190')

Other changes
-------------
* The undocumented, untested and apparently useless syntax
  "from somemodule cimport class/struct/union somename" was deprecated
  in anticipation of its removal in Cython 3.  The type
  modifier is not needed here and a plain "cimport" of the name will do.
  (Github issue :issue:'4905')
* Properly disable generation of descriptor docstrings on PyPy since they cause crashes.
  It was previously disabled, but only accidentally via a typo.
  Patch by Matti Picus.  (Github issue :issue:'5083')
* The "cpow" directive of Cython 3.0 is available as a no-op.
  (Github issue :issue:'5016')

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-devtools/python/python-cython.inc                  | 2 +-
 .../{python3-cython_0.29.32.bb => python3-cython_0.29.33.bb}    | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-cython_0.29.32.bb => python3-cython_0.29.33.bb} (100%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
index 750ccfd7ae..30d1b39467 100644
--- a/meta/recipes-devtools/python/python-cython.inc
+++ b/meta/recipes-devtools/python/python-cython.inc
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
 PYPI_PACKAGE = "Cython"
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI[sha256sum] = "8733cf4758b79304f2a4e39ebfac5e92341bce47bcceb26c1254398b2f8c1af7"
+SRC_URI[sha256sum] = "5040764c4a4d2ce964a395da24f0d1ae58144995dab92c6b96f44c3f4d72286a"
 UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
 
 inherit pypi
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.32.bb b/meta/recipes-devtools/python/python3-cython_0.29.33.bb
similarity index 100%
rename from meta/recipes-devtools/python/python3-cython_0.29.32.bb
rename to meta/recipes-devtools/python/python3-cython_0.29.33.bb