diff mbox series

python3-babel: upgrade 2.10.3 -> 2.11.0

Message ID 1667544476-4822-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit cac67727058415ecd491c85bcf1b62610849950f
Headers show
Series python3-babel: upgrade 2.10.3 -> 2.11.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 4, 2022, 6:47 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
"the author" changed to "the copyright holder nor the names of its contributors"
"THE AUTHOR" changed to "THE COPYRIGHT HOLDERS AND CONTRIBUTORS"

Changelog:
===========
Improvements
------------
* Support for hex escapes in JavaScript string literals :gh:'#877'
* Add support for formatting decimals in compact form :gh:'#909'
* Adapt parse_date to handle ISO dates in ASCII format :gh:'#842'
* Use 'ast' instead of 'eval' for Python string extraction :gh:'#915'
    * This also enables extraction from static f-strings.
      F-strings with expressions are silently ignored (but won't raise an error as they used to).

Infrastructure
---------------
* Tests: Use regular asserts and "pytest.raises()" :gh:'#875'
* Wheels are now built in GitHub Actions :gh:'#888'
* Small improvements to the CLDR downloader script :gh:'#894'
* Remove antiquated '__nonzero__' methods :gh:'#896'
* Remove superfluous '__unicode__' declarations :gh:'#905'
* Mark package compatible with Python 3.11 :gh:'#913'
* Quiesce pytest warnings :gh:'#916'

Bugfixes
-----------
* Use email.Message for pofile header parsing instead of the deprecated "cgi.parse_header" function. :gh:'#876'
* Remove determining time zone via systemsetup on macOS :gh:'#914'

Documentation
--------------
* Update Python versions in documentation :gh:'#898'
* Align BSD-3 license with OSI template :gh:'#912'

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-babel_2.10.3.bb => python3-babel_2.11.0.bb}      | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-babel_2.10.3.bb => python3-babel_2.11.0.bb} (76%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-babel_2.10.3.bb b/meta/recipes-devtools/python/python3-babel_2.11.0.bb
similarity index 76%
rename from meta/recipes-devtools/python/python3-babel_2.10.3.bb
rename to meta/recipes-devtools/python/python3-babel_2.11.0.bb
index 7420bfc917..f6eae88b80 100644
--- a/meta/recipes-devtools/python/python3-babel_2.10.3.bb
+++ b/meta/recipes-devtools/python/python3-babel_2.11.0.bb
@@ -1,9 +1,9 @@ 
 DESCRIPTION = "A collection of tools for internationalizing Python applications"
 HOMEPAGE = "http://babel.edgewall.org/"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1b3f4650099e6d6a73e5a7fc8774ff18"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fb98e9f202b978d6569807b9525cc691"
 
-SRC_URI[sha256sum] = "7614553711ee97490f732126dc077f8d0ae084ebc6a96e23db1482afabdb2c51"
+SRC_URI[sha256sum] = "5ef4b3226b0180dedded4229651c8b0e1a3a6a2837d45a073272f313e4cf97f6"
 
 PYPI_PACKAGE = "Babel"