ed: upgrade 1.17 -> 1.18

Message ID 1644308725-5262-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 3b2804babd629b55a37eb33ae823dfb682b53b8b
Headers show
Series ed: upgrade 1.17 -> 1.18 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 8, 2022, 8:25 a.m. UTC
License-Update:
year updated to 2022.
license changed from GNU3 to GNU2.

Changelog:
=========
* main_loop.c (get_shell_command): Flush stdout after printing cmd.
* signal.c (sighup_handler): Fix a memory leak just before exiting.
* carg_parser.c (ap_init): Likewise.
* io.c (read_file, write_file): Check ptr returned by strip_escapes.
* main_loop.c (get_shell_command, exec_command): Likewise.
* main_loop.c (get_shell_command): Remove backslash from escaped '%'.
* main_loop.c, regex.c: Implement case-insensitive REs.
* regex.c (compile_regex): Don't overwrite previous regex if error.
* main.c: New option '--strip-trailing-cr'.
* buffer.c (push_undo_atom): Fail if stack grows larger than INT_MAX.
  (too_many_lines): Fail if buffer grows larger than INT_MAX lines.
* global.c (set_active_node): Fail if list grows larger than INT_MAX.
* signal.c (resize_buffer): Fail if a line grows longer than INT_MAX.
* io.c (read_file): Return -2 for fatal errors.
* main_loop.c (main_loop): Set error status if fatal error from main.
* main.c [restricted_]: New message "Directory access restricted".
* ed.texi: New chapter "The 's' Command".
* COPYING: Restored.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-extended/ed/{ed_1.17.bb => ed_1.18.bb} | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
 rename meta/recipes-extended/ed/{ed_1.17.bb => ed_1.18.bb} (74%)

Comments

Alexander Kanavin Feb. 8, 2022, 10:25 a.m. UTC | #1
On Tue, 8 Feb 2022 at 09:26, wangmy <wangmy@fujitsu.com> wrote:

> License-Update:
> year updated to 2022.
> license changed from GNU3 to GNU2.
>  LICENSE = "GPLv3+"
> -LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
> -                    file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \
> -                    file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \
> +LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
> +                    file://ed.h;endline=20;md5=6e6a818b0593f937fc63ba08d5e314bf \
> +                    file://main.c;endline=17;md5=8419a08bb12936f32384a0d1c0f9e74c \


If the license changed, you need to update the LICENSE field. Also a
bit more research would be appreciated: can you find and link the
commit where the change occurred?

Alex
Mingyu Wang (Fujitsu) Feb. 10, 2022, 1:06 a.m. UTC | #2
As you can see the ChangeLog shown below, in version 1.5 the maintainer mistakenly changed the copyright holder from Andrew Moore to the FSF. In versions 1.6 and 1.11 he tried to fix the mistake, but he forgot to restore the original COPYING, which he have done now in 1.18.

Therefore, in addition to changing the LICENSE field from GPLv3 + to GPLv2 , should I add relevant information in the commit?

2010-08-30  Antonio Diaz Diaz  <ant_diaz@teleline.es>
        * Version 1.5 released.
        * Change copyright holder from Andrew, Antonio to the FSF.
          (This change was later discovered to be wrong. See 1.6 and 1.11).

2012-01-01  Antonio Diaz Diaz  <ant_diaz@teleline.es>

        * Version 1.6 released.
        * Restore copyright notices of Andrew L. Moore. It seems Andrew
          granted some permissions but never assigned copyright to the FSF.

2015-03-30  Antonio Diaz Diaz  <antonio@gnu.org>

        * Version 1.11 released.
        * Restore original copyright and license notices in the code. I
          assigned to the FSF the copyright on changes made to the part of ed
          already copyrighted by the FSF, which seems to be just the manual.

2022-02-04  Antonio Diaz Diaz  <antonio@gnu.org>
        * Version 1.18 released.
        * COPYING: Restored. (I forgot to do it in 1.11).

> -----Original Message-----
> From: Alexander Kanavin <alex.kanavin@gmail.com>
> Sent: Tuesday, February 8, 2022 6:25 PM
> To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>
> Cc: OE-core <openembedded-core@lists.openembedded.org>
> Subject: Re: [OE-core] [PATCH] ed: upgrade 1.17 -> 1.18
> 
> On Tue, 8 Feb 2022 at 09:26, wangmy <wangmy@fujitsu.com> wrote:
> 
> > License-Update:
> > year updated to 2022.
> > license changed from GNU3 to GNU2.
> >  LICENSE = "GPLv3+"
> > -LIC_FILES_CHKSUM =
> "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
> > -
> file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \
> > -
> file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \
> > +LIC_FILES_CHKSUM =
> "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
> > +
> file://ed.h;endline=20;md5=6e6a818b0593f937fc63ba08d5e314bf \
> > +
> > +file://main.c;endline=17;md5=8419a08bb12936f32384a0d1c0f9e74c \
> 
> 
> If the license changed, you need to update the LICENSE field. Also a bit
> more research would be appreciated: can you find and link the commit
> where the change occurred?
> 
> Alex
Alexander Kanavin Feb. 10, 2022, 8:53 a.m. UTC | #3
Thanks for the research. Yes, please do add this to commit and resend.

Alex

On Thu, 10 Feb 2022 at 02:07, wangmy@fujitsu.com <wangmy@fujitsu.com> wrote:
>
> As you can see the ChangeLog shown below, in version 1.5 the maintainer mistakenly changed the copyright holder from Andrew Moore to the FSF. In versions 1.6 and 1.11 he tried to fix the mistake, but he forgot to restore the original COPYING, which he have done now in 1.18.
>
> Therefore, in addition to changing the LICENSE field from GPLv3 + to GPLv2 , should I add relevant information in the commit?
>
> 2010-08-30  Antonio Diaz Diaz  <ant_diaz@teleline.es>
>         * Version 1.5 released.
>         * Change copyright holder from Andrew, Antonio to the FSF.
>           (This change was later discovered to be wrong. See 1.6 and 1.11).
>
> 2012-01-01  Antonio Diaz Diaz  <ant_diaz@teleline.es>
>
>         * Version 1.6 released.
>         * Restore copyright notices of Andrew L. Moore. It seems Andrew
>           granted some permissions but never assigned copyright to the FSF.
>
> 2015-03-30  Antonio Diaz Diaz  <antonio@gnu.org>
>
>         * Version 1.11 released.
>         * Restore original copyright and license notices in the code. I
>           assigned to the FSF the copyright on changes made to the part of ed
>           already copyrighted by the FSF, which seems to be just the manual.
>
> 2022-02-04  Antonio Diaz Diaz  <antonio@gnu.org>
>         * Version 1.18 released.
>         * COPYING: Restored. (I forgot to do it in 1.11).
>
> > -----Original Message-----
> > From: Alexander Kanavin <alex.kanavin@gmail.com>
> > Sent: Tuesday, February 8, 2022 6:25 PM
> > To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>
> > Cc: OE-core <openembedded-core@lists.openembedded.org>
> > Subject: Re: [OE-core] [PATCH] ed: upgrade 1.17 -> 1.18
> >
> > On Tue, 8 Feb 2022 at 09:26, wangmy <wangmy@fujitsu.com> wrote:
> >
> > > License-Update:
> > > year updated to 2022.
> > > license changed from GNU3 to GNU2.
> > >  LICENSE = "GPLv3+"
> > > -LIC_FILES_CHKSUM =
> > "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
> > > -
> > file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \
> > > -
> > file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \
> > > +LIC_FILES_CHKSUM =
> > "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
> > > +
> > file://ed.h;endline=20;md5=6e6a818b0593f937fc63ba08d5e314bf \
> > > +
> > > +file://main.c;endline=17;md5=8419a08bb12936f32384a0d1c0f9e74c \
> >
> >
> > If the license changed, you need to update the LICENSE field. Also a bit
> > more research would be appreciated: can you find and link the commit
> > where the change occurred?
> >
> > Alex

Patch

diff --git a/meta/recipes-extended/ed/ed_1.17.bb b/meta/recipes-extended/ed/ed_1.18.bb
similarity index 74%
rename from meta/recipes-extended/ed/ed_1.17.bb
rename to meta/recipes-extended/ed/ed_1.18.bb
index addf652d52..57e883d342 100644
--- a/meta/recipes-extended/ed/ed_1.17.bb
+++ b/meta/recipes-extended/ed/ed_1.18.bb
@@ -3,9 +3,9 @@  HOMEPAGE = "http://www.gnu.org/software/ed/"
 DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands."
 
 LICENSE = "GPLv3+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
-                    file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \
-                    file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \
+LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
+                    file://ed.h;endline=20;md5=6e6a818b0593f937fc63ba08d5e314bf \
+                    file://main.c;endline=17;md5=8419a08bb12936f32384a0d1c0f9e74c \
                     "
 
 SECTION = "base"
@@ -19,7 +19,7 @@  bindir = "${base_bindir}"
 SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz"
 UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/"
 
-SRC_URI[sha256sum] = "71de39883c25b6fab44add80635382a10c9bf154515b94729f4a6529ddcc5e54"
+SRC_URI[sha256sum] = "aca8efad9800c587724a20b97aa8fc47e6b5a47df81606feaba831b074462b4f"
 
 EXTRA_OEMAKE = "-e MAKEFLAGS="