python3-libarchive-c: upgrade 3.2 -> 4.0

Message ID 1643069496-5684-4-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 9adbc075c5a2b396d991144596fd92ebe16d4154
Headers show
Series python3-libarchive-c: upgrade 3.2 -> 4.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 25, 2022, 12:11 a.m. UTC
Changelog:
=========
-BREAKING & SECURITY: The archive extraction functions now pass 3 security flags
 (SECURE_NODOTDOT, SECURE_NOABSOLUTEPATHS and SECURE_SYMLINKS) to libarchive by
 default, unless the current directory is the root.
-BREAKING: The ArchiveEntry properties atime, mtime, ctime, birthtime and size
 now have the value None instead of 0 when they're unset.
-BREAKING: The ArchiveEntry.pathname property now attempts to decode bytes using
 UTF-8. This breaks reading archives that contain file names which look like
 UTF-8 but aren't, if such a thing exists. Proper support of encodings will
 probably be added in the next version.
-Multiple entries from the same archive can now be kept in memory, however only
 the current entry's content can be read.
-The filetype, linkpath, size, mode, redvmajor, redvminor, uid and gid
 attributes of an archive entry can now be modified.
-The four time properties of archive entries now have setters, so for example
 entry.set_mtime(0, 0) can be replaced by entry.mtime = 0.
-Archive entries have 4 new properties: perm, rdev, uname and gname.
-When adding files to an archive, a destination path can now be specified.
-The ArchiveRead class now has a bytes_read property.
-The ArchiveWrite class now has a bytes_written property.
-Python 3.6 is no longer tested.
-The documentation has been improved.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...{python3-libarchive-c_3.2.bb => python3-libarchive-c_4.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-libarchive-c_3.2.bb => python3-libarchive-c_4.0.bb} (85%)

Patch

diff --git a/meta/recipes-devtools/python/python3-libarchive-c_3.2.bb b/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
similarity index 85%
rename from meta/recipes-devtools/python/python3-libarchive-c_3.2.bb
rename to meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
index cc04210e72..3c6bc1e1ca 100644
--- a/meta/recipes-devtools/python/python3-libarchive-c_3.2.bb
+++ b/meta/recipes-devtools/python/python3-libarchive-c_4.0.bb
@@ -9,7 +9,7 @@  PYPI_PACKAGE = "libarchive-c"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "21ad493f4628972fc82440bff54c834a9fbe13be3893037a4bad332b9ee741e5"
+SRC_URI[sha256sum] = "a5b41ade94ba58b198d778e68000f6b7de41da768de7140c984f71d7fa8416e5"
 
 RDEPENDS:${PN} += "\
   libarchive \