mesa: upgrade 21.3.3 -> 21.3.4

Message ID 1642429806-13814-4-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 3cdb743ec048aa06c10e0da0fb3feb1ca740b6e2
Headers show
Series mesa: upgrade 21.3.3 -> 21.3.4 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 17, 2022, 2:30 p.m. UTC
Changelog:
==========
Bug fixes
---------
i965: gen5 exposes EXT_texture_integer incorrectly
[radeonsi, regression, bisected]: Rendering issues with Factorio
mesa >= 21.x (with llvmpipe) will break the game JVGS
Panfrost - RK3399 - FACTORIO - glitches everywhere
Baldurs Gate 3 (Patch 6) - ribbon-like artifacts on textures
Game Starsector crashes under certain circumstances with mesa 21.3.+
FreeSpace models incorrectly rendered on Polaris cards, causing system freeze
Incomplete evaluation of nested DEFINE macros
[r300g, bisected] piglit glsl-fs-discard-04 fails
Panfrost G52 Firefox terrible glitches on youtube playback

Changes
-------
pan/bi: Fix load_const of 1-bit booleans
gallium/util: Add pixel->blocks box helper
lima,panfrost: Correct pixel vs block mismatches
radv: Set optimal copy alignment to 1.
microsoft/compiler: Fix dxil_nir_create_bare_samplers()
ir3/ra: Fix logic bug in compress_regs_left
ir3: Bump type mismatch penalty to 3
aco: don't allow SDWA on VOP3P instructions
aco: validate VOP3P opsel correctly
tu: fix workaround for depth bounds test without depth test
intel/genxml/gen4-5: fix more Raster Operation in BLT to be a uint
crocus: fail resource allocation properly.
freedreno/afuc: Disable the disassembler on 32-bit builds.
i915g: Turn off FP16 in the vertex shaders.
r300: Fix omod failing to increase the number of channels stored.
nir_to_tgsi: Fix a bug in TXP detection after backend lowering.
pick_status.json: Update to 8a78706643ecad8a1f303cc9358873abc29978b4
pick_status.json: Mark 00bea38242d97e7ace1954f1bc7d32cbf0ce3ee0 as denominated
pick_status.json: Mark 2a0253b9b5d21c7571555abe3a1d851468a18740 as denominated
r300: fix handling swizzle in transform_source_conflicts
intel/compiler/test: Fix build with GCC 7
i965: Disable EXT_texture_integer on Gfx4 and Gfx5
Revert "anv: Stop doing too much per-sample shading"
anv: don't leave anv_batch fields undefined
anv: limit compiler valid color outputs using NIR variables
intel/dev: fixup chv workaround
etnaviv: initialize vertex attributes on context reset
etnaviv: drm: fix size limit in etna_cmd_stream_realloc
etnaviv: drm: properly handle reviving BOs via a lookup
zink: fix -Warray-bounds warning
radv: fix xfb query copy param ordering
zink: always unset vertex shader variant key data when changing last vertex stage
zink: add extra synchronization for buffer descriptor binds
zink: use device-local heap for sparse backing allocations
r300: Remove broken optimization in rc_transform_KILL
radeonsi/gfx8: use the proper dcc clear size
vbo/dlist: fix loopback crash
vbo/dlist: add vertices to incomplete primitives
radeonsi/gfx10: fix si_texture_get_offset for mipmapped tex
glapi: should not add alias function to static_data.py
aco: remove pack_half_2x16(a, 0) optimization
intel/fs: OpImageQueryLod does not support arrayed images as an operand
v3dv: Hotfix: Rename remaining V3DV_HAS_SURFACE->V3DV_USE_WSI_PLATFORM
radv: add drirc radv_disable_htile_layers and enable it for F1 2021
iris: unref syncobjs and free r/w dependencies array for slab entries
mesa: free idalloc storage for display lists
mesa: free vbo_save_vertex_list store prims
glsl/glcpp: make sure to expand new token after concatenation
venus: subtract appended header size in vn_CreatePipelineCache
Fix compilation on armv7l with gcc 11.2.0

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../mesa/{mesa-gl_21.3.3.bb => mesa-gl_21.3.4.bb}               | 0
 meta/recipes-graphics/mesa/mesa.inc                             | 2 +-
 meta/recipes-graphics/mesa/{mesa_21.3.3.bb => mesa_21.3.4.bb}   | 0
 3 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-graphics/mesa/{mesa-gl_21.3.3.bb => mesa-gl_21.3.4.bb} (100%)
 rename meta/recipes-graphics/mesa/{mesa_21.3.3.bb => mesa_21.3.4.bb} (100%)

Patch

diff --git a/meta/recipes-graphics/mesa/mesa-gl_21.3.3.bb b/meta/recipes-graphics/mesa/mesa-gl_21.3.4.bb
similarity index 100%
rename from meta/recipes-graphics/mesa/mesa-gl_21.3.3.bb
rename to meta/recipes-graphics/mesa/mesa-gl_21.3.4.bb
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 7f47f18591..71cc3b4617 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -23,7 +23,7 @@  SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
            file://0001-v3dv-account-for-64bit-time_t-on-32bit-arches.patch \
            "
 
-SRC_URI[sha256sum] = "ad7f4613ea7c5d08d9fcb5025270199e6ceb9aa99fd72ee572b70342240a8121"
+SRC_URI[sha256sum] = "77104fd4a93bce69da3b0982f8ee88ba7c4fb98cfc491a669894339cdcd4a67d"
 
 UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
 
diff --git a/meta/recipes-graphics/mesa/mesa_21.3.3.bb b/meta/recipes-graphics/mesa/mesa_21.3.4.bb
similarity index 100%
rename from meta/recipes-graphics/mesa/mesa_21.3.3.bb
rename to meta/recipes-graphics/mesa/mesa_21.3.4.bb