libsdl2: upgrade 2.0.18 -> 2.0.20

Message ID 1642429806-13814-3-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 21de64185beb799aee04dc12ae84e3a60cc671a3
Headers show
Series libsdl2: upgrade 2.0.18 -> 2.0.20 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 17, 2022, 2:30 p.m. UTC
0001-Fix-build-against-wayland-1.20.patch
removed since it is included in 2.0.20

License-Update: year updated to 2022.

Changelog:
=========
General:

SDL_RenderGeometryRaw() takes a pointer to SDL_Color, not int.
You can cast color data in SDL_PIXELFORMAT_RGBA32 format
(SDL_PIXELFORMAT_ABGR8888 on little endian systems) for this parameter.
Improved accuracy of horizontal and vertical line drawing when using OpenGL
or OpenGLES
Added the hint SDL_HINT_RENDER_LINE_METHOD to control the method of line
drawing used, to select speed, correctness, and compatibility.
Fixed hotplug controller detection, broken in 2.0.18

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../0001-Fix-build-against-wayland-1.20.patch | 45 -------------------
 .../{libsdl2_2.0.18.bb => libsdl2_2.0.20.bb}  |  7 ++-
 2 files changed, 3 insertions(+), 49 deletions(-)
 delete mode 100644 meta/recipes-graphics/libsdl2/libsdl2/0001-Fix-build-against-wayland-1.20.patch
 rename meta/recipes-graphics/libsdl2/{libsdl2_2.0.18.bb => libsdl2_2.0.20.bb} (93%)

Patch

diff --git a/meta/recipes-graphics/libsdl2/libsdl2/0001-Fix-build-against-wayland-1.20.patch b/meta/recipes-graphics/libsdl2/libsdl2/0001-Fix-build-against-wayland-1.20.patch
deleted file mode 100644
index 8923334e27..0000000000
--- a/meta/recipes-graphics/libsdl2/libsdl2/0001-Fix-build-against-wayland-1.20.patch
+++ /dev/null
@@ -1,45 +0,0 @@ 
-From e2ade2bfc46d915cd306c63c830b81d800b2575f Mon Sep 17 00:00:00 2001
-From: David Redondo <kde@david-redondo.de>
-Date: Fri, 10 Dec 2021 16:22:34 +0100
-Subject: [PATCH] Fix build against wayland 1.20
-
-Fixes #5088
-
-Upstream-Status: Backport [https://github.com/libsdl-org/SDL/pull/5092]
-
----
- src/video/wayland/SDL_waylanddyn.h | 2 ++
- src/video/wayland/SDL_waylandsym.h | 4 ++++
- 2 files changed, 6 insertions(+)
-
-diff --git a/src/video/wayland/SDL_waylanddyn.h b/src/video/wayland/SDL_waylanddyn.h
-index 13b0884..2268555 100644
---- a/src/video/wayland/SDL_waylanddyn.h
-+++ b/src/video/wayland/SDL_waylanddyn.h
-@@ -95,6 +95,8 @@ void SDL_WAYLAND_UnloadSymbols(void);
- #define wl_proxy_marshal_constructor_versioned (*WAYLAND_wl_proxy_marshal_constructor_versioned)
- #define wl_proxy_set_tag (*WAYLAND_wl_proxy_set_tag)
- #define wl_proxy_get_tag (*WAYLAND_wl_proxy_get_tag)
-+#define wl_proxy_marshal_flags (*WAYLAND_wl_proxy_marshal_flags)
-+#define wl_proxy_marshal_array_flags (*WAYLAND_wl_proxy_marshal_array_flags)
- 
- #define wl_seat_interface (*WAYLAND_wl_seat_interface)
- #define wl_surface_interface (*WAYLAND_wl_surface_interface)
-diff --git a/src/video/wayland/SDL_waylandsym.h b/src/video/wayland/SDL_waylandsym.h
-index d6e6a76..32e47d2 100644
---- a/src/video/wayland/SDL_waylandsym.h
-+++ b/src/video/wayland/SDL_waylandsym.h
-@@ -84,6 +84,10 @@ SDL_WAYLAND_MODULE(WAYLAND_CLIENT_1_18)
- SDL_WAYLAND_SYM(void, wl_proxy_set_tag, (struct wl_proxy *, const char * const *))
- SDL_WAYLAND_SYM(const char * const *, wl_proxy_get_tag, (struct wl_proxy *))
- 
-+SDL_WAYLAND_MODULE(WAYLAND_CLIENT_1_20)
-+SDL_WAYLAND_SYM(struct wl_proxy*, wl_proxy_marshal_flags, (struct wl_proxy *proxy, uint32_t opcode, const struct wl_interface *interfac, uint32_t version, uint32_t flags, ...))
-+SDL_WAYLAND_SYM(struct wl_proxy*, wl_proxy_marshal_array_flags, (struct wl_proxy *proxy, uint32_t opcode, const struct wl_interface *interface, uint32_t version,  uint32_t flags, union wl_argument *args))
-+
- SDL_WAYLAND_INTERFACE(wl_seat_interface)
- SDL_WAYLAND_INTERFACE(wl_surface_interface)
- SDL_WAYLAND_INTERFACE(wl_shm_pool_interface)
--- 
-2.7.4
-
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb
similarity index 93%
rename from meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
rename to meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb
index 6c949d9604..90724ab8b7 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.18.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb
@@ -8,7 +8,7 @@  BUGTRACKER = "http://bugzilla.libsdl.org/"
 SECTION = "libs"
 
 LICENSE = "Zlib"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=095c2687a3c3908e26984eaa8ec2d770"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=68a088513da90254b2fbe664f42af315"
 
 # arm-neon adds MIT license
 LICENSE:append = " ${@bb.utils.contains('PACKAGECONFIG', 'arm-neon', '& MIT', '', d)}"
@@ -17,14 +17,13 @@  LIC_FILES_CHKSUM:append = " ${@bb.utils.contains('PACKAGECONFIG', 'arm-neon', 'f
 PROVIDES = "virtual/libsdl2"
 
 SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \
-           file://0001-Fix-build-against-wayland-1.20.patch \
            file://optional-libunwind-generic.patch \
            file://0001-sdlchecks.cmake-pass-cflags-to-the-appropriate-cmake.patch \
-"
+           "
 
 S = "${WORKDIR}/SDL2-${PV}"
 
-SRC_URI[sha256sum] = "94d40cd73dbfa10bb6eadfbc28f355992bb2d6ef6761ad9d4074eff95ee5711c"
+SRC_URI[sha256sum] = "c56aba1d7b5b0e7e999e4a7698c70b63a3394ff9704b5f6e1c57e0c16f04dd06"
 
 inherit cmake lib_package binconfig-disabled pkgconfig