[v2] pango: upgrade 1.48.10 -> 1.50.0

Message ID 1639100843-17956-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [v2] pango: upgrade 1.48.10 -> 1.50.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 10, 2021, 1:47 a.m. UTC
Add patch 0001-Fix-bug-for-x86_64_x32.patch
to fix compile bug when building 32bit on x86_64 environment.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../pango/0001-Fix-bug-for-x86_64_x32.patch   | 55 +++++++++++++++++++
 .../{pango_1.48.10.bb => pango_1.50.0.bb}     |  4 +-
 2 files changed, 58 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
 rename meta/recipes-graphics/pango/{pango_1.48.10.bb => pango_1.50.0.bb} (91%)

Comments

Alexander Kanavin Dec. 10, 2021, 10:35 a.m. UTC | #1
+-#ifdef __x86_64__

I think the above simply needs to be adjusted to say 'if x86_64 and not
x32'?

Also, this does not resolve the newly occurring ptest failures.

Alex

On Fri, 10 Dec 2021 at 02:47, wangmy <wangmy@fujitsu.com> wrote:

> Add patch 0001-Fix-bug-for-x86_64_x32.patch
> to fix compile bug when building 32bit on x86_64 environment.
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../pango/0001-Fix-bug-for-x86_64_x32.patch   | 55 +++++++++++++++++++
>  .../{pango_1.48.10.bb => pango_1.50.0.bb}     |  4 +-
>  2 files changed, 58 insertions(+), 1 deletion(-)
>  create mode 100644
> meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
>  rename meta/recipes-graphics/pango/{pango_1.48.10.bb => pango_1.50.0.bb}
> (91%)
>
> diff --git
> a/meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
> b/meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
> new file mode 100644
> index 0000000000..9ab55879a4
> --- /dev/null
> +++ b/meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
> @@ -0,0 +1,55 @@
> +From 8e97429dfb9a2931c79658869da25b44014f8eba Mon Sep 17 00:00:00 2001
> +From: Wang Mingyu <wangmy@fujitsu.com>
> +Date: Thu, 9 Dec 2021 00:13:20 +0900
> +Subject: [PATCH] Fix bug for x86_64_x32
> +
> +When built 32-bit Pango on x86_64 environment, the following problems
> occured:
> +
> +error: size of array '_GStaticAssertCompileTimeAssertion_4' is negative
> +|   826 | #define G_STATIC_ASSERT(expr) typedef char G_PASTE
> (_GStaticAssertCompileTimeAssertion_, __COUNTER__)[(expr) ? 1 : -1]
> G_GNUC_UNUSED
> +
> +This problem can be solved by removing the judgement of arch.
> +
> +Upstream-Status: Inappropriate [
> https://gitlab.gnome.org/GNOME/pango/-/issues/637]
> +
> +Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> +---
> + pango/pango-item-private.h | 15 ---------------
> + 1 file changed, 15 deletions(-)
> +
> +diff --git a/pango/pango-item-private.h b/pango/pango-item-private.h
> +index d37fc3f..d49f2a6 100644
> +--- a/pango/pango-item-private.h
> ++++ b/pango/pango-item-private.h
> +@@ -40,19 +40,6 @@ G_BEGIN_DECLS
> +
> + typedef struct _PangoItemPrivate PangoItemPrivate;
> +
> +-#ifdef __x86_64__
> +-
> +-struct _PangoItemPrivate
> +-{
> +-  int offset;
> +-  int length;
> +-  int num_chars;
> +-  int char_offset;
> +-  PangoAnalysis analysis;
> +-};
> +-
> +-#else
> +-
> + struct _PangoItemPrivate
> + {
> +   int offset;
> +@@ -62,8 +49,6 @@ struct _PangoItemPrivate
> +   int char_offset;
> + };
> +
> +-#endif
> +-
> + G_STATIC_ASSERT (offsetof (PangoItem, offset) == offsetof
> (PangoItemPrivate, offset));
> + G_STATIC_ASSERT (offsetof (PangoItem, length) == offsetof
> (PangoItemPrivate, length));
> + G_STATIC_ASSERT (offsetof (PangoItem, num_chars) == offsetof
> (PangoItemPrivate, num_chars));
> +--
> +2.25.1
> +
> diff --git a/meta/recipes-graphics/pango/pango_1.48.10.bb
> b/meta/recipes-graphics/pango/pango_1.50.0.bb
> similarity index 91%
> rename from meta/recipes-graphics/pango/pango_1.48.10.bb
> rename to meta/recipes-graphics/pango/pango_1.50.0.bb
> index 40df7042e6..974e053b8f 100644
> --- a/meta/recipes-graphics/pango/pango_1.48.10.bb
> +++ b/meta/recipes-graphics/pango/pango_1.50.0.bb
> @@ -20,7 +20,9 @@ GIR_MESON_DISABLE_FLAG = "disabled"
>
>  SRC_URI += "file://run-ptest"
>
> -SRC_URI[archive.sha256sum] =
> "21e1f5798bcdfda75eabc4280514b0896ab56f656d4e7e66030b9a2535ecdc98"
> +SRC_URI:append:x86-x32 = " file://0001-Fix-bug-for-x86_64_x32.patch"
> +
> +SRC_URI[archive.sha256sum] =
> "dba8b62ddf86e10f73f93c3d2256b73238b2bcaf87037ca229b40bdc040eb3f3"
>
>  DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv
> cairo harfbuzz fribidi"
>
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#159488):
> https://lists.openembedded.org/g/openembedded-core/message/159488
> Mute This Topic: https://lists.openembedded.org/mt/87627577/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>

Patch

diff --git a/meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch b/meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
new file mode 100644
index 0000000000..9ab55879a4
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango/0001-Fix-bug-for-x86_64_x32.patch
@@ -0,0 +1,55 @@ 
+From 8e97429dfb9a2931c79658869da25b44014f8eba Mon Sep 17 00:00:00 2001
+From: Wang Mingyu <wangmy@fujitsu.com>
+Date: Thu, 9 Dec 2021 00:13:20 +0900
+Subject: [PATCH] Fix bug for x86_64_x32
+
+When built 32-bit Pango on x86_64 environment, the following problems occured:
+
+error: size of array '_GStaticAssertCompileTimeAssertion_4' is negative
+|   826 | #define G_STATIC_ASSERT(expr) typedef char G_PASTE (_GStaticAssertCompileTimeAssertion_, __COUNTER__)[(expr) ? 1 : -1] G_GNUC_UNUSED
+
+This problem can be solved by removing the judgement of arch.
+
+Upstream-Status: Inappropriate [https://gitlab.gnome.org/GNOME/pango/-/issues/637]
+
+Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
+---
+ pango/pango-item-private.h | 15 ---------------
+ 1 file changed, 15 deletions(-)
+
+diff --git a/pango/pango-item-private.h b/pango/pango-item-private.h
+index d37fc3f..d49f2a6 100644
+--- a/pango/pango-item-private.h
++++ b/pango/pango-item-private.h
+@@ -40,19 +40,6 @@ G_BEGIN_DECLS
+ 
+ typedef struct _PangoItemPrivate PangoItemPrivate;
+ 
+-#ifdef __x86_64__
+-
+-struct _PangoItemPrivate
+-{
+-  int offset;
+-  int length;
+-  int num_chars;
+-  int char_offset;
+-  PangoAnalysis analysis;
+-};
+-
+-#else
+-
+ struct _PangoItemPrivate
+ {
+   int offset;
+@@ -62,8 +49,6 @@ struct _PangoItemPrivate
+   int char_offset;
+ };
+ 
+-#endif
+-
+ G_STATIC_ASSERT (offsetof (PangoItem, offset) == offsetof (PangoItemPrivate, offset));
+ G_STATIC_ASSERT (offsetof (PangoItem, length) == offsetof (PangoItemPrivate, length));
+ G_STATIC_ASSERT (offsetof (PangoItem, num_chars) == offsetof (PangoItemPrivate, num_chars));
+-- 
+2.25.1
+
diff --git a/meta/recipes-graphics/pango/pango_1.48.10.bb b/meta/recipes-graphics/pango/pango_1.50.0.bb
similarity index 91%
rename from meta/recipes-graphics/pango/pango_1.48.10.bb
rename to meta/recipes-graphics/pango/pango_1.50.0.bb
index 40df7042e6..974e053b8f 100644
--- a/meta/recipes-graphics/pango/pango_1.48.10.bb
+++ b/meta/recipes-graphics/pango/pango_1.50.0.bb
@@ -20,7 +20,9 @@  GIR_MESON_DISABLE_FLAG = "disabled"
 
 SRC_URI += "file://run-ptest"
 
-SRC_URI[archive.sha256sum] = "21e1f5798bcdfda75eabc4280514b0896ab56f656d4e7e66030b9a2535ecdc98"
+SRC_URI:append:x86-x32 = " file://0001-Fix-bug-for-x86_64_x32.patch"
+
+SRC_URI[archive.sha256sum] = "dba8b62ddf86e10f73f93c3d2256b73238b2bcaf87037ca229b40bdc040eb3f3"
 
 DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"