wayland: upgrade 1.19.0 -> 1.20.0

Message ID 1639089018-30078-1-git-send-email-denis@denix.org
State Accepted, archived
Commit d81c8d137895e1fb70bb56c61d53502670d7bc43
Headers show
Series wayland: upgrade 1.19.0 -> 1.20.0 | expand

Commit Message

Denys Dmytriyenko Dec. 9, 2021, 10:30 p.m. UTC
Wayland 1.20.0 is released!

This release contains the following major changes:

- FreeBSD support has been entirely upstreamed and has been added to
  our continuous integration system.
- The autotools build system has been dropped. Meson has replaced it.
- A few protocol additions: wl_surface.offset allows clients to update
  a surface's buffer offset independently from the buffer,
  wl_output.name and description allow clients to identify outputs
  without depending on xdg-output-unstable-v1.
- In protocol definitions, events have a new "type" attribute and can
  now be marked as destructors.
- A number of bug fixes, including a race condition when destroying
  proxies in multi-threaded clients.

Drop patch to fix strndup detection on MinGW that no longer applies, as
meson claims to had that fixed since version 0.54.2

Signed-off-by: Denys Dmytriyenko <denis@denix.org>
---
 ...0001-build-Fix-strndup-detection-on-MinGW.patch | 37 ----------------------
 .../{wayland_1.19.0.bb => wayland_1.20.0.bb}       |  3 +-
 2 files changed, 1 insertion(+), 39 deletions(-)
 delete mode 100644 meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch
 rename meta/recipes-graphics/wayland/{wayland_1.19.0.bb => wayland_1.20.0.bb} (93%)

Comments

Richard Purdie Dec. 11, 2021, 11:02 a.m. UTC | #1
On Thu, 2021-12-09 at 17:30 -0500, Denys Dmytriyenko wrote:
> Wayland 1.20.0 is released!
> 
> This release contains the following major changes:
> 
> - FreeBSD support has been entirely upstreamed and has been added to
>   our continuous integration system.
> - The autotools build system has been dropped. Meson has replaced it.
> - A few protocol additions: wl_surface.offset allows clients to update
>   a surface's buffer offset independently from the buffer,
>   wl_output.name and description allow clients to identify outputs
>   without depending on xdg-output-unstable-v1.
> - In protocol definitions, events have a new "type" attribute and can
>   now be marked as destructors.
> - A number of bug fixes, including a race condition when destroying
>   proxies in multi-threaded clients.
> 
> Drop patch to fix strndup detection on MinGW that no longer applies, as
> meson claims to had that fixed since version 0.54.2
> 
> Signed-off-by: Denys Dmytriyenko <denis@denix.org>
> ---
>  ...0001-build-Fix-strndup-detection-on-MinGW.patch | 37 ----------------------
>  .../{wayland_1.19.0.bb => wayland_1.20.0.bb}       |  3 +-
>  2 files changed, 1 insertion(+), 39 deletions(-)
>  delete mode 100644 meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch
>  rename meta/recipes-graphics/wayland/{wayland_1.19.0.bb => wayland_1.20.0.bb} (93%)
> 
> diff --git a/meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch b/meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch
> deleted file mode 100644
> index ad1063b..0000000
> --- a/meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch
> +++ /dev/null
> @@ -1,37 +0,0 @@
> -From 6a6223a8e217664a348835e92d5a602f50e18b2c Mon Sep 17 00:00:00 2001
> -From: Joshua Watt <JPEWhacker@gmail.com>
> -Date: Thu, 20 Feb 2020 15:20:45 -0600
> -Subject: [PATCH] build: Fix strndup detection on MinGW
> -
> -GCC and meson conspire together to incorrectly detect that strndup()
> -exists on MinGW as __builtin_strndup, when no such function exists. As a
> -work around, meson will skip looking for __builtin functions if an
> -'#include' is in the prefix, so add '#include <string.h>' when looking
> -for strndup().
> -
> -See: https://github.com/mesonbuild/meson/issues/3672
> -
> -Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
> -Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/wayland/merge_requests/63]
> -
> ----
> - meson.build | 2 +-
> - 1 file changed, 1 insertion(+), 1 deletion(-)
> -
> -diff --git a/meson.build b/meson.build
> -index 11c35fa..80729d0 100644
> ---- a/meson.build
> -+++ b/meson.build
> -@@ -36,11 +36,11 @@ have_funcs = [
> - 	'posix_fallocate',
> - 	'prctl',
> - 	'memfd_create',
> --	'strndup',
> - ]
> - foreach f: have_funcs
> - 	config_h.set('HAVE_' + f.underscorify().to_upper(), cc.has_function(f))
> - endforeach
> -+config_h.set('HAVE_STRNDUP', cc.has_function('strndup') and cc.has_header_symbol('string.h', 'strndup'))
> - 
> - if get_option('libraries')
> - 	ffi_dep = dependency('libffi')
> diff --git a/meta/recipes-graphics/wayland/wayland_1.19.0.bb b/meta/recipes-graphics/wayland/wayland_1.20.0.bb
> similarity index 93%
> rename from meta/recipes-graphics/wayland/wayland_1.19.0.bb
> rename to meta/recipes-graphics/wayland/wayland_1.20.0.bb
> index 4c9ae0f..e984414 100644
> --- a/meta/recipes-graphics/wayland/wayland_1.19.0.bb
> +++ b/meta/recipes-graphics/wayland/wayland_1.20.0.bb
> @@ -15,9 +15,8 @@ DEPENDS = "expat libffi wayland-native"
>  SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
>             file://run-ptest \
>             file://0002-Do-not-hardcode-the-path-to-wayland-scanner.patch \
> -           file://0001-build-Fix-strndup-detection-on-MinGW.patch \
>             "
> -SRC_URI[sha256sum] = "baccd902300d354581cd5ad3cc49daa4921d55fb416a5883e218750fef166d15"
> +SRC_URI[sha256sum] = "b8a034154c7059772e0fdbd27dbfcda6c732df29cae56a82274f6ec5d7cd8725"
>  
>  UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
> 

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/2640/steps/11/logs/stdio

and there may be more to follow :(

Cheers,

Richard

Patch

diff --git a/meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch b/meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch
deleted file mode 100644
index ad1063b..0000000
--- a/meta/recipes-graphics/wayland/wayland/0001-build-Fix-strndup-detection-on-MinGW.patch
+++ /dev/null
@@ -1,37 +0,0 @@ 
-From 6a6223a8e217664a348835e92d5a602f50e18b2c Mon Sep 17 00:00:00 2001
-From: Joshua Watt <JPEWhacker@gmail.com>
-Date: Thu, 20 Feb 2020 15:20:45 -0600
-Subject: [PATCH] build: Fix strndup detection on MinGW
-
-GCC and meson conspire together to incorrectly detect that strndup()
-exists on MinGW as __builtin_strndup, when no such function exists. As a
-work around, meson will skip looking for __builtin functions if an
-'#include' is in the prefix, so add '#include <string.h>' when looking
-for strndup().
-
-See: https://github.com/mesonbuild/meson/issues/3672
-
-Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
-Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/wayland/merge_requests/63]
-
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index 11c35fa..80729d0 100644
---- a/meson.build
-+++ b/meson.build
-@@ -36,11 +36,11 @@ have_funcs = [
- 	'posix_fallocate',
- 	'prctl',
- 	'memfd_create',
--	'strndup',
- ]
- foreach f: have_funcs
- 	config_h.set('HAVE_' + f.underscorify().to_upper(), cc.has_function(f))
- endforeach
-+config_h.set('HAVE_STRNDUP', cc.has_function('strndup') and cc.has_header_symbol('string.h', 'strndup'))
- 
- if get_option('libraries')
- 	ffi_dep = dependency('libffi')
diff --git a/meta/recipes-graphics/wayland/wayland_1.19.0.bb b/meta/recipes-graphics/wayland/wayland_1.20.0.bb
similarity index 93%
rename from meta/recipes-graphics/wayland/wayland_1.19.0.bb
rename to meta/recipes-graphics/wayland/wayland_1.20.0.bb
index 4c9ae0f..e984414 100644
--- a/meta/recipes-graphics/wayland/wayland_1.19.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.20.0.bb
@@ -15,9 +15,8 @@  DEPENDS = "expat libffi wayland-native"
 SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
            file://run-ptest \
            file://0002-Do-not-hardcode-the-path-to-wayland-scanner.patch \
-           file://0001-build-Fix-strndup-detection-on-MinGW.patch \
            "
-SRC_URI[sha256sum] = "baccd902300d354581cd5ad3cc49daa4921d55fb416a5883e218750fef166d15"
+SRC_URI[sha256sum] = "b8a034154c7059772e0fdbd27dbfcda6c732df29cae56a82274f6ec5d7cd8725"
 
 UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"