lighttpd: upgrade 1.4.61 -> 1.4.63

Message ID 1638835566-3825-1-git-send-email-zhengrq.fnst@fujitsu.com
State Accepted, archived
Commit 84de86213709abbd9dd3c61105652e7fafce5615
Headers show
Series lighttpd: upgrade 1.4.61 -> 1.4.63 | expand

Commit Message

zhengrq.fnst@fujitsu.com Dec. 7, 2021, 12:06 a.m. UTC
refresh 0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch

Changelog from 1.4.61:
========================================
Important changes:
support pcre2; HTTP Digest auth userhash

bugfixes:
[mod_alias] fix use-after-free bug (fixes #3114)
[core] clean up fdlog_st and log_error_st decls
[core] 'struct log_error_st'->'log_error_st'
[core] remove redundant asserts
[core] explicitly include sys/cdefs.h
[tests] t/test_mod_ssi
[core] fdevent_socket_nb_cloexec_init()
[core] fdevent_impl.c separate from fdevent.c
[core] merge fdevent impls into fdevent_impl.c
[core] fdevent_fdnode.c separate from fdevent.c
[core] close backend socket fds more quickly
[core] use TCP_CORK w/ TLS if cq length > 16k
[core] warn if dynamic modules before mod_auth
[mod_cgi] check fd-to-cgi not -1 before close
[core] libev EV_ERROR conflicts with kqueue
[tests] disable test_mod_ssi in cmake (temporary)
[tests] disable test_mod_ssi in cmake (temporary)
[tests] reenable test_mod_ssi in cmake
[core] run plugin cleanup hooks in reverse
[core] fix removal of server.pid-file when testing (fixes #3115)
[doc] improve sample configs
[doc] expand vhosts.template
[doc] improve sample configs
[core] use ck_assert() in vector.[ch]
[tests] mod_ssi tests moved to src/t/test_mod_ssi
[mod_ssi] 0-init ssi_val_t in ssi_ctx_t
[mod_ssi] fix ancient bugs; replace cond parser
[mod_ssi] remove mod_ssi parser generator file
[mod_ssi] merge mod_ssi_expr.c into mod_ssi.c
[core] uint_fast32_t tweaks
[core] better asm for binary num to ascii string
[tests] t/test_mod now runs all t/test_mod_*.c
[tests] t/test_mod_alias.c
[tests] remove unused mod from tests/lighttpd.conf
[mod_evasive] smaller funcs for testing
[tests] t/test_mod_evasive.c
[mod_evasive] update comment to add references
[tests] combine tests into test_common.c
[core] get_http_method_key() tweak
[mod_dirlisting] check for disabled cache at start
[core] buffer_append_string_encoded_json()
[mod_dirlisting] (experimental) json (disabled)
[tests] t/test_mod needs -ldl on Debian
[core] save config regex captures only if used
[core] save pcre result state in config_pcre_match
[core] use stack w/ pcre_exec unless save captures
[core] extend pcre_keyvalue_ctx to pass more state
[core] pcre2 support (—with-pcre2)
[core] allocate one fewer cond_match_t, if needed
[core] allocate pcre output vector on demand
[build] configure.ac with AC_PROG_CC_C99 (fixes #3116)
[build] CI builds now use pcre2 (upgrade pcre)
[core] fix compiler warning in 32-bit build
[build] fix CMake pcre2 detection
[mod_auth] RFC7616 HTTP Digest username* userhash
[mod_dirlisting] fix bug not showing HEADER.txt
[tests] t/test_mod_ssi adjust to follow symlinks
[mod_auth] quiet coverity warning
[doc] refresh/update dependency lists in doc
[core] fix crash when using lighttpd -1 with pipes (fixes #3117)
[core] import xxHash v0.8.1
[core] isolate use of sys/filio.h
[core] fix reqpool mem corruption in 1.4.62 (fixes #3118)

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
---
 ...or-pcre-dependency-instead-of-config.patch | 25 ++++++++++---------
 ...{lighttpd_1.4.61.bb => lighttpd_1.4.63.bb} |  2 +-
 2 files changed, 14 insertions(+), 13 deletions(-)
 rename meta/recipes-extended/lighttpd/{lighttpd_1.4.61.bb => lighttpd_1.4.63.bb} (97%)

Patch

diff --git a/meta/recipes-extended/lighttpd/lighttpd/0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch b/meta/recipes-extended/lighttpd/lighttpd/0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch
index f17bdce2c0..b60102ecc1 100644
--- a/meta/recipes-extended/lighttpd/lighttpd/0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch
+++ b/meta/recipes-extended/lighttpd/lighttpd/0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch
@@ -6,28 +6,29 @@  Subject: [PATCH] Use pkg-config for pcre dependency instead of -config script.
 RP 2014/5/22
 Upstream-Status: Pending
 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+
 ---
  configure.ac | 16 ++++++++++++----
  1 file changed, 12 insertions(+), 4 deletions(-)
 
 diff --git a/configure.ac b/configure.ac
-index 5383cec..c29a902 100644
+index 806347b..81a7997 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -651,10 +651,18 @@ AC_ARG_WITH([pcre],
+@@ -913,10 +913,18 @@ AC_ARG_WITH([pcre2],
  )
- AC_MSG_RESULT([$WITH_PCRE])
+ AC_MSG_RESULT([$WITH_PCRE2])
  
--if test "$WITH_PCRE" != no; then
--  if test "$WITH_PCRE" != yes; then
--    PCRE_LIB="-L$WITH_PCRE/lib -lpcre"
+-if test "$WITH_PCRE2" != no; then
+-  if test "$WITH_PCRE2" != yes; then
+-    PCRE_LIB="-L$WITH_PCRE2/lib -lpcre2-8"
 -    CPPFLAGS="$CPPFLAGS -I$WITH_PCRE/include"
 +if test "$WITH_PCRE" != "no"; then
 +  PKG_CHECK_MODULES(PCREPKG, [libpcre], [
-+				PCRE_LIB=${PCREPKG_LIBS}
-+				CPPFLAGS="$CPPFLAGS ${PCREPKG_CFLAGS}"
++                               PCRE_LIB=${PCREPKG_LIBS}
++                               CPPFLAGS="$CPPFLAGS ${PCREPKG_CFLAGS}"
 +  ], [
-+				AC_MSG_ERROR([pcre pkgconfig not found, install the pcre-devel package or build with --without-pcre])
++                               AC_MSG_ERROR([pcre pkgconfig not found, install the pcre-devel package or build with --without-pcre])
 +  ])
 +
 +  if test x"$PCRE_LIB" != x; then
@@ -35,8 +36,8 @@  index 5383cec..c29a902 100644
 +    AC_DEFINE([HAVE_PCRE_H], [1], [pcre.h])
 +    AC_SUBST(PCRE_LIB)
    else
-     AC_PATH_PROG([PCRECONFIG], [pcre-config])
-     if test -n "$PCRECONFIG"; then
+     AC_PATH_PROG([PCRE2CONFIG], [pcre2-config])
+     if test -n "$PCRE2CONFIG"; then
 -- 
-2.15.0
+2.25.1
 
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.61.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.63.bb
similarity index 97%
rename from meta/recipes-extended/lighttpd/lighttpd_1.4.61.bb
rename to meta/recipes-extended/lighttpd/lighttpd_1.4.63.bb
index 32b0ae4ace..6c1476be1a 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.61.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.63.bb
@@ -20,7 +20,7 @@  SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
            file://0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch \
            "
 
-SRC_URI[sha256sum] = "43f0d63d04a1b7c5b8aab07e0612e44ccad0afc0614bab784c5b019872363432"
+SRC_URI[sha256sum] = "2aef7f0102ebf54a1241a1c3ea8976892f8684bfb21697c9fffb8de0e2d6eab9"
 
 DEPENDS = "virtual/crypt"