[meta-oe] s-nail: Set VAL_MTA

Message ID 20220505093308.824156-1-mingli.yu@windriver.com
State Under Review
Headers show
Series [meta-oe] s-nail: Set VAL_MTA | expand

Commit Message

Yu, Mingli May 5, 2022, 9:33 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Some build server may provide sendmail like /usr/lib/sendmail which
may result the VAL_MTA to be /usr/lib/sendmail during do_configure,
but the sendmail is actually /usr/sbin/sendmail on the target.

Fixes:
  # echo "invalide address email" | s-nail -s "test mail" -r test@test.com tester@test.com
  s-nail: Cannot start /usr/lib/sendmail: executable not found (adjust *mta* variable)
  /home/root/dead.letter 10/234
  s-nail: ... message not sent

  # which sendmail
  /usr/sbin/sendmail

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 .../files/0001-make.rc-set-VAL_MTA.patch      | 48 +++++++++++++++++++
 .../recipes-extended/s-nail/s-nail_14.9.24.bb |  3 +-
 2 files changed, 50 insertions(+), 1 deletion(-)
 create mode 100644 meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch

Comments

Khem Raj May 5, 2022, 6:39 p.m. UTC | #1
Can we pass VAL_MTA from recipe via EXTRA_OEMAKE or something ?

On Thu, May 5, 2022 at 2:33 AM Yu, Mingli <mingli.yu@windriver.com> wrote:
>
> From: Mingli Yu <mingli.yu@windriver.com>
>
> Some build server may provide sendmail like /usr/lib/sendmail which
> may result the VAL_MTA to be /usr/lib/sendmail during do_configure,
> but the sendmail is actually /usr/sbin/sendmail on the target.
>
> Fixes:
>   # echo "invalide address email" | s-nail -s "test mail" -r test@test.com tester@test.com
>   s-nail: Cannot start /usr/lib/sendmail: executable not found (adjust *mta* variable)
>   /home/root/dead.letter 10/234
>   s-nail: ... message not sent
>
>   # which sendmail
>   /usr/sbin/sendmail
>
> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> ---
>  .../files/0001-make.rc-set-VAL_MTA.patch      | 48 +++++++++++++++++++
>  .../recipes-extended/s-nail/s-nail_14.9.24.bb |  3 +-
>  2 files changed, 50 insertions(+), 1 deletion(-)
>  create mode 100644 meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch
>
> diff --git a/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch b/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch
> new file mode 100644
> index 000000000..f4decda14
> --- /dev/null
> +++ b/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch
> @@ -0,0 +1,48 @@
> +From da8c7a027390de7828d4272a3c8bcdbffbac25ad Mon Sep 17 00:00:00 2001
> +From: Mingli Yu <mingli.yu@windriver.com>
> +Date: Thu, 5 May 2022 16:57:48 +0800
> +Subject: [PATCH] make.rc: set VAL_MTA
> +
> +Some build server may provide sendmail like /usr/lib/sendmail which
> +may result the VAL_MTA to be /usr/lib/sendmail, but the sendmail
> +is actually /usr/sbin/sendmail on the target.
> +
> +Fixes:
> +  # echo "invalide address email" | s-nail -s "test mail" -r test@test.com tester@test.com
> +  s-nail: Cannot start /usr/lib/sendmail: executable not found (adjust *mta* variable)
> +  /home/root/dead.letter 10/234
> +  s-nail: ... message not sent
> +
> +  # which sendmail
> +  /usr/sbin/sendmail
> +
> +Upstream-Status: Inappropriate[oe-specific]
> +
> +Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> +---
> + make.rc | 9 +--------
> + 1 file changed, 1 insertion(+), 8 deletions(-)
> +
> +diff --git a/make.rc b/make.rc
> +index 98bd968..45ac0d4 100644
> +--- a/make.rc
> ++++ b/make.rc
> +@@ -96,14 +96,7 @@ VAL_MAIL=`\
> +
> + # Path to the local MTA (Mail-Transfer-Agent).
> + # MTA aliases (aliases(5)) are optionally supported via OPT_MTA_ALIASES.
> +-VAL_MTA=`\
> +-   if [ -x /usr/bin/sendmail ]; then \
> +-      echo /usr/bin/sendmail;\
> +-   elif [ -x /usr/lib/sendmail ]; then \
> +-      echo /usr/lib/sendmail;\
> +-   else \
> +-      echo /usr/sbin/sendmail;\
> +-   fi`
> ++VAL_MTA=/usr/sbin/sendmail
> +
> + # Today a lot of systems no longer use sendmail(1), but a different MTA.
> + # To ensure compatibility with sendmail(1), a system called
> +--
> +2.25.1
> +
> diff --git a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb b/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb
> index bc514b577..539f9c3c8 100644
> --- a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb
> +++ b/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb
> @@ -6,7 +6,8 @@ LICENSE = "ISC & BSD-3-Clause & BSD-4-Clause"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=87266591c81260f10221f1f38872d023"
>
>  SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \
> -           file://make-errors.patch"
> +           file://make-errors.patch \
> +           file://0001-make.rc-set-VAL_MTA.patch"
>  SRC_URI[sha256sum] = "2714d6b8fb2af3b363fc7c79b76d058753716345d1b6ebcd8870ecd0e4f7ef8c"
>
>  DEPENDS = "coreutils-native"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#96959): https://lists.openembedded.org/g/openembedded-devel/message/96959
> Mute This Topic: https://lists.openembedded.org/mt/90907417/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch b/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch
new file mode 100644
index 000000000..f4decda14
--- /dev/null
+++ b/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch
@@ -0,0 +1,48 @@ 
+From da8c7a027390de7828d4272a3c8bcdbffbac25ad Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Thu, 5 May 2022 16:57:48 +0800
+Subject: [PATCH] make.rc: set VAL_MTA
+
+Some build server may provide sendmail like /usr/lib/sendmail which
+may result the VAL_MTA to be /usr/lib/sendmail, but the sendmail
+is actually /usr/sbin/sendmail on the target.
+
+Fixes:
+  # echo "invalide address email" | s-nail -s "test mail" -r test@test.com tester@test.com
+  s-nail: Cannot start /usr/lib/sendmail: executable not found (adjust *mta* variable)
+  /home/root/dead.letter 10/234
+  s-nail: ... message not sent
+
+  # which sendmail
+  /usr/sbin/sendmail
+
+Upstream-Status: Inappropriate[oe-specific]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ make.rc | 9 +--------
+ 1 file changed, 1 insertion(+), 8 deletions(-)
+
+diff --git a/make.rc b/make.rc
+index 98bd968..45ac0d4 100644
+--- a/make.rc
++++ b/make.rc
+@@ -96,14 +96,7 @@ VAL_MAIL=`\
+ 
+ # Path to the local MTA (Mail-Transfer-Agent).
+ # MTA aliases (aliases(5)) are optionally supported via OPT_MTA_ALIASES.
+-VAL_MTA=`\
+-   if [ -x /usr/bin/sendmail ]; then \
+-      echo /usr/bin/sendmail;\
+-   elif [ -x /usr/lib/sendmail ]; then \
+-      echo /usr/lib/sendmail;\
+-   else \
+-      echo /usr/sbin/sendmail;\
+-   fi`
++VAL_MTA=/usr/sbin/sendmail
+ 
+ # Today a lot of systems no longer use sendmail(1), but a different MTA.
+ # To ensure compatibility with sendmail(1), a system called
+-- 
+2.25.1
+
diff --git a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb b/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb
index bc514b577..539f9c3c8 100644
--- a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb
+++ b/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb
@@ -6,7 +6,8 @@  LICENSE = "ISC & BSD-3-Clause & BSD-4-Clause"
 LIC_FILES_CHKSUM = "file://COPYING;md5=87266591c81260f10221f1f38872d023"
 
 SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \
-           file://make-errors.patch"
+           file://make-errors.patch \
+           file://0001-make.rc-set-VAL_MTA.patch"
 SRC_URI[sha256sum] = "2714d6b8fb2af3b363fc7c79b76d058753716345d1b6ebcd8870ecd0e4f7ef8c"
 
 DEPENDS = "coreutils-native"