[2/2] musl-locales: explicitly depend on gettext-native

Message ID 20220428125559.2994529-2-ross.burton@arm.com
State Accepted, archived
Commit 77ae1fe772f12677f9d86946d09d10534845723f
Headers show
Series [1/2] distro/poky-tiny: don't put translations into images | expand

Commit Message

Ross Burton April 28, 2022, 12:55 p.m. UTC
The gettext class is designed for use by applications with optional NLS
support: depending on the value of USE_NLS it will either depend on
gettext-minimal-native (just the autoconf macros) or gettext-native, and
will pass --enable-nls/--disable-nls as appropriate.

However, musl-locales specifically needs to run msgfmt at runtime,
so explicitly depend on gettext-native instead.

Also remove the redundant EXTRA_OECMAKE assignment.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-core/musl/musl-locales_git.bb | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Patch

diff --git a/meta/recipes-core/musl/musl-locales_git.bb b/meta/recipes-core/musl/musl-locales_git.bb
index fa814d2bd9..40b20e250d 100644
--- a/meta/recipes-core/musl/musl-locales_git.bb
+++ b/meta/recipes-core/musl/musl-locales_git.bb
@@ -14,14 +14,12 @@  SRCREV = "1101fb2bcdd189cd9415b8bd1c775eb43527d25c"
 
 S = "${WORKDIR}/git"
 
-DEPENDS = "virtual/libintl"
+DEPENDS = "virtual/libintl gettext-native"
 
 PROVIDES = "virtual/libc-locale"
 
-inherit cmake gettext
+inherit cmake
 
-EXTRA_OECMAKE = ""
-#
 # We will skip parsing for non-musl systems
 python () {
     if d.getVar('TCLIBC') != "musl":