[meta-python] python3-wxgtk4: add distro feature check to match dependency

Message ID 20220404124425.42692-1-davide.gardenal@huawei.com
State New
Headers show
Series [meta-python] python3-wxgtk4: add distro feature check to match dependency | expand

Commit Message

Davide Gardenal April 4, 2022, 12:44 p.m. UTC
Add REQUIRED_DISTRO_FEATURE to match wxwidgets,
this fix build error (not buildable target) when x11 is not supported

Signed-off-by: Davide Gardenal <davide.gardenal@huawei.com>
---
 .../recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb   | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Robert Yang April 9, 2022, 8:28 a.m. UTC | #1
Hello,

On 4/4/22 20:44, Davide Gardenal wrote:
> Add REQUIRED_DISTRO_FEATURE to match wxwidgets,
> this fix build error (not buildable target) when x11 is not supported
> 
> Signed-off-by: Davide Gardenal <davide.gardenal@huawei.com>
> ---
>   .../recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb   | 4 ++++
>   1 file changed, 4 insertions(+)
> 
> diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
> index e61b00efa..dcb373a1f 100644
> --- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
> +++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
> @@ -4,6 +4,10 @@ HOMEPAGE = "http://www.wxpython.org"
>   LICENSE = "WXwindows"
>   LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
>   
> +inherit features_check
> +
> +REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"

The fix isn't correct enough since there is no PACKAGECONFIG for python3-wxgtk4, 
I will send another patch based on this.

// Robert


> +
>   DEPENDS = "wxwidgets-native wxwidgets"
>   
>   PYPI_PACKAGE = "wxPython"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#96377): https://lists.openembedded.org/g/openembedded-devel/message/96377
> Mute This Topic: https://lists.openembedded.org/mt/90240535/3616940
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [liezhi.yang@windriver.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index e61b00efa..dcb373a1f 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -4,6 +4,10 @@  HOMEPAGE = "http://www.wxpython.org"
 LICENSE = "WXwindows"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce1d18e2d633d41786c0a8dfbc80917"
 
+inherit features_check
+
+REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'no_gui', '', 'x11', d)}"
+
 DEPENDS = "wxwidgets-native wxwidgets"
 
 PYPI_PACKAGE = "wxPython"