[meta-python,v2] python3-pyscaffold: fix wheel build and license

Message ID 20220302174325.25744-1-jsbronder@cold-front.org
State New
Headers show
Series [meta-python,v2] python3-pyscaffold: fix wheel build and license | expand

Commit Message

Justin Bronder March 2, 2022, 5:43 p.m. UTC
Without python3-setuptools-scm-native, the version on the generated
wheel is 0.0.0, not ${PV} as expected which causes
pip_install_wheel_do_install to fail to find the wheel.

Consulting the LICENSE.txt distributed with the source, the template
files under pyscaffold.templates, which are installed as part of this
recipe, are licensed as BSD-0-Clause

Signed-off-by: Justin Bronder <jsbronder@cold-front.org>
---
 .../python/python3-pyscaffold_4.1.4.bb             | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb b/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb
index 7e5599e4aa..fbba75c435 100644
--- a/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb
@@ -5,18 +5,18 @@  used to create template Projects."
 
 HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
 SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
-
-inherit pypi setuptools3
-
-PYPI_PACKAGE = "PyScaffold"
+LICENSE = "0BSD & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
+DEPENDS += "python3-setuptools-scm-native"
 
 SRC_URI[sha256sum] = "46a2bbdf255ba2efc6c56ae1428249b61d56c4a3e54ef3db0d05fa97792011a5"
 
-BBCLASSEXTEND = "native nativesdk"
+inherit pypi setuptools3
+PYPI_PACKAGE = "PyScaffold"
 
 RDEPENDS:${PN} += " \
 	python3-email \
 	python3-compression \
 "
+
+BBCLASSEXTEND = "native nativesdk"