[2/3] perl: Makefile.PL: Fix _PATH_LOG for deterministic build

Message ID d4b25c6c4a2a48da96da92bd03fe060e0cb37547.1646204967.git.liezhi.yang@windriver.com
State New
Headers show
Series [1/3] quilt: Disable external sendmail for deterministic build | expand

Commit Message

Robert Yang March 2, 2022, 7:12 a.m. UTC
It checks host's path such as /dev/log and uses it, this doesn't make sense for
cross build, and it causes undeterministic, for example, the contianer os
usually doesn't have /dev/log which leads to a different build result since
other host usually has /dev/log, so make it always use the default value to fix
the issue.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
---
 ...Makefile.PL-Fix-_PATH_LOG-for-determ.patch | 34 +++++++++++++++++++
 meta/recipes-devtools/perl/perl_5.34.0.bb     |  1 +
 2 files changed, 35 insertions(+)
 create mode 100644 meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch

Comments

Alexander Kanavin March 2, 2022, 8:42 a.m. UTC | #1
Can you file a ticket upstream for this please, and include the link
in the patch?

Alex

On Wed, 2 Mar 2022 at 08:13, Robert Yang <liezhi.yang@windriver.com> wrote:
>
> It checks host's path such as /dev/log and uses it, this doesn't make sense for
> cross build, and it causes undeterministic, for example, the contianer os
> usually doesn't have /dev/log which leads to a different build result since
> other host usually has /dev/log, so make it always use the default value to fix
> the issue.
>
> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
> ---
>  ...Makefile.PL-Fix-_PATH_LOG-for-determ.patch | 34 +++++++++++++++++++
>  meta/recipes-devtools/perl/perl_5.34.0.bb     |  1 +
>  2 files changed, 35 insertions(+)
>  create mode 100644 meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>
> diff --git a/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
> new file mode 100644
> index 00000000000..f6bcbce6856
> --- /dev/null
> +++ b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
> @@ -0,0 +1,34 @@
> +From a73fff1fcf0def4ce93964f1b63fe3ad0967259d Mon Sep 17 00:00:00 2001
> +From: Robert Yang <liezhi.yang@windriver.com>
> +Date: Fri, 18 Feb 2022 09:44:26 +0000
> +Subject: [PATCH] cpan/Sys-Syslog/Makefile.PL: Fix _PATH_LOG for deterministic
> +
> +It checks host's path such as /dev/log and uses it, this doesn't make sense for
> +cross build, and it causes undeterministic, for example, the contianer os
> +usually doesn't have /dev/log which leads to a different build result since
> +other host usually has /dev/log, so make it always use the default value to fix
> +the issue.
> +
> +Upstream-Status:Inappropriate [OE specific]
> +
> +Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
> +---
> + cpan/Sys-Syslog/Makefile.PL | 2 ++
> + 1 file changed, 2 insertions(+)
> +
> +diff --git a/cpan/Sys-Syslog/Makefile.PL b/cpan/Sys-Syslog/Makefile.PL
> +index d09ba69..d44e58c 100644
> +--- a/cpan/Sys-Syslog/Makefile.PL
> ++++ b/cpan/Sys-Syslog/Makefile.PL
> +@@ -130,6 +130,8 @@ else {
> +     $_PATH_LOG = "";
> + }
> +
> ++# OE specific
> ++$_PATH_LOG = "";
> +
> + # if possible, generate the code that handles the constants with
> + # ExtUtils::Constant, otherwise use cached copy in fallback/
> +--
> +2.31.1
> +
> diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
> index a97da872032..8a1db7ed359 100644
> --- a/meta/recipes-devtools/perl/perl_5.34.0.bb
> +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
> @@ -20,6 +20,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
>             file://aacd2398e766500cb5d83c4d76b642fcf31d997a.patch \
>             file://ea57297a58b8f10ab885c19eec48ea076116cc1f.patch \
>             file://5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch \
> +           file://0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch \
>             "
>  SRC_URI:append:class-native = " \
>             file://perl-configpm-switch.patch \
> --
> 2.31.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#162590): https://lists.openembedded.org/g/openembedded-core/message/162590
> Mute This Topic: https://lists.openembedded.org/mt/89496472/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Robert Yang March 2, 2022, 8:47 a.m. UTC | #2
Hi

On 3/2/22 4:42 PM, Alexander Kanavin wrote:
> Can you file a ticket upstream for this please, and include the link
> in the patch?
> 

This patch won't work for upstream, only work by cross building, let me check on 
how to make it work for all cases.

// Robert


> Alex
> 
> On Wed, 2 Mar 2022 at 08:13, Robert Yang <liezhi.yang@windriver.com> wrote:
>>
>> It checks host's path such as /dev/log and uses it, this doesn't make sense for
>> cross build, and it causes undeterministic, for example, the contianer os
>> usually doesn't have /dev/log which leads to a different build result since
>> other host usually has /dev/log, so make it always use the default value to fix
>> the issue.
>>
>> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
>> ---
>>   ...Makefile.PL-Fix-_PATH_LOG-for-determ.patch | 34 +++++++++++++++++++
>>   meta/recipes-devtools/perl/perl_5.34.0.bb     |  1 +
>>   2 files changed, 35 insertions(+)
>>   create mode 100644 meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>>
>> diff --git a/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>> new file mode 100644
>> index 00000000000..f6bcbce6856
>> --- /dev/null
>> +++ b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>> @@ -0,0 +1,34 @@
>> +From a73fff1fcf0def4ce93964f1b63fe3ad0967259d Mon Sep 17 00:00:00 2001
>> +From: Robert Yang <liezhi.yang@windriver.com>
>> +Date: Fri, 18 Feb 2022 09:44:26 +0000
>> +Subject: [PATCH] cpan/Sys-Syslog/Makefile.PL: Fix _PATH_LOG for deterministic
>> +
>> +It checks host's path such as /dev/log and uses it, this doesn't make sense for
>> +cross build, and it causes undeterministic, for example, the contianer os
>> +usually doesn't have /dev/log which leads to a different build result since
>> +other host usually has /dev/log, so make it always use the default value to fix
>> +the issue.
>> +
>> +Upstream-Status:Inappropriate [OE specific]
>> +
>> +Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
>> +---
>> + cpan/Sys-Syslog/Makefile.PL | 2 ++
>> + 1 file changed, 2 insertions(+)
>> +
>> +diff --git a/cpan/Sys-Syslog/Makefile.PL b/cpan/Sys-Syslog/Makefile.PL
>> +index d09ba69..d44e58c 100644
>> +--- a/cpan/Sys-Syslog/Makefile.PL
>> ++++ b/cpan/Sys-Syslog/Makefile.PL
>> +@@ -130,6 +130,8 @@ else {
>> +     $_PATH_LOG = "";
>> + }
>> +
>> ++# OE specific
>> ++$_PATH_LOG = "";
>> +
>> + # if possible, generate the code that handles the constants with
>> + # ExtUtils::Constant, otherwise use cached copy in fallback/
>> +--
>> +2.31.1
>> +
>> diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
>> index a97da872032..8a1db7ed359 100644
>> --- a/meta/recipes-devtools/perl/perl_5.34.0.bb
>> +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
>> @@ -20,6 +20,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
>>              file://aacd2398e766500cb5d83c4d76b642fcf31d997a.patch \
>>              file://ea57297a58b8f10ab885c19eec48ea076116cc1f.patch \
>>              file://5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch \
>> +           file://0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch \
>>              "
>>   SRC_URI:append:class-native = " \
>>              file://perl-configpm-switch.patch \
>> --
>> 2.31.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#162590): https://lists.openembedded.org/g/openembedded-core/message/162590
>> Mute This Topic: https://lists.openembedded.org/mt/89496472/1686489
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Alexander Kanavin March 2, 2022, 8:48 a.m. UTC | #3
Yes, but you do not need to submit the patch for inclusion, only to
file a ticket, and ask upstream what can be done about the issue.

Alex

On Wed, 2 Mar 2022 at 09:47, Robert Yang <liezhi.yang@windriver.com> wrote:
>
> Hi
>
> On 3/2/22 4:42 PM, Alexander Kanavin wrote:
> > Can you file a ticket upstream for this please, and include the link
> > in the patch?
> >
>
> This patch won't work for upstream, only work by cross building, let me check on
> how to make it work for all cases.
>
> // Robert
>
>
> > Alex
> >
> > On Wed, 2 Mar 2022 at 08:13, Robert Yang <liezhi.yang@windriver.com> wrote:
> >>
> >> It checks host's path such as /dev/log and uses it, this doesn't make sense for
> >> cross build, and it causes undeterministic, for example, the contianer os
> >> usually doesn't have /dev/log which leads to a different build result since
> >> other host usually has /dev/log, so make it always use the default value to fix
> >> the issue.
> >>
> >> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
> >> ---
> >>   ...Makefile.PL-Fix-_PATH_LOG-for-determ.patch | 34 +++++++++++++++++++
> >>   meta/recipes-devtools/perl/perl_5.34.0.bb     |  1 +
> >>   2 files changed, 35 insertions(+)
> >>   create mode 100644 meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
> >>
> >> diff --git a/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
> >> new file mode 100644
> >> index 00000000000..f6bcbce6856
> >> --- /dev/null
> >> +++ b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
> >> @@ -0,0 +1,34 @@
> >> +From a73fff1fcf0def4ce93964f1b63fe3ad0967259d Mon Sep 17 00:00:00 2001
> >> +From: Robert Yang <liezhi.yang@windriver.com>
> >> +Date: Fri, 18 Feb 2022 09:44:26 +0000
> >> +Subject: [PATCH] cpan/Sys-Syslog/Makefile.PL: Fix _PATH_LOG for deterministic
> >> +
> >> +It checks host's path such as /dev/log and uses it, this doesn't make sense for
> >> +cross build, and it causes undeterministic, for example, the contianer os
> >> +usually doesn't have /dev/log which leads to a different build result since
> >> +other host usually has /dev/log, so make it always use the default value to fix
> >> +the issue.
> >> +
> >> +Upstream-Status:Inappropriate [OE specific]
> >> +
> >> +Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
> >> +---
> >> + cpan/Sys-Syslog/Makefile.PL | 2 ++
> >> + 1 file changed, 2 insertions(+)
> >> +
> >> +diff --git a/cpan/Sys-Syslog/Makefile.PL b/cpan/Sys-Syslog/Makefile.PL
> >> +index d09ba69..d44e58c 100644
> >> +--- a/cpan/Sys-Syslog/Makefile.PL
> >> ++++ b/cpan/Sys-Syslog/Makefile.PL
> >> +@@ -130,6 +130,8 @@ else {
> >> +     $_PATH_LOG = "";
> >> + }
> >> +
> >> ++# OE specific
> >> ++$_PATH_LOG = "";
> >> +
> >> + # if possible, generate the code that handles the constants with
> >> + # ExtUtils::Constant, otherwise use cached copy in fallback/
> >> +--
> >> +2.31.1
> >> +
> >> diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
> >> index a97da872032..8a1db7ed359 100644
> >> --- a/meta/recipes-devtools/perl/perl_5.34.0.bb
> >> +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
> >> @@ -20,6 +20,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
> >>              file://aacd2398e766500cb5d83c4d76b642fcf31d997a.patch \
> >>              file://ea57297a58b8f10ab885c19eec48ea076116cc1f.patch \
> >>              file://5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch \
> >> +           file://0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch \
> >>              "
> >>   SRC_URI:append:class-native = " \
> >>              file://perl-configpm-switch.patch \
> >> --
> >> 2.31.1
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#162590): https://lists.openembedded.org/g/openembedded-core/message/162590
> >> Mute This Topic: https://lists.openembedded.org/mt/89496472/1686489
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
Robert Yang March 2, 2022, 9:49 a.m. UTC | #4
On 3/2/22 4:48 PM, Alexander Kanavin wrote:
> Yes, but you do not need to submit the patch for inclusion, only to
> file a ticket, and ask upstream what can be done about the issue.

Thanks, submitted a ticket to upstream and add the url in the patch:

Submitted a ticket to upstream: https://rt.cpan.org/Ticket/Display.html?id=141612

Upstream-Status: Inappropriate [OE specific]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>


And updated the patch in the PULL:


   git://git.openembedded.org/openembedded-core-contrib rbt/deterministic
   http://cgit.openembedded.org/openembedded-core-contrib/log/?h=rbt/deterministic

// Robert


> 
> Alex
> 
> On Wed, 2 Mar 2022 at 09:47, Robert Yang <liezhi.yang@windriver.com> wrote:
>>
>> Hi
>>
>> On 3/2/22 4:42 PM, Alexander Kanavin wrote:
>>> Can you file a ticket upstream for this please, and include the link
>>> in the patch?
>>>
>>
>> This patch won't work for upstream, only work by cross building, let me check on
>> how to make it work for all cases.
>>
>> // Robert
>>
>>
>>> Alex
>>>
>>> On Wed, 2 Mar 2022 at 08:13, Robert Yang <liezhi.yang@windriver.com> wrote:
>>>>
>>>> It checks host's path such as /dev/log and uses it, this doesn't make sense for
>>>> cross build, and it causes undeterministic, for example, the contianer os
>>>> usually doesn't have /dev/log which leads to a different build result since
>>>> other host usually has /dev/log, so make it always use the default value to fix
>>>> the issue.
>>>>
>>>> Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
>>>> ---
>>>>    ...Makefile.PL-Fix-_PATH_LOG-for-determ.patch | 34 +++++++++++++++++++
>>>>    meta/recipes-devtools/perl/perl_5.34.0.bb     |  1 +
>>>>    2 files changed, 35 insertions(+)
>>>>    create mode 100644 meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>>>>
>>>> diff --git a/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>>>> new file mode 100644
>>>> index 00000000000..f6bcbce6856
>>>> --- /dev/null
>>>> +++ b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
>>>> @@ -0,0 +1,34 @@
>>>> +From a73fff1fcf0def4ce93964f1b63fe3ad0967259d Mon Sep 17 00:00:00 2001
>>>> +From: Robert Yang <liezhi.yang@windriver.com>
>>>> +Date: Fri, 18 Feb 2022 09:44:26 +0000
>>>> +Subject: [PATCH] cpan/Sys-Syslog/Makefile.PL: Fix _PATH_LOG for deterministic
>>>> +
>>>> +It checks host's path such as /dev/log and uses it, this doesn't make sense for
>>>> +cross build, and it causes undeterministic, for example, the contianer os
>>>> +usually doesn't have /dev/log which leads to a different build result since
>>>> +other host usually has /dev/log, so make it always use the default value to fix
>>>> +the issue.
>>>> +
>>>> +Upstream-Status:Inappropriate [OE specific]
>>>> +
>>>> +Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
>>>> +---
>>>> + cpan/Sys-Syslog/Makefile.PL | 2 ++
>>>> + 1 file changed, 2 insertions(+)
>>>> +
>>>> +diff --git a/cpan/Sys-Syslog/Makefile.PL b/cpan/Sys-Syslog/Makefile.PL
>>>> +index d09ba69..d44e58c 100644
>>>> +--- a/cpan/Sys-Syslog/Makefile.PL
>>>> ++++ b/cpan/Sys-Syslog/Makefile.PL
>>>> +@@ -130,6 +130,8 @@ else {
>>>> +     $_PATH_LOG = "";
>>>> + }
>>>> +
>>>> ++# OE specific
>>>> ++$_PATH_LOG = "";
>>>> +
>>>> + # if possible, generate the code that handles the constants with
>>>> + # ExtUtils::Constant, otherwise use cached copy in fallback/
>>>> +--
>>>> +2.31.1
>>>> +
>>>> diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
>>>> index a97da872032..8a1db7ed359 100644
>>>> --- a/meta/recipes-devtools/perl/perl_5.34.0.bb
>>>> +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
>>>> @@ -20,6 +20,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
>>>>               file://aacd2398e766500cb5d83c4d76b642fcf31d997a.patch \
>>>>               file://ea57297a58b8f10ab885c19eec48ea076116cc1f.patch \
>>>>               file://5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch \
>>>> +           file://0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch \
>>>>               "
>>>>    SRC_URI:append:class-native = " \
>>>>               file://perl-configpm-switch.patch \
>>>> --
>>>> 2.31.1
>>>>
>>>>
>>>> -=-=-=-=-=-=-=-=-=-=-=-
>>>> Links: You receive all messages sent to this group.
>>>> View/Reply Online (#162590): https://lists.openembedded.org/g/openembedded-core/message/162590
>>>> Mute This Topic: https://lists.openembedded.org/mt/89496472/1686489
>>>> Group Owner: openembedded-core+owner@lists.openembedded.org
>>>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
>>>> -=-=-=-=-=-=-=-=-=-=-=-
>>>>

Patch

diff --git a/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
new file mode 100644
index 00000000000..f6bcbce6856
--- /dev/null
+++ b/meta/recipes-devtools/perl/files/0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch
@@ -0,0 +1,34 @@ 
+From a73fff1fcf0def4ce93964f1b63fe3ad0967259d Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Fri, 18 Feb 2022 09:44:26 +0000
+Subject: [PATCH] cpan/Sys-Syslog/Makefile.PL: Fix _PATH_LOG for deterministic
+
+It checks host's path such as /dev/log and uses it, this doesn't make sense for
+cross build, and it causes undeterministic, for example, the contianer os
+usually doesn't have /dev/log which leads to a different build result since
+other host usually has /dev/log, so make it always use the default value to fix
+the issue.
+
+Upstream-Status:Inappropriate [OE specific]
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ cpan/Sys-Syslog/Makefile.PL | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cpan/Sys-Syslog/Makefile.PL b/cpan/Sys-Syslog/Makefile.PL
+index d09ba69..d44e58c 100644
+--- a/cpan/Sys-Syslog/Makefile.PL
++++ b/cpan/Sys-Syslog/Makefile.PL
+@@ -130,6 +130,8 @@ else {
+     $_PATH_LOG = "";
+ }
+ 
++# OE specific
++$_PATH_LOG = "";
+ 
+ # if possible, generate the code that handles the constants with 
+ # ExtUtils::Constant, otherwise use cached copy in fallback/
+-- 
+2.31.1
+
diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
index a97da872032..8a1db7ed359 100644
--- a/meta/recipes-devtools/perl/perl_5.34.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
@@ -20,6 +20,7 @@  SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
            file://aacd2398e766500cb5d83c4d76b642fcf31d997a.patch \
            file://ea57297a58b8f10ab885c19eec48ea076116cc1f.patch \
            file://5bc1e5fdd87aa205011512cd1e6cc655bcf677fd.patch \
+           file://0001-cpan-Sys-Syslog-Makefile.PL-Fix-_PATH_LOG-for-determ.patch \
            "
 SRC_URI:append:class-native = " \
            file://perl-configpm-switch.patch \