diff mbox series

[04/19] swig: merge .inc into .bb

Message ID 20240419121945.1920944-4-alex@linutronix.de
State Accepted, archived
Commit d5edf129a39be5b4a62d6fa73b151dcc3a098e79
Headers show
Series [01/19] liba52: remove the recipe | expand

Commit Message

Alexander Kanavin April 19, 2024, 12:19 p.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/swig/swig.inc      | 67 -----------------------
 meta/recipes-devtools/swig/swig_4.2.1.bb | 69 +++++++++++++++++++++++-
 2 files changed, 67 insertions(+), 69 deletions(-)
 delete mode 100644 meta/recipes-devtools/swig/swig.inc

Comments

Richard Purdie April 20, 2024, 12:11 p.m. UTC | #1
On Fri, 2024-04-19 at 14:19 +0200, Alexander Kanavin via lists.openembedded.org wrote:
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  meta/recipes-devtools/swig/swig.inc      | 67 -----------------------
>  meta/recipes-devtools/swig/swig_4.2.1.bb | 69 +++++++++++++++++++++++-
>  2 files changed, 67 insertions(+), 69 deletions(-)
>  delete mode 100644 meta/recipes-devtools/swig/swig.inc
> 
> diff --git a/meta/recipes-devtools/swig/swig.inc b/meta/recipes-devtools/swig/swig.inc
> deleted file mode 100644
> index 7a6c4d7359c..00000000000

This seems to have a reproducibility issue:

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4685/steps/12/logs/stdio

Also, your patch From address is now getting corrupted on the mailing
list, you probably need to add the From: lines to your patches when
sending.

Cheers,

Richard
Alexander Kanavin April 20, 2024, 5:58 p.m. UTC | #2
On Sat, 20 Apr 2024 at 14:11, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> Also, your patch From address is now getting corrupted on the mailing
> list, you probably need to add the From: lines to your patches when
> sending.

I think this has actually been happening for a while (I write patches
using linutronix email but send them over gmail smtp):

From: "Alexander Kanavin via lists.openembedded.org"
<alex.kanavin=gmail.com@lists.openembedded.org>
X-Google-Original-From: Alexander Kanavin <alex@linutronix.de>

git format-patch has an option to force a From: at the start of the
patch which I'll enable.

Alex
Alexander Kanavin April 22, 2024, 10:46 a.m. UTC | #3
On Sat, 20 Apr 2024 at 14:11, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:

> This seems to have a reproducibility issue:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/4685/steps/12/logs/stdio

I have to show you the issue, as it's a face-meet-palm-ish new way to
thwart the build path checker:

#ifndef YY_YY_HOME_POKYBUILD_YOCTO_WORKER_REPRODUCIBLE_BUILD_BUILD_ST_REPRODUCIBLEB_TMP_WORK_CORE2_64_POKY_LINUX_SWIG_4_2_1_BUILD_SOURCE_CPARSE_PARSER_H_INCLUDED
#define YY_YY_HOME_POKYBUILD_YOCTO_WORKER_NO_X11_BUILD_BUILD_TMP_WORK_CORE2_64_POKY_LINUX_SWIG_4_2_1_BUILD_SOURCE_CPARSE_PARSER_H_INCLUDED

http://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20240420-_5niux5i/packages/diff-html/

Alex
diff mbox series

Patch

diff --git a/meta/recipes-devtools/swig/swig.inc b/meta/recipes-devtools/swig/swig.inc
deleted file mode 100644
index 7a6c4d7359c..00000000000
--- a/meta/recipes-devtools/swig/swig.inc
+++ /dev/null
@@ -1,67 +0,0 @@ 
-SUMMARY = "SWIG - Simplified Wrapper and Interface Generator"
-DESCRIPTION = "SWIG is a compiler that makes it easy to integrate C and C++ \
-code with other languages including Perl, Tcl, Ruby, Python, Java, Guile, \
-Mzscheme, Chicken, OCaml, Pike, and C#."
-HOMEPAGE = "http://swig.sourceforge.net/"
-LICENSE = "BSD-3-Clause & GPL-3.0-only"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e7807a6282784a7dde4c846626b08fc6 \
-                    file://LICENSE-GPL;md5=d32239bcb673463ab874e80d47fae504 \
-                    file://LICENSE-UNIVERSITIES;md5=8ce9dcc8f7c994de4a408b205c72ba08"
-
-SECTION = "devel"
-
-DEPENDS = "libpcre2 bison-native"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
-UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/swig/files/swig/"
-UPSTREAM_CHECK_REGEX = "swig-(?P<pver>\d+(\.\d+)+)"
-
-inherit autotools python3native pkgconfig
-
-EXTRA_OECONF = " \
-    --with-python3=${PYTHON} \
-    --without-allegrocl \
-    --without-android \
-    --without-boost \
-    --without-chicken \
-    --without-clisp \
-    --without-csharp \
-    --without-d \
-    --without-gcj \
-    --without-go \
-    --without-guile \
-    --without-java \
-    --without-lua \
-    --without-mzscheme \
-    --without-ocaml \
-    --without-octave \
-    --without-perl5 \
-    --without-pike \
-    --without-php \
-    --without-r \
-    --without-ruby \
-    --without-tcl \
-"
-
-EXTRA_AUTORECONF += "-I Tools/config"
-
-BBCLASSEXTEND = "native nativesdk"
-
-# necessary together with bison dependency until a new upstream version after
-# 3.0.12 includes 0001-Fix-generated-code-for-constant-expressions-containi.patch
-do_configure:append() {
-    mkdir -p ${B}/Source/CParse
-}
-
-do_install:append:class-nativesdk() {
-    cd ${D}${bindir}
-    ln -s swig swig2.0
-}
-
-def swiglib_relpath(d):
-    swiglib = d.getVar('datadir') + "/" + d.getVar('BPN') + "/" + d.getVar('PV')
-    return os.path.relpath(swiglib, d.getVar('bindir'))
-
-do_install:append:class-native() {
-    create_wrapper ${D}${bindir}/swig SWIG_LIB='`dirname $''realpath`'/${@swiglib_relpath(d)}
-}
diff --git a/meta/recipes-devtools/swig/swig_4.2.1.bb b/meta/recipes-devtools/swig/swig_4.2.1.bb
index 4b438a72982..7062d4e9aa3 100644
--- a/meta/recipes-devtools/swig/swig_4.2.1.bb
+++ b/meta/recipes-devtools/swig/swig_4.2.1.bb
@@ -1,7 +1,72 @@ 
-require ${BPN}.inc
+SUMMARY = "SWIG - Simplified Wrapper and Interface Generator"
+DESCRIPTION = "SWIG is a compiler that makes it easy to integrate C and C++ \
+code with other languages including Perl, Tcl, Ruby, Python, Java, Guile, \
+Mzscheme, Chicken, OCaml, Pike, and C#."
+HOMEPAGE = "http://swig.sourceforge.net/"
+LICENSE = "BSD-3-Clause & GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e7807a6282784a7dde4c846626b08fc6 \
+                    file://LICENSE-GPL;md5=d32239bcb673463ab874e80d47fae504 \
+                    file://LICENSE-UNIVERSITIES;md5=8ce9dcc8f7c994de4a408b205c72ba08"
 
-SRC_URI += "file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch \
+SECTION = "devel"
+
+DEPENDS = "libpcre2 bison-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
+            file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch \
             file://0001-configure-use-pkg-config-for-pcre-detection.patch \
             file://determinism.patch \
            "
 SRC_URI[sha256sum] = "fa045354e2d048b2cddc69579e4256245d4676894858fcf0bab2290ecf59b7d8"
+UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/swig/files/swig/"
+UPSTREAM_CHECK_REGEX = "swig-(?P<pver>\d+(\.\d+)+)"
+
+inherit autotools python3native pkgconfig
+
+EXTRA_OECONF = " \
+    --with-python3=${PYTHON} \
+    --without-allegrocl \
+    --without-android \
+    --without-boost \
+    --without-chicken \
+    --without-clisp \
+    --without-csharp \
+    --without-d \
+    --without-gcj \
+    --without-go \
+    --without-guile \
+    --without-java \
+    --without-lua \
+    --without-mzscheme \
+    --without-ocaml \
+    --without-octave \
+    --without-perl5 \
+    --without-pike \
+    --without-php \
+    --without-r \
+    --without-ruby \
+    --without-tcl \
+"
+
+EXTRA_AUTORECONF += "-I Tools/config"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# necessary together with bison dependency until a new upstream version after
+# 3.0.12 includes 0001-Fix-generated-code-for-constant-expressions-containi.patch
+do_configure:append() {
+    mkdir -p ${B}/Source/CParse
+}
+
+do_install:append:class-nativesdk() {
+    cd ${D}${bindir}
+    ln -s swig swig2.0
+}
+
+def swiglib_relpath(d):
+    swiglib = d.getVar('datadir') + "/" + d.getVar('BPN') + "/" + d.getVar('PV')
+    return os.path.relpath(swiglib, d.getVar('bindir'))
+
+do_install:append:class-native() {
+    create_wrapper ${D}${bindir}/swig SWIG_LIB='`dirname $''realpath`'/${@swiglib_relpath(d)}
+}