diff mbox series

[28/33] python3-pycparser: upgrade 2.21 -> 2.22

Message ID 1712646620-16608-28-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [01/33] babeltrace2: upgrade 2.0.5 -> 2.0.6 | expand

Commit Message

Mingyu Wang (Fujitsu) April 9, 2024, 7:10 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
-Add missing SCHAR limit defines
-Use proper SPDX identifier
-Add Python 3.11 as a supported version
-Fix multi-pragma/single statement blocks (#479)
-Add an encoding parameter to parse_file
-Feature/add pragma support
-Set up permissions to ci.yml
-_build_tables: Invalidate cache before importing generated modules
-Upgrade GitHub Actions
-Create a Security Policy
-New example to generate AST from scratch
-Add support for Python 3.12
-ply: Make generated lextab.py deterministic

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-pycparser_2.21.bb => python3-pycparser_2.22.bb}  | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-pycparser_2.21.bb => python3-pycparser_2.22.bb} (69%)

Comments

Alexander Kanavin April 9, 2024, 9:29 a.m. UTC | #1
On Tue, 9 Apr 2024 at 09:11, wangmy via lists.openembedded.org
<wangmy=fujitsu.com@lists.openembedded.org> wrote:
>  LICENSE = "BSD-3-Clause"
> -LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=9761c3ffee7ba99c60dca0408fd3262b"

License checksum change should be explained.

Alex
Trevor Gamblin April 9, 2024, 12:05 p.m. UTC | #2
On 2024-04-09 11:29, Alexander Kanavin wrote:
> On Tue, 9 Apr 2024 at 09:11, wangmy via lists.openembedded.org
> <wangmy=fujitsu.com@lists.openembedded.org> wrote:
>>   LICENSE = "BSD-3-Clause"
>> -LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"
>> +LIC_FILES_CHKSUM = "file://LICENSE;md5=9761c3ffee7ba99c60dca0408fd3262b"
> License checksum change should be explained.
Thanks for pointing that out. Odd that patchtest didn't get it this time.
>
> Alex
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#198059): https://lists.openembedded.org/g/openembedded-core/message/198059
> Mute This Topic: https://lists.openembedded.org/mt/105417654/7611679
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [tgamblin@baylibre.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pycparser_2.21.bb b/meta/recipes-devtools/python/python3-pycparser_2.22.bb
similarity index 69%
rename from meta/recipes-devtools/python/python3-pycparser_2.21.bb
rename to meta/recipes-devtools/python/python3-pycparser_2.22.bb
index 00deceebf9..9a5abc42bd 100644
--- a/meta/recipes-devtools/python/python3-pycparser_2.21.bb
+++ b/meta/recipes-devtools/python/python3-pycparser_2.22.bb
@@ -1,9 +1,9 @@ 
 SUMMARY = "Parser of the C language, written in pure Python"
 HOMEPAGE = "https://github.com/eliben/pycparser"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9761c3ffee7ba99c60dca0408fd3262b"
 
-SRC_URI[sha256sum] = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"
+SRC_URI[sha256sum] = "491c8be9c040f5390f5bf44a5b07752bd07f56edf992381b05c701439eec10f6"
 
 inherit pypi setuptools3