diff mbox series

[meta-multimedia,2/2] vlc: Upgrade to 3.0.20

Message ID 20240308062947.1258485-2-raj.khem@gmail.com
State Accepted, archived
Headers show
Series [meta-gnome,1/2] gnome-online-accounts: Fix build with libxml2 2.12 | expand

Commit Message

Khem Raj March 8, 2024, 6:29 a.m. UTC
Fix build with taglib 2.0

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../vlc/0001-make-opencv-configurable.patch   |  2 +-
 .../vlc/vlc/0002-use-vorbisidec.patch         |  2 +-
 ...packageconfig-to-detect-mmal-support.patch |  2 +-
 ...ave-same-signature-between-glibc-and.patch | 11 +--
 ...e-incompatible-function-pointer-type.patch |  7 +-
 .../recipes-multimedia/vlc/vlc/taglib-2.patch | 67 +++++++++++++++++++
 .../vlc/{vlc_3.0.18.bb => vlc_3.0.20.bb}      |  7 +-
 7 files changed, 76 insertions(+), 22 deletions(-)
 create mode 100644 meta-multimedia/recipes-multimedia/vlc/vlc/taglib-2.patch
 rename meta-multimedia/recipes-multimedia/vlc/{vlc_3.0.18.bb => vlc_3.0.20.bb} (96%)
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
index cc65af009b..d6ff0b2dba 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0001-make-opencv-configurable.patch
@@ -7,7 +7,7 @@  Signed-off-by: Tim Orling <TicoTimo@gmail.com>
 
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1892,7 +1892,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu
+@@ -1891,7 +1891,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu
  dnl
  dnl  OpenCV wrapper and example filters
  dnl
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0002-use-vorbisidec.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0002-use-vorbisidec.patch
index 8ecddd33c6..f68da33607 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0002-use-vorbisidec.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0002-use-vorbisidec.patch
@@ -6,7 +6,7 @@  Signed-off-by: Tim Orling <TicoTimo@gmail.com>
 
 --- a/modules/codec/Makefile.am
 +++ b/modules/codec/Makefile.am
-@@ -321,7 +321,7 @@ codec_LTLIBRARIES += $(LTLIBdaala)
+@@ -324,7 +324,7 @@ codec_LTLIBRARIES += $(LTLIBdaala)
  libtremor_plugin_la_SOURCES = codec/vorbis.c
  libtremor_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) -DMODULE_NAME_IS_tremor
  libtremor_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(codecdir)'
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0004-Use-packageconfig-to-detect-mmal-support.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0004-Use-packageconfig-to-detect-mmal-support.patch
index b9f5ad591c..6659a44a0a 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0004-Use-packageconfig-to-detect-mmal-support.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0004-Use-packageconfig-to-detect-mmal-support.patch
@@ -16,7 +16,7 @@  Signed-off-by: Khem Raj <raj.khem@gmail.com>
 
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3461,27 +3461,18 @@ AC_ARG_ENABLE(mmal,
+@@ -3460,27 +3460,18 @@ AC_ARG_ENABLE(mmal,
    AS_HELP_STRING([--enable-mmal],
      [Multi-Media Abstraction Layer (MMAL) hardware plugin (default enable)]))
  if test "${enable_mmal}" != "no"; then
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0005-ioctl-does-not-have-same-signature-between-glibc-and.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0005-ioctl-does-not-have-same-signature-between-glibc-and.patch
index cbf4f2b911..89e7d585d7 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0005-ioctl-does-not-have-same-signature-between-glibc-and.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0005-ioctl-does-not-have-same-signature-between-glibc-and.patch
@@ -10,11 +10,9 @@  Signed-off-by: Khem Raj <raj.khem@gmail.com>
  modules/access/v4l2/v4l2.h | 4 ++++
  2 files changed, 8 insertions(+)
 
-diff --git a/modules/access/v4l2/lib.c b/modules/access/v4l2/lib.c
-index b212e1bc5f..ff7c66bf35 100644
 --- a/modules/access/v4l2/lib.c
 +++ b/modules/access/v4l2/lib.c
-@@ -43,7 +43,11 @@ int (*v4l2_fd_open) (int, int) = fd_open;
+@@ -49,7 +49,11 @@ int (*v4l2_fd_open) (int, int) = fd_open
  //int (*v4l2_open) (const char *, int, ...) = open;
  //int (*v4l2_dup) (const char *, int, ...) = dup;
  int (*v4l2_close) (int) = close;
@@ -26,11 +24,9 @@  index b212e1bc5f..ff7c66bf35 100644
  ssize_t (*v4l2_read) (int, void *, size_t) = read;
  //ssize_t (*v4l2_write) (int, const void *, size_t) = write;
  void * (*v4l2_mmap) (void *, size_t, int, int, int, int64_t) = mmap;
-diff --git a/modules/access/v4l2/v4l2.h b/modules/access/v4l2/v4l2.h
-index ac4562e269..727e83e9b1 100644
 --- a/modules/access/v4l2/v4l2.h
 +++ b/modules/access/v4l2/v4l2.h
-@@ -23,7 +23,11 @@
+@@ -28,7 +28,11 @@
  /* libv4l2 functions */
  extern int (*v4l2_fd_open) (int, int);
  extern int (*v4l2_close) (int);
@@ -42,6 +38,3 @@  index ac4562e269..727e83e9b1 100644
  extern ssize_t (*v4l2_read) (int, void *, size_t);
  extern void * (*v4l2_mmap) (void *, size_t, int, int, int, int64_t);
  extern int (*v4l2_munmap) (void *, size_t);
--- 
-2.39.2
-
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0006-configure-Disable-incompatible-function-pointer-type.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-configure-Disable-incompatible-function-pointer-type.patch
index 4128db1aea..b158328aa2 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc/0006-configure-Disable-incompatible-function-pointer-type.patch
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-configure-Disable-incompatible-function-pointer-type.patch
@@ -10,11 +10,9 @@  Signed-off-by: Khem Raj <raj.khem@gmail.com>
  configure.ac | 5 +++++
  1 file changed, 5 insertions(+)
 
-diff --git a/configure.ac b/configure.ac
-index 9f1c099e13..8e45a05808 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -98,6 +98,11 @@ AS_IF([test -n "${with_binary_version}"],[
+@@ -98,6 +98,11 @@ AS_IF([test -n "${with_binary_version}"]
  dnl Prevent clang from accepting unknown flags with a mere warning
  AX_APPEND_COMPILE_FLAGS([-Werror=unknown-warning-option -Werror=invalid-command-line-argument], [CFLAGS])
  AX_APPEND_COMPILE_FLAGS([-Werror=unknown-warning-option -Werror=invalid-command-line-argument], [CXXFLAGS])
@@ -26,6 +24,3 @@  index 9f1c099e13..8e45a05808 100644
  
  dnl
  dnl  Check the operating system
--- 
-2.39.2
-
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/taglib-2.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/taglib-2.patch
new file mode 100644
index 0000000000..f238ff4244
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/taglib-2.patch
@@ -0,0 +1,67 @@ 
+Fix build with taglib 2.0
+
+Source: https://gitlab.archlinux.org/archlinux/packaging/packages/vlc/-/blob/main/taglib-2.patch?ref_type=heads
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/modules/meta_engine/taglib.cpp
++++ b/modules/meta_engine/taglib.cpp
+@@ -185,7 +185,7 @@ public:
+         ByteVector res(length, 0);
+         ssize_t i_read = vlc_stream_Read( m_stream, res.data(), length);
+         if (i_read < 0)
+-            return ByteVector::null;
++            return ByteVector();
+         else if ((size_t)i_read != length)
+             res.resize(i_read);
+         return res;
+@@ -465,7 +465,7 @@ static void ReadMetaFromASF( ASF::Tag* t
+ static void ReadMetaFromBasicTag(const Tag* tag, vlc_meta_t *dest)
+ {
+ #define SET( accessor, meta )                                                  \
+-    if( !tag->accessor().isNull() && !tag->accessor().isEmpty() )              \
++    if( !tag->accessor().isEmpty() )              \
+         vlc_meta_Set##meta( dest, tag->accessor().toCString(true) )
+ #define SETINT( accessor, meta )                                               \
+     if( tag->accessor() )                                                      \
+@@ -806,15 +806,15 @@ static void ReadMetaFromMP4( MP4::Tag* t
+ {
+     MP4::Item list;
+ #define SET( keyName, metaName )                                                             \
+-    if( tag->itemListMap().contains(keyName) )                                               \
++    if( tag->itemMap().contains(keyName) )                                               \
+     {                                                                                        \
+-        list = tag->itemListMap()[keyName];                                                  \
++        list = tag->itemMap()[keyName];                                                  \
+         vlc_meta_Set##metaName( p_meta, list.toStringList().front().toCString( true ) );     \
+     }
+ #define SET_EXTRA( keyName, metaName )                                                   \
+-    if( tag->itemListMap().contains(keyName) )                                  \
++    if( tag->itemMap().contains(keyName) )                                  \
+     {                                                                                \
+-        list = tag->itemListMap()[keyName];                                     \
++        list = tag->itemMap()[keyName];                                     \
+         vlc_meta_AddExtra( p_meta, metaName, list.toStringList().front().toCString( true ) ); \
+     }
+ 
+@@ -824,9 +824,9 @@ static void ReadMetaFromMP4( MP4::Tag* t
+ #undef SET
+ #undef SET_EXTRA
+ 
+-    if( tag->itemListMap().contains("covr") )
++    if( tag->itemMap().contains("covr") )
+     {
+-        MP4::CoverArtList list = tag->itemListMap()["covr"].toCoverArtList();
++        MP4::CoverArtList list = tag->itemMap()["covr"].toCoverArtList();
+         const char *psz_format = list[0].format() == MP4::CoverArt::PNG ? "image/png" : "image/jpeg";
+ 
+         msg_Dbg( p_demux_meta, "Found embedded art (%s) is %i bytes",
+@@ -1337,7 +1337,7 @@ static int WriteMeta( vlc_object_t *p_th
+         if( RIFF::AIFF::File* riff_aiff = dynamic_cast<RIFF::AIFF::File*>(f.file()) )
+             WriteMetaToId3v2( riff_aiff->tag(), p_item );
+         else if( RIFF::WAV::File* riff_wav = dynamic_cast<RIFF::WAV::File*>(f.file()) )
+-            WriteMetaToId3v2( riff_wav->tag(), p_item );
++            WriteMetaToId3v2( riff_wav->ID3v2Tag(), p_item );
+     }
+     else if( TrueAudio::File* trueaudio = dynamic_cast<TrueAudio::File*>(f.file()) )
+     {
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.18.bb b/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.20.bb
similarity index 96%
rename from meta-multimedia/recipes-multimedia/vlc/vlc_3.0.18.bb
rename to meta-multimedia/recipes-multimedia/vlc/vlc_3.0.20.bb
index 12b32879a7..85af2f9bbe 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.18.bb
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc_3.0.20.bb
@@ -16,17 +16,16 @@  DEPENDS = "coreutils-native fribidi libtool libgcrypt libgcrypt-native bison-nat
 LDFLAGS:append:riscv64 = " -latomic"
 LDFLAGS:append:riscv32 = " -latomic"
 
-SRC_URI = "git://github.com/videolan/vlc.git;protocol=https;branch=3.0.x \
+SRC_URI = "https://get.videolan.org/${BPN}/${PV}/${BP}.tar.xz \
            file://0001-make-opencv-configurable.patch \
            file://0002-use-vorbisidec.patch \
            file://0003-fix-luaL-checkint.patch \
            file://0004-Use-packageconfig-to-detect-mmal-support.patch \
            file://0005-ioctl-does-not-have-same-signature-between-glibc-and.patch \
            file://0006-configure-Disable-incompatible-function-pointer-type.patch \
-           file://0001-po-Fix-invalid-.oc-translation-format-string.patch \
+           file://taglib-2.patch \
 "
-SRCREV = "e9eceaed4d838dbd84638bfb2e4bdd08294163b1"
-S = "${WORKDIR}/git"
+SRC_URI[sha256sum] = "adc7285b4d2721cddf40eb5270cada2aaa10a334cb546fd55a06353447ba29b5"
 
 inherit autotools-brokensep features_check gettext pkgconfig mime-xdg