diff mbox series

[meta-python] python3-icecream: add recipe

Message ID 20240306171740.480830-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-icecream: add recipe | expand

Commit Message

Alper Ak March 6, 2024, 5:17 p.m. UTC
icecream (ic) package offers a more concise and readable way to debug code by replacing print statements with simple function calls.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-icecream_2.1.3.bb            | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb

Comments

Khem Raj March 6, 2024, 5:19 p.m. UTC | #1
Are there any unit tests with this new package ?

On Wed, Mar 6, 2024 at 9:17 AM Alper Ak <alperyasinak1@gmail.com> wrote:
>
> icecream (ic) package offers a more concise and readable way to debug code by replacing print statements with simple function calls.
>
> Signed-off-by: alperak <alperyasinak1@gmail.com>
> ---
>  .../python/python3-icecream_2.1.3.bb            | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
> new file mode 100644
> index 000000000..ec3a4b90f
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Never use print() to debug again; inspect variables, expressions, and program execution with a single, simple function call."
> +HOMEPAGE = "https://github.com/gruns/icecream"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eca5ce1610d64ed40920efdce85ff8d1"
> +
> +SRC_URI[sha256sum] = "0aa4a7c3374ec36153a1d08f81e3080e83d8ac1eefd97d2f4fe9544e8f9b49de"
> +
> +inherit pypi setuptools3
> +
> +RDEPENDS:${PN} += " \
> +        python3-asttokens \
> +        python3-colorama \
> +        python3-executing \
> +        python3-numbers \
> +        python3-pygments \
> +        python3-pprint \
> +"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#109174): https://lists.openembedded.org/g/openembedded-devel/message/109174
> Mute This Topic: https://lists.openembedded.org/mt/104770329/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alper Ak March 6, 2024, 6:38 p.m. UTC | #2
There is but when I tried to test it, I encountered deprecated things being
used. For example, new assert function name is required for Python 3.12
compat.

Khem Raj <raj.khem@gmail.com>, 6 Mar 2024 Çar, 20:19 tarihinde şunu yazdı:

> Are there any unit tests with this new package ?
>
> On Wed, Mar 6, 2024 at 9:17 AM Alper Ak <alperyasinak1@gmail.com> wrote:
> >
> > icecream (ic) package offers a more concise and readable way to debug
> code by replacing print statements with simple function calls.
> >
> > Signed-off-by: alperak <alperyasinak1@gmail.com>
> > ---
> >  .../python/python3-icecream_2.1.3.bb            | 17 +++++++++++++++++
> >  1 file changed, 17 insertions(+)
> >  create mode 100644 meta-python/recipes-devtools/python/
> python3-icecream_2.1.3.bb
> >
> > diff --git a/meta-python/recipes-devtools/python/
> python3-icecream_2.1.3.bb b/meta-python/recipes-devtools/python/
> python3-icecream_2.1.3.bb
> > new file mode 100644
> > index 000000000..ec3a4b90f
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
> > @@ -0,0 +1,17 @@
> > +SUMMARY = "Never use print() to debug again; inspect variables,
> expressions, and program execution with a single, simple function call."
> > +HOMEPAGE = "https://github.com/gruns/icecream"
> > +LICENSE = "MIT"
> > +LIC_FILES_CHKSUM =
> "file://LICENSE.txt;md5=eca5ce1610d64ed40920efdce85ff8d1"
> > +
> > +SRC_URI[sha256sum] =
> "0aa4a7c3374ec36153a1d08f81e3080e83d8ac1eefd97d2f4fe9544e8f9b49de"
> > +
> > +inherit pypi setuptools3
> > +
> > +RDEPENDS:${PN} += " \
> > +        python3-asttokens \
> > +        python3-colorama \
> > +        python3-executing \
> > +        python3-numbers \
> > +        python3-pygments \
> > +        python3-pprint \
> > +"
> > --
> > 2.25.1
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#109174):
> https://lists.openembedded.org/g/openembedded-devel/message/109174
> > Mute This Topic: https://lists.openembedded.org/mt/104770329/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
new file mode 100644
index 000000000..ec3a4b90f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icecream_2.1.3.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Never use print() to debug again; inspect variables, expressions, and program execution with a single, simple function call."
+HOMEPAGE = "https://github.com/gruns/icecream"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eca5ce1610d64ed40920efdce85ff8d1"
+
+SRC_URI[sha256sum] = "0aa4a7c3374ec36153a1d08f81e3080e83d8ac1eefd97d2f4fe9544e8f9b49de"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+        python3-asttokens \
+        python3-colorama \
+        python3-executing \
+        python3-numbers \
+        python3-pygments \
+        python3-pprint \
+"