diff mbox series

bmaptool: now part of Yocto Project

Message ID 20240304192558.27575-1-twoerner@gmail.com
State Accepted, archived
Commit 7a036b1a1ec7dcd27dbe18d4c2e703bd2a8af182
Headers show
Series bmaptool: now part of Yocto Project | expand

Commit Message

Trevor Woerner March 4, 2024, 7:25 p.m. UTC
The bmaptool (previously: bmap-tools, bmap-tool, bmaptool) has been moved
to be under the Yocto Project umbrella and is now hosted at:

	github.com/yoctoproject/bmaptool

Signed-off-by: Trevor Woerner <twoerner@gmail.com>
---
 meta/classes-recipe/image_types.bbclass                   | 2 +-
 meta/classes-recipe/image_types_wic.bbclass               | 2 +-
 meta/conf/distro/include/maintainers.inc                  | 2 +-
 .../bmap-tools_git.bb => bmaptool/bmaptool_git.bb}        | 8 ++++----
 .../files/0001-BmapCopy.py-fix-error-message.patch        | 0
 ...0002-CLI.py-fix-block-device-udev-race-condition.patch | 0
 .../0003-BmapCopy.py-tweak-suggested-udev-rule.patch      | 0
 7 files changed, 7 insertions(+), 7 deletions(-)
 rename meta/recipes-support/{bmap-tools/bmap-tools_git.bb => bmaptool/bmaptool_git.bb} (78%)
 rename meta/recipes-support/{bmap-tools => bmaptool}/files/0001-BmapCopy.py-fix-error-message.patch (100%)
 rename meta/recipes-support/{bmap-tools => bmaptool}/files/0002-CLI.py-fix-block-device-udev-race-condition.patch (100%)
 rename meta/recipes-support/{bmap-tools => bmaptool}/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch (100%)

Comments

Richard Purdie March 5, 2024, 11:59 a.m. UTC | #1
On Mon, 2024-03-04 at 14:25 -0500, Trevor Woerner wrote:
> The bmaptool (previously: bmap-tools, bmap-tool, bmaptool) has been moved
> to be under the Yocto Project umbrella and is now hosted at:
> 
> 	github.com/yoctoproject/bmaptool
> 
> Signed-off-by: Trevor Woerner <twoerner@gmail.com>
> ---
>  meta/classes-recipe/image_types.bbclass                   | 2 +-
>  meta/classes-recipe/image_types_wic.bbclass               | 2 +-
>  meta/conf/distro/include/maintainers.inc                  | 2 +-
>  .../bmap-tools_git.bb => bmaptool/bmaptool_git.bb}        | 8 ++++----
>  .../files/0001-BmapCopy.py-fix-error-message.patch        | 0
>  ...0002-CLI.py-fix-block-device-udev-race-condition.patch | 0
>  .../0003-BmapCopy.py-tweak-suggested-udev-rule.patch      | 0
>  7 files changed, 7 insertions(+), 7 deletions(-)
>  rename meta/recipes-support/{bmap-tools/bmap-tools_git.bb => bmaptool/bmaptool_git.bb} (78%)
>  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0001-BmapCopy.py-fix-error-message.patch (100%)
>  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0002-CLI.py-fix-block-device-udev-race-condition.patch (100%)
>  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch (100%)

Thanks. Unfortunately this wasn't quite enough and caused a ton of
build failures, it also needs:

diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
index 9282d36a4dc..76494e7fca4 100644
--- a/meta/recipes-core/meta/wic-tools.bb
+++ b/meta/recipes-core/meta/wic-tools.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
 
 DEPENDS = "\
            parted-native gptfdisk-native dosfstools-native \
-           mtools-native bmap-tools-native grub-native cdrtools-native \
+           mtools-native bmaptool-native grub-native cdrtools-native \
            btrfs-tools-native squashfs-tools-native pseudo-native \
            e2fsprogs-native util-linux-native tar-native erofs-utils-native \
            virtual/${TARGET_PREFIX}binutils \
diff --git a/scripts/lib/wic/misc.py b/scripts/lib/wic/misc.py
index 2b90821b305..1a7c140fa6c 100644
--- a/scripts/lib/wic/misc.py
+++ b/scripts/lib/wic/misc.py
@@ -25,7 +25,7 @@ from wic import WicError
 logger = logging.getLogger('wic')
 
 # executable -> recipe pairs for exec_native_cmd
-NATIVE_RECIPES = {"bmaptool": "bmap-tools",
+NATIVE_RECIPES = {"bmaptool": "bmaptool",
                   "dumpe2fs": "e2fsprogs",
                   "grub-mkimage": "grub-efi",
                   "isohybrid": "syslinux",

but I'll squash that into the patch.

Cheers,

Richard
Trevor Woerner March 5, 2024, 12:52 p.m. UTC | #2
On Tue 2024-03-05 @ 11:59:17 AM, Richard Purdie wrote:
> On Mon, 2024-03-04 at 14:25 -0500, Trevor Woerner wrote:
> > The bmaptool (previously: bmap-tools, bmap-tool, bmaptool) has been moved
> > to be under the Yocto Project umbrella and is now hosted at:
> > 
> > 	github.com/yoctoproject/bmaptool
> > 
> > Signed-off-by: Trevor Woerner <twoerner@gmail.com>
> > ---
> >  meta/classes-recipe/image_types.bbclass                   | 2 +-
> >  meta/classes-recipe/image_types_wic.bbclass               | 2 +-
> >  meta/conf/distro/include/maintainers.inc                  | 2 +-
> >  .../bmap-tools_git.bb => bmaptool/bmaptool_git.bb}        | 8 ++++----
> >  .../files/0001-BmapCopy.py-fix-error-message.patch        | 0
> >  ...0002-CLI.py-fix-block-device-udev-race-condition.patch | 0
> >  .../0003-BmapCopy.py-tweak-suggested-udev-rule.patch      | 0
> >  7 files changed, 7 insertions(+), 7 deletions(-)
> >  rename meta/recipes-support/{bmap-tools/bmap-tools_git.bb => bmaptool/bmaptool_git.bb} (78%)
> >  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0001-BmapCopy.py-fix-error-message.patch (100%)
> >  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0002-CLI.py-fix-block-device-udev-race-condition.patch (100%)
> >  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch (100%)
> 
> Thanks. Unfortunately this wasn't quite enough and caused a ton of
> build failures, it also needs:

Oops! Sorry about that.

> diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
> index 9282d36a4dc..76494e7fca4 100644
> --- a/meta/recipes-core/meta/wic-tools.bb
> +++ b/meta/recipes-core/meta/wic-tools.bb
> @@ -4,7 +4,7 @@ LICENSE = "MIT"
>  
>  DEPENDS = "\
>             parted-native gptfdisk-native dosfstools-native \
> -           mtools-native bmap-tools-native grub-native cdrtools-native \
> +           mtools-native bmaptool-native grub-native cdrtools-native \
>             btrfs-tools-native squashfs-tools-native pseudo-native \
>             e2fsprogs-native util-linux-native tar-native erofs-utils-native \
>             virtual/${TARGET_PREFIX}binutils \
> diff --git a/scripts/lib/wic/misc.py b/scripts/lib/wic/misc.py
> index 2b90821b305..1a7c140fa6c 100644
> --- a/scripts/lib/wic/misc.py
> +++ b/scripts/lib/wic/misc.py
> @@ -25,7 +25,7 @@ from wic import WicError
>  logger = logging.getLogger('wic')
>  
>  # executable -> recipe pairs for exec_native_cmd
> -NATIVE_RECIPES = {"bmaptool": "bmap-tools",
> +NATIVE_RECIPES = {"bmaptool": "bmaptool",
>                    "dumpe2fs": "e2fsprogs",
>                    "grub-mkimage": "grub-efi",
>                    "isohybrid": "syslinux",
> 
> but I'll squash that into the patch.

Great, thanks!
Khem Raj March 5, 2024, 7:17 p.m. UTC | #3
This also needs to reflect in docs.

On Tue, Mar 5, 2024 at 4:52 AM Trevor Woerner <twoerner@gmail.com> wrote:
>
> On Tue 2024-03-05 @ 11:59:17 AM, Richard Purdie wrote:
> > On Mon, 2024-03-04 at 14:25 -0500, Trevor Woerner wrote:
> > > The bmaptool (previously: bmap-tools, bmap-tool, bmaptool) has been moved
> > > to be under the Yocto Project umbrella and is now hosted at:
> > >
> > >     github.com/yoctoproject/bmaptool
> > >
> > > Signed-off-by: Trevor Woerner <twoerner@gmail.com>
> > > ---
> > >  meta/classes-recipe/image_types.bbclass                   | 2 +-
> > >  meta/classes-recipe/image_types_wic.bbclass               | 2 +-
> > >  meta/conf/distro/include/maintainers.inc                  | 2 +-
> > >  .../bmap-tools_git.bb => bmaptool/bmaptool_git.bb}        | 8 ++++----
> > >  .../files/0001-BmapCopy.py-fix-error-message.patch        | 0
> > >  ...0002-CLI.py-fix-block-device-udev-race-condition.patch | 0
> > >  .../0003-BmapCopy.py-tweak-suggested-udev-rule.patch      | 0
> > >  7 files changed, 7 insertions(+), 7 deletions(-)
> > >  rename meta/recipes-support/{bmap-tools/bmap-tools_git.bb => bmaptool/bmaptool_git.bb} (78%)
> > >  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0001-BmapCopy.py-fix-error-message.patch (100%)
> > >  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0002-CLI.py-fix-block-device-udev-race-condition.patch (100%)
> > >  rename meta/recipes-support/{bmap-tools => bmaptool}/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch (100%)
> >
> > Thanks. Unfortunately this wasn't quite enough and caused a ton of
> > build failures, it also needs:
>
> Oops! Sorry about that.
>
> > diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
> > index 9282d36a4dc..76494e7fca4 100644
> > --- a/meta/recipes-core/meta/wic-tools.bb
> > +++ b/meta/recipes-core/meta/wic-tools.bb
> > @@ -4,7 +4,7 @@ LICENSE = "MIT"
> >
> >  DEPENDS = "\
> >             parted-native gptfdisk-native dosfstools-native \
> > -           mtools-native bmap-tools-native grub-native cdrtools-native \
> > +           mtools-native bmaptool-native grub-native cdrtools-native \
> >             btrfs-tools-native squashfs-tools-native pseudo-native \
> >             e2fsprogs-native util-linux-native tar-native erofs-utils-native \
> >             virtual/${TARGET_PREFIX}binutils \
> > diff --git a/scripts/lib/wic/misc.py b/scripts/lib/wic/misc.py
> > index 2b90821b305..1a7c140fa6c 100644
> > --- a/scripts/lib/wic/misc.py
> > +++ b/scripts/lib/wic/misc.py
> > @@ -25,7 +25,7 @@ from wic import WicError
> >  logger = logging.getLogger('wic')
> >
> >  # executable -> recipe pairs for exec_native_cmd
> > -NATIVE_RECIPES = {"bmaptool": "bmap-tools",
> > +NATIVE_RECIPES = {"bmaptool": "bmaptool",
> >                    "dumpe2fs": "e2fsprogs",
> >                    "grub-mkimage": "grub-efi",
> >                    "isohybrid": "syslinux",
> >
> > but I'll squash that into the patch.
>
> Great, thanks!
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#196631): https://lists.openembedded.org/g/openembedded-core/message/196631
> Mute This Topic: https://lists.openembedded.org/mt/104729497/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/classes-recipe/image_types.bbclass b/meta/classes-recipe/image_types.bbclass
index 3733bdfc20c6..4ad13b43677a 100644
--- a/meta/classes-recipe/image_types.bbclass
+++ b/meta/classes-recipe/image_types.bbclass
@@ -363,7 +363,7 @@  CONVERSION_DEPENDS_zip = "zip-native"
 CONVERSION_DEPENDS_7zip = "p7zip-native"
 CONVERSION_DEPENDS_zst = "zstd-native"
 CONVERSION_DEPENDS_sum = "mtd-utils-native"
-CONVERSION_DEPENDS_bmap = "bmap-tools-native"
+CONVERSION_DEPENDS_bmap = "bmaptool-native"
 CONVERSION_DEPENDS_u-boot = "u-boot-tools-native"
 CONVERSION_DEPENDS_vmdk = "qemu-system-native"
 CONVERSION_DEPENDS_vdi = "qemu-system-native"
diff --git a/meta/classes-recipe/image_types_wic.bbclass b/meta/classes-recipe/image_types_wic.bbclass
index ce7125f6f18f..cf3be909b30c 100644
--- a/meta/classes-recipe/image_types_wic.bbclass
+++ b/meta/classes-recipe/image_types_wic.bbclass
@@ -106,7 +106,7 @@  do_image_wic[recrdeptask] += "do_deploy"
 do_image_wic[deptask] += "do_image_complete"
 
 WKS_FILE_DEPENDS_DEFAULT = '${@bb.utils.contains_any("BUILD_ARCH", [ 'x86_64', 'i686' ], "syslinux-native", "",d)}'
-WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native erofs-utils-native"
+WKS_FILE_DEPENDS_DEFAULT += "bmaptool-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native erofs-utils-native"
 # Unified kernel images need objcopy
 WKS_FILE_DEPENDS_DEFAULT += "virtual/${TARGET_PREFIX}binutils"
 WKS_FILE_DEPENDS_BOOTLOADERS = ""
diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index 7e17e9b71fa0..a3433f496cb4 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -70,7 +70,7 @@  RECIPE_MAINTAINER:pn-bison = "Chen Qi <Qi.Chen@windriver.com>"
 RECIPE_MAINTAINER:pn-blktool = "Yi Zhao <yi.zhao@windriver.com>"
 RECIPE_MAINTAINER:pn-blktrace = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER:pn-bluez5 = "Anuj Mittal <anuj.mittal@intel.com>"
-RECIPE_MAINTAINER:pn-bmap-tools = "Anuj Mittal <anuj.mittal@intel.com>"
+RECIPE_MAINTAINER:pn-bmaptool = "Trevor Woerner <twoerner@gmail.com>"
 RECIPE_MAINTAINER:pn-boost = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER:pn-boost-build-native = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER:pn-bootchart2 = "Alexander Kanavin <alex.kanavin@gmail.com>"
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_git.bb b/meta/recipes-support/bmaptool/bmaptool_git.bb
similarity index 78%
rename from meta/recipes-support/bmap-tools/bmap-tools_git.bb
rename to meta/recipes-support/bmaptool/bmaptool_git.bb
index ffb6ccfe99a5..87328af8c65b 100644
--- a/meta/recipes-support/bmap-tools/bmap-tools_git.bb
+++ b/meta/recipes-support/bmaptool/bmaptool_git.bb
@@ -1,16 +1,16 @@ 
 SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
-DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
-bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
+DESCRIPTION = "bmaptool - tools to generate block map (AKA bmap) and flash images using \
+bmap. bmaptool is a generic tool for creating the block map (bmap) for a file, \
 and copying files using the block map. The idea is that large file containing \
 unused blocks, like raw system image files, can be copied or flashed a lot \
 faster with bmaptool than with traditional tools like "dd" or "cp"."
-HOMEPAGE = "https://github.com/01org/bmap-tools"
+HOMEPAGE = "https://github.com/yoctoproject/bmaptool"
 SECTION = "console/utils"
 LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI = "git://github.com/intel/${BPN};branch=main;protocol=https \
+SRC_URI = "git://github.com/yoctoproject/${BPN};branch=main;protocol=https \
 	file://0001-BmapCopy.py-fix-error-message.patch \
 	file://0002-CLI.py-fix-block-device-udev-race-condition.patch \
 	file://0003-BmapCopy.py-tweak-suggested-udev-rule.patch \
diff --git a/meta/recipes-support/bmap-tools/files/0001-BmapCopy.py-fix-error-message.patch b/meta/recipes-support/bmaptool/files/0001-BmapCopy.py-fix-error-message.patch
similarity index 100%
rename from meta/recipes-support/bmap-tools/files/0001-BmapCopy.py-fix-error-message.patch
rename to meta/recipes-support/bmaptool/files/0001-BmapCopy.py-fix-error-message.patch
diff --git a/meta/recipes-support/bmap-tools/files/0002-CLI.py-fix-block-device-udev-race-condition.patch b/meta/recipes-support/bmaptool/files/0002-CLI.py-fix-block-device-udev-race-condition.patch
similarity index 100%
rename from meta/recipes-support/bmap-tools/files/0002-CLI.py-fix-block-device-udev-race-condition.patch
rename to meta/recipes-support/bmaptool/files/0002-CLI.py-fix-block-device-udev-race-condition.patch
diff --git a/meta/recipes-support/bmap-tools/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch b/meta/recipes-support/bmaptool/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch
similarity index 100%
rename from meta/recipes-support/bmap-tools/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch
rename to meta/recipes-support/bmaptool/files/0003-BmapCopy.py-tweak-suggested-udev-rule.patch