diff mbox series

[meta-python,28/60] python3-pyroute2: switch to pytest --automake

Message ID 9bad15ac1b99a3c47cf99d426ebaff4e05cc324f.1708127759.git.tim.orling@konsulko.com
State Accepted
Headers show
Series [meta-python,01/60] python3-uritemplate: switch to pytest --automake | expand

Commit Message

Tim Orling Feb. 17, 2024, 12:15 a.m. UTC
* Sort RDEPENDS for ptest alphabetically

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta-python/recipes-devtools/python/python3-pyroute2/run-ptest | 2 +-
 meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
index ea429ba21e..f1c8729f0e 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyroute2/run-ptest
@@ -1,4 +1,4 @@ 
 #!/bin/sh
 
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
 
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb
index 6b340a18ce..740a6d7f73 100644
--- a/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.7.10.bb
@@ -27,9 +27,10 @@  SRC_URI += " \
 "
 
 RDEPENDS:${PN}-ptest += " \
-    python3-pytest \
     python3-fcntl \
+    python3-pytest \
     python3-sqlite3 \
+    python3-unittest-automake-output \
 "
 
 do_install_ptest() {