diff mbox series

[meta-python,PATCHv2] python3-scikit-build: upgrade 0.16.7 -> 0.17.6

Message ID 20240204105344.28531-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python,PATCHv2] python3-scikit-build: upgrade 0.16.7 -> 0.17.6 | expand

Commit Message

Alper Ak Feb. 4, 2024, 10:53 a.m. UTC
Moved to hatchling as a build backend and requires hatch-fancy-pypi-readme, hatch-vcs.

As stated in the upstream, the license updated to MIT only.

Changelog: https://github.com/scikit-build/scikit-build/releases

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 Unlike v1, tomli has been removed from RDEPENDS because since Python 3.11+ has built in tomllib.

 .../python/python3-scikit-build_0.16.7.bb     | 21 ------------------
 .../python/python3-scikit-build_0.17.6.bb     | 22 +++++++++++++++++++
 2 files changed, 22 insertions(+), 21 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb b/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
deleted file mode 100644
index c033c56ba..000000000
--- a/meta-python/recipes-devtools/python/python3-scikit-build_0.16.7.bb
+++ /dev/null
@@ -1,21 +0,0 @@ 
-SUMMARY = "Improved build system generator for Python C/C++/Fortran/Cython extensions"
-LICENSE = "MIT & BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
-
-DEPENDS = "python3-setuptools-scm-native"
-
-PYPI_PACKAGE = "scikit-build"
-
-inherit pypi python_setuptools_build_meta
-SRC_URI[sha256sum] = "a9b9cc7479b71e6c8d434596dfade025253aae23adb22a9a2d85850fd51cecfd"
-
-RDEPENDS:${PN} = " \
-	python3-distro \
-	python3-packaging \
-	python3-setuptools \
-	python3-typing-extensions \
-	python3-wheel \
-	cmake \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb b/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
new file mode 100644
index 000000000..7f99dd16b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-scikit-build_0.17.6.bb
@@ -0,0 +1,22 @@ 
+SUMMARY = "Improved build system generator for Python C/C++/Fortran/Cython extensions"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7c96d2b08b3cec6d3c67fb864d1fd8cc"
+
+DEPENDS = "${PYTHON_PN}-hatch-vcs-native ${PYTHON_PN}-hatch-fancy-pypi-readme-native"
+
+PYPI_PACKAGE = "scikit_build"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "b51a51a36b37c42650994b5047912f59b22e3210b23e321f287611f9ef6e5c9d"
+
+RDEPENDS:${PN} = " \
+	${PYTHON_PN}-distro \
+	${PYTHON_PN}-packaging \
+	${PYTHON_PN}-setuptools \
+	${PYTHON_PN}-typing-extensions \
+	${PYTHON_PN}-wheel \
+	cmake \
+"
+
+BBCLASSEXTEND = "native nativesdk"