diff mbox series

tcl: Fix prepending to run-ptest script

Message ID 20240109232912.2557227-1-raj.khem@gmail.com
State Accepted, archived
Commit 7bb45591f9caa7ff6b065220927a26e8261e2866
Headers show
Series tcl: Fix prepending to run-ptest script | expand

Commit Message

Khem Raj Jan. 9, 2024, 11:29 p.m. UTC
This ensures that string is prepended properly and eclosed in ''
Fixes the ptest runs on musl

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/tcltk/tcl_8.6.13.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.13.bb b/meta/recipes-devtools/tcltk/tcl_8.6.13.bb
index b33a78e147f..bb75353a5a8 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.13.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.13.bb
@@ -88,7 +88,7 @@  do_install_ptest() {
 
 do_install_ptest:append:libc-musl () {
 	# Assumes locales other than provided by musl-locales
-	sed -i -e 's|SKIPPED_TESTS=|SKIPPED_TESTS="unixInit-3*"|' ${D}${PTEST_PATH}/run-ptest
+	sed -i -e "s|SKIPPED_TESTS='|SKIPPED_TESTS='unixInit-3* |" ${D}${PTEST_PATH}/run-ptest
 }
 
 # Fix some paths that might be used by Tcl extensions