diff mbox series

[meta-oe] driverctl: upgrade 0.111 -> 0.115

Message ID 20231222065506.1326249-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] driverctl: upgrade 0.111 -> 0.115 | expand

Commit Message

Alper Ak Dec. 22, 2023, 6:55 a.m. UTC
Changelog:

* driverctl: Fix duplicate ID write error
* driverctl: add list-persisted command
* Fix device driver binding issue after re-enumeration
* driverctl: fix list_devices() when `driver_override` is not set

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../driverctl/driverctl_0.111.bb              | 28 -------------------
 .../driverctl/driverctl_0.115.bb              | 23 +++++++++++++++
 2 files changed, 23 insertions(+), 28 deletions(-)
 delete mode 100644 meta-oe/recipes-support/driverctl/driverctl_0.111.bb
 create mode 100644 meta-oe/recipes-support/driverctl/driverctl_0.115.bb

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Fri, 22 Dec 2023 09:55:06 +0300, alperak wrote:
> Changelog:
> 
> * driverctl: Fix duplicate ID write error
> * driverctl: add list-persisted command
> * Fix device driver binding issue after re-enumeration
> * driverctl: fix list_devices() when `driver_override` is not set
> 
> [...]

Applied, thanks!

[1/1] driverctl: upgrade 0.111 -> 0.115
      commit: 1f2c2ebcbcf5944225462f530e0d56b20f1b4630

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/driverctl/driverctl_0.111.bb b/meta-oe/recipes-support/driverctl/driverctl_0.111.bb
deleted file mode 100644
index f5f542c54..000000000
--- a/meta-oe/recipes-support/driverctl/driverctl_0.111.bb
+++ /dev/null
@@ -1,28 +0,0 @@ 
-SUMMARY = "driverctl is a device driver control utility for Linux"
-LICENSE = "LGPL-2.1-only"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1-only;md5=1a6d268fd218675ffea8be556788b780"
-
-REQUIRED_DISTRO_FEATURES = "systemd"
-
-DEPENDS = "systemd"
-RDEPENDS:${PN} += "bash bash-completion"
-
-SRC_URI = " git://gitlab.com/driverctl/driverctl.git;branch=master"
-SRCREV = "fa9dce43d1a667d6e6e26895fbed01b3b04362c9"
-
-S = "${WORKDIR}/git"
-
-inherit pkgconfig systemd features_check
-
-FILES:${PN} += "${libdir}"
-FILES:${PN} += "${libdir}/udev"
-FILES:${PN} += "${libdir}/udev/rules.d"
-FILES:${PN} += "${systemd_unitdir}"
-FILES:${PN} += "${systemd_unitdir}/system"
-FILES:${PN} += "${datadir}"
-FILES:${PN} += "${datadir}/bash-completion"
-FILES:${PN} += "${datadir}/bash-completion/completions"
-
-do_install () {
-	oe_runmake install DESTDIR=${D}
-}
diff --git a/meta-oe/recipes-support/driverctl/driverctl_0.115.bb b/meta-oe/recipes-support/driverctl/driverctl_0.115.bb
new file mode 100644
index 000000000..d37563eda
--- /dev/null
+++ b/meta-oe/recipes-support/driverctl/driverctl_0.115.bb
@@ -0,0 +1,23 @@ 
+SUMMARY = "driverctl is a device driver control utility for Linux"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+DEPENDS = "systemd"
+RDEPENDS:${PN} += "bash bash-completion"
+
+SRC_URI = "git://gitlab.com/driverctl/driverctl.git;branch=master;protocol=https"
+SRCREV = "2ba60536eb20ca0a6a751bd8b6501dba84ec45d3"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig systemd features_check
+
+do_install () {
+	oe_runmake install DESTDIR=${D}
+}
+
+FILES:${PN} += "${libdir}"
+FILES:${PN} += "${datadir}"
+