diff mbox series

[meta-python] python3-flask: fix upstream uri and version check

Message ID 20231221181237.3904447-1-derek@asterius.io
State Accepted
Headers show
Series [meta-python] python3-flask: fix upstream uri and version check | expand

Commit Message

Derek Straka Dec. 21, 2023, 6:12 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 meta-python/recipes-devtools/python/python3-flask_2.3.3.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Thu, 21 Dec 2023 18:12:37 +0000, Derek Straka wrote:
> 


Applied, thanks!

[1/1] python3-flask: fix upstream uri and version check
      commit: 075497ce2d71cf63e47f0faa6c76bde8b7dc8f85

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask_2.3.3.bb b/meta-python/recipes-devtools/python/python3-flask_2.3.3.bb
index c8c8d870a..99a61f136 100644
--- a/meta-python/recipes-devtools/python/python3-flask_2.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_2.3.3.bb
@@ -8,6 +8,9 @@  LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
 
 SRC_URI[sha256sum] = "09c347a92aa7ff4a8e7f3206795f30d826654baf38b873d0744cd571ca609efc"
 
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask"
+UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)"
+
 inherit pypi python_setuptools_build_meta
 
 CLEANBROKEN = "1"