diff mbox series

python3-pip: upgrade 23.3.1 -> 23.3.2

Message ID 1702979907-8398-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 51bd305c023b64ae5f6972bb489916861d11477f
Headers show
Series python3-pip: upgrade 23.3.1 -> 23.3.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 19, 2023, 9:58 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

no_shebang_mangling.patch
refreshed for 23.3.2

Changelog:
==========
-Fix a bug in extras handling for link requirements
-Fix mercurial revision "parse error": use --rev={ref} instead of -r={ref}

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python3-pip/no_shebang_mangling.patch     | 21 +++++++++++++------
 ...n3-pip_23.3.1.bb => python3-pip_23.3.2.bb} |  2 +-
 2 files changed, 16 insertions(+), 7 deletions(-)
 rename meta/recipes-devtools/python/{python3-pip_23.3.1.bb => python3-pip_23.3.2.bb} (97%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch b/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch
index 920e22bc02..b59f4888da 100644
--- a/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch
+++ b/meta/recipes-devtools/python/python3-pip/no_shebang_mangling.patch
@@ -1,14 +1,23 @@ 
+From 915bf32cd117cd86cc0d4b96bc9490b1c7119ffd Mon Sep 17 00:00:00 2001
+From: Richard Purdie <richard.purdie@linuxfoundation.org>
+Date: Wed, 23 Feb 2022 12:27:06 +0000
+Subject: [PATCH] python3-pip: Don't change shebang
+
 Patch pip to disable shebang mangling and also force the python executable
 to be python3 from the environment when building anything for the target
 (or nativesdk). This avoids incorrect interpreter paths in the target scripts.
 
 Upstream-Status: Inappropriate [OE specific config]
 
-Index: pip-22.0.3/src/pip/_vendor/distlib/scripts.py
-===================================================================
---- pip-22.0.3.orig/src/pip/_vendor/distlib/scripts.py
-+++ pip-22.0.3/src/pip/_vendor/distlib/scripts.py
-@@ -135,6 +135,8 @@ class ScriptMaker(object):
+---
+ src/pip/_vendor/distlib/scripts.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/pip/_vendor/distlib/scripts.py b/src/pip/_vendor/distlib/scripts.py
+index d270624..42c0d10 100644
+--- a/src/pip/_vendor/distlib/scripts.py
++++ b/src/pip/_vendor/distlib/scripts.py
+@@ -137,6 +137,8 @@ class ScriptMaker(object):
          See also: http://www.in-ulm.de/~mascheck/various/shebang/#length
                    https://hg.mozilla.org/mozilla-central/file/tip/mach
          """
@@ -17,7 +26,7 @@  Index: pip-22.0.3/src/pip/_vendor/distlib/scripts.py
          if os.name != 'posix':
              simple_shebang = True
          else:
-@@ -340,7 +342,7 @@ class ScriptMaker(object):
+@@ -348,7 +350,7 @@ class ScriptMaker(object):
                  return
  
              match = FIRST_LINE_RE.match(first_line.replace(b'\r\n', b'\n'))
diff --git a/meta/recipes-devtools/python/python3-pip_23.3.1.bb b/meta/recipes-devtools/python/python3-pip_23.3.2.bb
similarity index 97%
rename from meta/recipes-devtools/python/python3-pip_23.3.1.bb
rename to meta/recipes-devtools/python/python3-pip_23.3.2.bb
index 3699bdf515..475cc12984 100644
--- a/meta/recipes-devtools/python/python3-pip_23.3.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_23.3.2.bb
@@ -33,7 +33,7 @@  inherit pypi python_setuptools_build_meta
 
 SRC_URI += "file://no_shebang_mangling.patch"
 
-SRC_URI[sha256sum] = "1fcaa041308d01f14575f6d0d2ea4b75a3e2871fe4f9c694976f908768e14174"
+SRC_URI[sha256sum] = "7fd9972f96db22c8077a1ee2691b172c8089b17a5652a44494a9ecb0d78f9149"
 
 do_install:append() {
     rm -f ${D}/${bindir}/pip