diff mbox series

[17/20] gstd: correctly delete files in do_install

Message ID 20231215075239.3049865-17-alex@linutronix.de
State Accepted, archived
Headers show
Series [01/20] python3-pyinotify: remove as unmaintained | expand

Commit Message

Alexander Kanavin Dec. 15, 2023, 7:52 a.m. UTC
gstd always installs these in /usr, so root_prefix would
work only if usrmerge is in DISTRO_FEATURES.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../recipes-multimedia/gstreamer-1.0/gstd_git.bb            | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
index cabbf2cc1..87792491a 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
@@ -20,9 +20,9 @@  GTKDOC_MESON_OPTION = "enable-gtk-doc"
 inherit meson pkgconfig gettext gtk-doc python3native python3-dir python3targetconfig
 
 do_install:append() {
-        rmdir ${D}${root_prefix}${localstatedir}/run/${BPN} ${D}${root_prefix}${localstatedir}/run \
-              ${D}${root_prefix}${localstatedir}/log/${BPN} ${D}${root_prefix}${localstatedir}/log \
-              ${D}${root_prefix}${localstatedir}
+        rmdir ${D}${exec_prefix}${localstatedir}/run/${BPN} ${D}${exec_prefix}${localstatedir}/run \
+              ${D}${exec_prefix}${localstatedir}/log/${BPN} ${D}${exec_prefix}${localstatedir}/log \
+              ${D}${exec_prefix}${localstatedir}
         rm -f ${D}${bindir}/gst-client ${D}${bindir}/gstd-client
         if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
                 install -d ${D}${sysconfdir}/tmpfiles.d