diff mbox series

[meta-python] python3-pint: upgrade 0.22 -> 0.23

Message ID 1702544387-28194-1-git-send-email-wangmy@fujitsu.com
State Superseded
Headers show
Series [meta-python] python3-pint: upgrade 0.22 -> 0.23 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 14, 2023, 8:59 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
- Add _get_conversion_factor to registry with cache.
- Homogenize input and ouput of internal regitry functions to
  facility typing, subclassing and wrapping.
- Generated downstream_status page to track the state of downstream projects.
- Improve typing annotation.
- Updated to flexparser 0.2.
- Faster wraps
- Add codspeed github action.
- Move benchmarks to pytest-benchmarks.
- Support pytest on python 3.12 wrt Fraction formatting change
- Fixed Transformation type protocol.
- Documented to_preferred and created added an autoautoconvert_to_preferred
  registry option.
- Enable Pint to parse uncertainty numbers.
- Optimize matplotlib unit conversion for Quantity arrays
- Add numpy.linalg.norm implementation.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pint_0.22.bb => python3-pint_0.23.bb}       | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pint_0.22.bb => python3-pint_0.23.bb} (88%)

Comments

Khem Raj Dec. 14, 2023, 5:42 p.m. UTC | #1
duplicate of https://patchwork.yoctoproject.org/project/oe/patch/20231214002735.1137483-1-derek@asterius.io/

On Thu, Dec 14, 2023 at 1:00 AM wangmy <wangmy@fujitsu.com> wrote:
>
> From: Wang Mingyu <wangmy@fujitsu.com>
>
> Changelog:
> ===========
> - Add _get_conversion_factor to registry with cache.
> - Homogenize input and ouput of internal regitry functions to
>   facility typing, subclassing and wrapping.
> - Generated downstream_status page to track the state of downstream projects.
> - Improve typing annotation.
> - Updated to flexparser 0.2.
> - Faster wraps
> - Add codspeed github action.
> - Move benchmarks to pytest-benchmarks.
> - Support pytest on python 3.12 wrt Fraction formatting change
> - Fixed Transformation type protocol.
> - Documented to_preferred and created added an autoautoconvert_to_preferred
>   registry option.
> - Enable Pint to parse uncertainty numbers.
> - Optimize matplotlib unit conversion for Quantity arrays
> - Add numpy.linalg.norm implementation.
>
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../python/{python3-pint_0.22.bb => python3-pint_0.23.bb}       | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>  rename meta-python/recipes-devtools/python/{python3-pint_0.22.bb => python3-pint_0.23.bb} (88%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pint_0.22.bb b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
> similarity index 88%
> rename from meta-python/recipes-devtools/python/python3-pint_0.22.bb
> rename to meta-python/recipes-devtools/python/python3-pint_0.23.bb
> index 0eed33f79..82709ea08 100644
> --- a/meta-python/recipes-devtools/python/python3-pint_0.22.bb
> +++ b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
> @@ -10,7 +10,7 @@ PYPI_PACKAGE := "Pint"
>
>  inherit pypi ptest python_setuptools_build_meta
>
> -SRC_URI[sha256sum] = "2d139f6abbcf3016cad7d3cec05707fe908ac4f99cf59aedfd6ee667b7a64433"
> +SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
>
>  DEPENDS += "python3-setuptools-scm-native"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107442): https://lists.openembedded.org/g/openembedded-devel/message/107442
> Mute This Topic: https://lists.openembedded.org/mt/103166860/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pint_0.22.bb b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
similarity index 88%
rename from meta-python/recipes-devtools/python/python3-pint_0.22.bb
rename to meta-python/recipes-devtools/python/python3-pint_0.23.bb
index 0eed33f79..82709ea08 100644
--- a/meta-python/recipes-devtools/python/python3-pint_0.22.bb
+++ b/meta-python/recipes-devtools/python/python3-pint_0.23.bb
@@ -10,7 +10,7 @@  PYPI_PACKAGE := "Pint"
 
 inherit pypi ptest python_setuptools_build_meta
 
-SRC_URI[sha256sum] = "2d139f6abbcf3016cad7d3cec05707fe908ac4f99cf59aedfd6ee667b7a64433"
+SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
 
 DEPENDS += "python3-setuptools-scm-native"